<!doctype html>

<!--[if lt IE 7]> <html class="no-js ie ie6 lt-ie10 lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie ie7 lt-ie10 lt-ie9 lt-ie8" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie ie8 lt-ie10 lt-ie9" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="no-js ie ie9 lt-ie10" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html class="no-js" lang="en"> <!--<![endif]-->

<head>

	<meta charset="utf-8">

	<link rel="alternate" type="application/rss+xml" title="A List Apart: The Full Feed" href="/main/feed" />

	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="shortcut icon" href="/components/assets/img/favicons/favicon.ico" type="image/x-icon" />
	<link rel="apple-touch-icon" href="/components/assets/img/favicons/apple-touch-icon.png" />
	<link rel="apple-touch-icon" sizes="57x57" href="/components/assets/img/favicons/apple-touch-icon-57x57.png" />
	<link rel="apple-touch-icon" sizes="72x72" href="/components/assets/img/favicons/apple-touch-icon-72x72.png" />
	<link rel="apple-touch-icon" sizes="76x76" href="/components/assets/img/favicons/apple-touch-icon-76x76.png" />
	<link rel="apple-touch-icon" sizes="114x114" href="/components/assets/img/favicons/apple-touch-icon-114x114.png" />
	<link rel="apple-touch-icon" sizes="120x120" href="/components/assets/img/favicons/apple-touch-icon-120x120.png" />
	<link rel="apple-touch-icon" sizes="144x144" href="/components/assets/img/favicons/apple-touch-icon-144x144.png" />
	<link rel="apple-touch-icon" sizes="152x152" href="/components/assets/img/favicons/apple-touch-icon-152x152.png" />

	<meta name="application-name" content="A List Apart"/>
	<meta name="msapplication-TileColor" content="#222222"/>
	<meta name="msapplication-TileImage" content="/components/assets/img/favicons/windows-8-tile.png"/>

	<link href="https://plus.google.com/+alistapart/" rel="publisher" />

	<meta http-equiv="imagetoolbar" content="false" />

	<link rel="stylesheet" href="http://alistapart.com/d/_cache/60752e87345432991e7cd6b53c5d61e28e94f37f.1484567694.css" />

	<script src="/components/assets/js/libs/modernizr-custom.js"></script>
	<script src="/components/assets/js/libs/jquery-3.0.0.min.js"></script>
	<script src="/components/assets/js/libs/jquery-migrate-1.4.1.min.js"></script>





	<title>I Don’t Need Help · An A List Apart Article</title>

	<link rel="alternate" type="application/rss+xml" title="A feed for comments on this article" href="/comments/feed/i-dont-need-help" />

	
	<style>
	 {
		border: 1px solid rgba(0,0,0,.4) !important;
	}
	
	 {
		/*box-shadow: inset 0 0 18px -8px rgba(255,161,161,.9);*/
		content: url(/components/assets/img/laurel-white-2.svg) !important;
		padding-top: 3px !important;
		height: 23px !important;
	}
	</style>

	

	<link rel="canonical" href="http://alistapart.com/article/i-dont-need-help"/>

	<meta name="description" content="Just because your users don&#8217;t ask for help doesn&#8217;t mean they don&#8217;t need it." class="entry-summary">
	<meta name="author" content="">

	<meta name="twitter:card" content="summary">
	<meta name="twitter:site" content="@alistapart">
	<meta name="twitter:title" content="I Don’t Need Help">
	<meta name="twitter:description" content="Just because your users don&#8217;t ask for help doesn&#8217;t mean they don&#8217;t need it.">
	<meta name="twitter:url" content="http://alistapart.com/article/i-dont-need-help">

	<meta property="og:title" content="I Don’t Need Help" />
	<meta property="og:description" content="Just because your users don&#8217;t ask for help doesn&#8217;t mean they don&#8217;t need it." />
	<meta property="og:url" content="http://alistapart.com/article/i-dont-need-help" />
	<meta property="og:image" content="" />

</head>

<body class="printable " itemscope itemtype="http://schema.org/Article">
<link itemprop="mainEntityOfPage" href="http://alistapart.com/article/i-dont-need-help" />
	<header class="logo-holder">

		<h1 name="top" class="killer-logo" itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><a href="http://alistapart.com" title="A List Apart home page" tabindex="-1" itemprop="url"><span itemprop="logo" itemscope itemtype="http://schema.org/ImageObject"><img itemprop="url" src="http://alistapart.com/components/assets/img/ala-logo-big.png" alt="A List Apart"></span></a><span class="screen-reader" itemprop="name">A List Apart</span></h1>

	</header>



	<a class="go-to-nav" href="#main-nav" title="skip to nav">Menu</a>

	<nav class="global-nav" id="main-nav" role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">

		<ul class="inline-items">
			<li><a href="/" title="Home" itemprop="url"><span itemprop="name">Home</span></a></li>
			
			<li class="active"><a href="/articles" itemprop="url"><span itemprop="name">Articles</span></a></li>
			<li ><a href="/events" itemprop="url"><span itemprop="name">Events</span></a></li>
			<li ><a href="/topics" itemprop="url"><span itemprop="name">Topics</span></a></li>
			<li ><a href="/about/contribute" itemprop="url"><span itemprop="name">Write for us</span></a></li>
			<li class="back-to-top"><a href="#top">Back to top</a></li>
			<li class="head-east-young-man">
				<form id="main-search" class="main-search" data-action="/search" action="http://www.google.com/search" method="GET">
					<input type="hidden" name="sitesearch" value="alistapart.com" />
					<label for="search-keywords"><input id="search-keywords" type="search" data-name="keywards" name="q" placeholder="Search" aria-label="Search" value="" required="required"></label>
					<input id="submit-search" name="submit" type="image" src="/components/assets/img/icon_magnify_v.svg" data-fallback="/components/assets/img/icon_magnify_v.png" alt="Submit">
				</form>
			</li>
		</ul>

	</nav>


	


	<div role="main" class="main-wrapper">

		<article class="article-layout hentry">

			<header class="entry-header">

				 

				

				<h1 class="entry-title" itemprop="headline">I Don’t Need Help</h1>

				<p class="entry-details">
					<meta itemprop="description" content="Just because your users don't ask for help doesn't mean they don't need it."/>

					<span itemprop="author" itemscope itemtype="http://schema.org/Person">by <a itemprop="sameAs" class="author" rel="author" href="/author/neha-singh"><span itemprop="name">Neha Singh</span></a></span>

					<time class="pubdate updated" datetime="2017-02-07T11:00:00-05:00" itemprop="datePublished">February 07, 2017</time>
					<meta itemprop="dateModified" content="2017-02-07T10:57:13-05:00">

					<span class="entry-meta optional-break">

						Published in <a href="/topic/design"><span itemprop="about">Design</span></a>, <a href="/topic/user-experience"><span itemprop="about">User Experience</span></a>


					</span>
				</p>

				 

			</header>

			 

			

			

			<div class="main-content" itemprop="articleBody">

			

			

			

				<p>We have no excuse&#8230;admit it. UX may brag about intuitive and pretty, but we sure suck at helping people—this one thing that most defines, most embodies great user experience.</p>


				<div class="aside-breaker"><b>Article Continues Below</b></div>

				<aside class="content-minutiae">
					
                  <a href="#comments" class="comment-bubble comment-bubble-articles">
                     <span>no comments yet</span>
                  </a>

					


                  <div class="minutiae-block share-block">
                     <h1 class="propagation-enablers" aria-hidden="true">Share this on</h1>
                     <ul class="propagation-enablers">
                        <li class="circle-twitter"><a href="http://twitter.com/intent/tweet?url=http://alistapart.com/article/i-dont-need-help&text=I+Don%E2%80%99t+Need+Help&via=alistapart" data-trackevent="Share: Twitter" title="share this on Twitter"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="0 0 274 224" enable-background="new 0 0 274 224" xml:space="preserve">
                        <path d="M273.7,27.2c-10.1,4.5-20.9,7.5-32.2,8.8c11.6-6.9,20.5-17.9,24.7-31c-10.8,6.4-22.8,11.1-35.6,13.6
                           C220.3,7.7,205.7,0.9,189.6,0.9c-31,0-56.1,25.1-56.1,56.1c0,4.4,0.5,8.7,1.5,12.8C88.3,67.4,47,45.1,19.3,11.2
                           c-4.8,8.3-7.6,17.9-7.6,28.2c0,19.5,9.9,36.6,25,46.7c-9.2-0.3-17.8-2.8-25.4-7c0,0.2,0,0.5,0,0.7c0,27.2,19.3,49.8,45,55
                           c-4.7,1.3-9.7,2-14.8,2c-3.6,0-7.1-0.4-10.6-1c7.1,22.3,27.9,38.5,52.4,39c-19.2,15-43.4,24-69.7,24c-4.5,0-9-0.3-13.4-0.8
                           c24.8,15.9,54.3,25.2,86,25.2c103.2,0,159.6-85.5,159.6-159.6c0-2.4-0.1-4.9-0.2-7.3C256.7,48.3,266.2,38.5,273.7,27.2z"/>
                        </svg></a></li><!--
                        --><li class="circle-facebook"><a href="http://www.facebook.com/sharer.php?u=http://alistapart.com/article/i-dont-need-help&t=I+Don%E2%80%99t+Need+Help" data-trackevent="Share: Facebook" title="share this on Facebook"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-95.6 286.6 114 220" enable-background="new -95.6 286.6 114 220" xml:space="preserve">
                        <path id="f" d="M-21.6,505.9v-99.8h33.5l5-38.9h-38.5v-24.8c0-11.3,3.1-18.9,19.3-18.9l20.6,0v-34.8
                           c-3.6-0.5-15.8-1.5-30-1.5c-29.7,0-50,18.1-50,51.4v28.7h-33.6v38.9h33.6v99.8H-21.6z"/>
                        </svg></a></li><!--
                        --><li class="circle-google"><a href="https://plus.google.com/share?url=http://alistapart.com/article/i-dont-need-help" data-trackevent="Share: Google+" title="share this on Google+"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-212.7 354.2 84 86" enable-background="new -212.7 354.2 84 86" xml:space="preserve">
                        <g>
                           <g>
                              <path d="M-168.4,403.2l-4-3.1c-1.2-1-2.9-2.3-2.9-4.8c0-2.4,1.7-4,3.1-5.4c4.6-3.7,9.3-7.5,9.3-15.7
                                 c0-8.4-5.3-12.9-7.8-15h6.8l7.2-4.5h-21.8c-6,0-14.6,1.4-20.9,6.6c-4.8,4.1-7.1,9.8-7.1,14.8c0,8.6,6.6,17.4,18.3,17.4
                                 c1.1,0,2.3-0.1,3.5-0.2c-0.5,1.3-1.1,2.4-1.1,4.3c0,3.4,1.8,5.5,3.3,7.5c-5,0.3-14.3,0.9-21.1,5.1c-6.5,3.9-8.5,9.5-8.5,13.5
                                 c0,8.2,7.7,15.8,23.8,15.8c19,0,29.1-10.5,29.1-20.9C-159.1,411.1-163.5,407.3-168.4,403.2z M-182.9,390.5
                                 c-9.5,0-13.8-12.3-13.8-19.7c0-2.9,0.5-5.9,2.4-8.2c1.8-2.2,4.9-3.7,7.7-3.7c9.2,0,13.9,12.4,13.9,20.4c0,2-0.2,5.5-2.8,8.1
                                 C-177.2,389.1-180.1,390.5-182.9,390.5z M-182.8,435c-11.8,0-19.5-5.7-19.5-13.5c0-7.9,7.1-10.5,9.5-11.4
                                 c4.6-1.6,10.6-1.8,11.6-1.8c1.1,0,1.7,0,2.5,0.1c8.4,6,12.1,9,12.1,14.6C-166.5,429.9-172.2,435-182.8,435z"/>
                              <polygon points="-140.5,390.3 -140.5,379.2 -146,379.2 -146,390.3 -157,390.3 -157,395.8 -146,395.8 -146,407
                                 -140.5,407 -140.5,395.8 -129.4,395.8 -129.4,390.3 		"/>
                           </g>
                        </g>
                        </svg></a></li>
                     </ul>
                  </div>


					 

				</aside>


			<div class="utility-side-bar">            <script src="/components/assets/js/libs/htmlParser.js"></script>
            <script src="/components/assets/js/libs/postscribe.js"></script>
            <!-- BuySellAds PRO Zone Code (Sidebar Sponsor) -->
            <div id="bsap_2374" class="bsaPROrocks bsa-tall" data-serve="CVAIC27J"></div>
            <!-- End BuySellAds PRO Zone Code -->
            <aside id="job-board-target" class="job-board ad"></aside>


</div><p>Throughout history, there’s one recurring theme: people need help. For all we know, the need for assistance might have triggered the development of communication. It could have led to bonding among tribes and our existence today. In the future, it might be the only thing that staves off human extinction and promotes societal evolution.</p>

<p>But if so, that begs the question: why do we find it so difficult to <a href="https://www.scientificamerican.com/article/asking-advice-makes-a-good-impression1/">ask for help </a> or offer guidance to one another? Do we prefer to figure things out for ourselves? Are we afraid that any request for assistance would be fraught with obligations to reciprocate? Are we worried that we&#8217;ll be rejected? Or that we might not get the help we need? </p>

<p>People do need help. It&#8217;s a given—and a problem in the field of UX. We claim to do so much for users, but treat help as an afterthought. How come it isn&#8217;t our primary consideration?</p>

<p>A glance at most websites, including those for large and small organizations, suggests that user assistance is treated as a cursory option—often relegated to a question mark symbol tacked onto a corner. The assumptions are:</p>

<ul>
<li>Users won&#8217;t need help; the design is intuitive.</li> 
<li>If users do want help, they&#8217;ll look for it (somewhere).</li>
<li>Once users figure out where to look, they&#8217;ll seek help when they need it.</li>
</ul>

<p>If the same scenario were layered on real-world interactions, it would be analogous to visiting a large museum, with maps, tours, guides, and program schedules hidden in a locker at some end far off the main entrance. </p>

<h2>Why offer help before it&#8217;s requested?</h2>

<p>Taking the guesswork out of a customer’s experience is beneficial to all involved.</p>

<p>Consider that you’re walking into a new casual diner. Initially you may wonder if everything is self-service, and if you are expected to clear your own table. You could just stare at folks around the room and make your move based on what other diners are doing. Or, the franchisee could help you get up to speed right away. Ikea solves the what-do-I-do problem with a “Why should I clear my own table?” sign right at the center of its popular store restaurant. The sign solves two problems—it gives the customer needed information immediately and it promotes Ikea’s aim to cut costs. </p>

<p>Designers create user interfaces through careful planning, so one popular conclusion is that if a design has been a success, no explanation—no prominent sign—is required.</p>

<p>But help is often sought or needed for a variety of reasons. Help could be required to explain certain fields in a form, to define the meaning of a specific icon, to parse highly technical terms, to identify new features, to illuminate hidden gestures, or to detail policies that are obtuse. </p>

<p>A user may immediately understand that a pencil icon opens an editing pop-up. If he doesn&#8217;t, he may well figure it out eventually but only after moments wasted in confusion. </p>

<p>No matter how smart a design is, unless it is customized to every user’s personality, needs, working conditions, device, domain knowledge, technical expertise, and mood, it will need some explaining. A good designer empathizes with unique concerns and takes users as they are, from practiced online mavens to casual browsers. A good design includes user assistance that is given due consideration.&nbsp; </p>

<h2>When help goes wrong</h2>

<p>Sometimes websites do make dedicated attempts to help. And sometimes those attempts smack of overkill.</p>

<p>There are video tours expertly created to take users through each feature in the product. There are slideshows with custom fonts and colorful characters that highlight everything  new and promising in the release. There are translucent overlays of clever pointers to indicate where useful action commands are located. </p>

<p><a href="https://www.nngroup.com/articles/mobile-instructional-overlay/">Analytics and studies</a> show that when presented with any of the above on launch of an application, a user either:</p>

<ol>
 <li>Rushes through it with no interest in its content, or</li>
 <li>Closes it.</li>
</ol>

<p>The main issue with providing informational assistance as the first screen is that users do not care yet. They have not seen enough of the product to want to learn about its intricacies. </p>

<p>Users want to get to the product as soon as possible; they&#8217;ve already read the marketing material, gone through the registration process, perhaps even read the “Terms and Conditions.”&nbsp; They do not want anything else to lengthen the delay. If forced to read through preliminary content or go through tours, they do so while disengaged and hence, promptly forget all they learned.</p>

<p>Some applications have book-length help manuals. Immense thought and work goes into writing and creating these documents. But they exist in a separate world, removed from the application itself, expecting the user to click away from her task at hand to read and learn. Often, they are poorly designed, making the process of finding information in the &#8220;help” website a chore. </p>

<h2>Can help intrude?</h2>

<p>Handholding, intrusive help is as frowned upon in the design world as lack of intuitiveness. Examples of this include forcing open an overlay with offers of help while the user is engaged in a task; loading screens full of product descriptions without context; or launching a product tour that must be completed before the user can access the product. This is where the need to understand the goals of the application comes in. </p>

<p>Is this an enterprise application with cloud-based storage, multiple server connections, and sensitive data transfers? In that case, help should become a visible priority. What if it&#8217;s an app built with a strong gamification approach? In that case, help can probably take a passive backseat. </p>

<p>Consider user behavior patterns while designing the help function. Some users prefer an uninterrupted reading experience—they like to dive deep into the subject matter, read every instruction, perhaps even download the content for offline reading. They rely on in-depth topic descriptions. On the other end of the spectrum, some users prefer to scan the text. They only seek help after they&#8217;ve made a mistake and will rarely go to a dedicated off-context help website. Short bites of support within the application work best for them. </p>

<p>Instructions offered in a non-intrusive manner can enhance an experience, whether real or virtual. Hiking on a trail with clear path markers, distance indicators, wildlife cautions, and plant and foliage descriptions would be safe and informative and hence, helpful. The “x minute read” tag in Medium posts, the <a href="https://blog.outbound.io/slack-kills-at-onboarding-heres-how-they-do-it">Slackbot</a> messenger in Slack, and the delineations of <a href="https://gsuite.google.com/learning-center/products/quickstart/">simple steps</a> in Google Apps Learning Center are all examples of help offered to users without distracting fanfare. </p>

<h2>How to help</h2>

<p>Simply ensuring your user assistance function is visible can be enough to provide comfort. In the same way a good interface doesn&#8217;t make users think too hard, a good help function should be easy to find and access.</p>

<p>Help can be designed to be contextual or stand-alone (a mix of both works best). </p>

<p>Contextual help is any form of <a href="http://content26.com/blog/user-experience-user-assistance-joe-welinske/">user assistance</a> that is embedded within the product’s screens. It prevents disruption from user&#8217;s immediate focus. It is concise and quick to read and access. It is available when the user requests or—even better—expects it.</p>

<p>A few examples:</p>

<ul>
<li>Tooltips that appear on hover indicating the name of an icon or button.</li>
<li>Info-tips that open after clicking an “i” or “?” next to a form or field or any part of UI worth explaining. These should have brief content that explains the purpose/meaning of the relevant element.</li>
<li>Ghost text that appears within a text field or next to the UI element to help users learn about the element.</li> 
<li>A panel that functions an an overlay within the product screen, providing users with more detailed help information.</li> 
<li>Quick &#8220;Getting Started&#8221; guides that merge with the interface and take users through the actions flow.</li>
<li>Tooltips indicating feature upgrades within the UI.</li>
<li>Hint text that demonstrates search protocols—such as suggested keywords that actually work in the application.</li>
</ul><p> </p>

<p>Stand-alone help can take a more <a href="https://basecamp.com/help/3">detailed approach</a>. </p>

<p>Designing the help center for an application is usually a challenge. Should information architecture match the application&#8217;s architecture? How will users approach the content? Would they want every action and interface element documented? If so, how should the content be structured for easy perusal? If they don&#8217;t, how do writers prioritize topics? How much is too much?</p>

<p>Effective search functionality can help save users from getting lost in content; a <a href="https://mint.lc.intuit.com/mint">prominent search box</a> makes it simple to locate the right topic before users get overwhelmed. And if the application&#8217;s search option is internet friendly, it will appeal even more to those users who prefer using a &#8220;real&#8221; search engine (like Google or Bing). </p>

<p>Documentation categorized by features or tasks allows users to filter more quickly. It is also important to identify which information warrants greater visibility—help users solve their most pressing concerns, and quickly. Customer feedback, analytics, and user research can help determine which topics your users are looking for most. </p>

<h2>The myth of technical proficiency</h2>

<p>Enterprise applications as well as consumer applications can benefit from a well thought out help system. It&#8217;s poor logic to say that an interface is designed for “technically proficient” users who therefore won&#8217;t need any help. </p>

<p>A well-designed help function is more than a set of instructions in an emergency. It is thoughtful, approachable, and considerate. It knows that no quest for assistance is too small, no needed explanation is too big. It&#8217;s time we uprooted the precedents of cumbersome or &#8220;barely there&#8221; help functions. It is time to make Help <em>helpful</em>. </p>

<p>After all, needing help is part of the human condition.</p>

<p>&nbsp;</p>

				

			

			 

				

				
				<!-- START RELATED SIDEBAR -->
				
				
				<aside id="related" class="sidebar var1 nocontent">
				<i class="widget-branding ala"></i>
				<!-- if this article does not have a follow up show recent articles by this author -->
				
				
					
							

							
							
				
				<!-- end first block -->
				
				<!-- show categories -->
				
					
	
   <section class="related-articles">



   <h1 class="primary-cat-header">
      Further reading about
      <a href="/topic/user-experience" data-trackevent="Related sidebar: Related by category">User Experience</a>
   </h1>

   <article>



<h2><a href="http://alistapart.com/article/dao-of-product-design">A Dao of Product Design</a></h2>
   <p>Encourage people to shine in their brilliance, but make sure your product also helps them avoid being petty or awful.</p><h2><a href="http://alistapart.com/article/awaken-the-champion-a-b-tester-within">Awaken the Champion A/B Tester Within</a></h2>
   <p>In A/B testing as in athletics, intuition and effort will only go so far — a champion uses advanced analysis and big data to win.</p>

   </article>

</section>
 
   


				
				
					
				
				</aside>
				<!-- END RELATED SIDEBAR -->
				

				<footer class="entry-footer nocontent">
				<h1>About the Author</h1>

				<div class="byline author vcard">

					<a class="photo" href="/author/neha-singh"><img src="/d/_made/pix/authors/photos/neha-singh-edit_120_120_c1.jpg" alt="Image of Neha Singh"></a>

					<h2><a class="fn" href="/author/neha-singh">Neha Singh</a></h2>

					<div class="author-bio">Neha Singh is a lead designer at Juniper Networks. Starting with an engineering degree and a strong interest in design, she quickly evolved into a designer with a strong interest in writing. She has been a content strategist at Yahoo!, design consultant at Apple, and UX lead at Barnes & Noble. She loves Jane Austen, astrophysics and kathak.</div>

					
						</ul>

				</div>
				
				 

				</footer>

				
<aside class="promo-box email-promo">
   <b>Get our latest articles in your inbox.</b> <a href="/email-signup" data-trackevent="Post-article: email promo">Sign up for email alerts</a>.
</aside>

			</div>

			<div class="post-article">

				<div class="column-holder unequal-columns">

					<section id="comments" class="column comment-holder">

							<h1 class="classy" itemprop="commentCount" data-url-title="i-dont-need-help">
							 
							<span>No Comments (yet)<span>
							</h1>

							
							<span id="load-comments" data-url-title="i-dont-need-help"></span>

							
								<ol class="article-comments form">

	<li id="commenter-signin" class="commenter-signin no-comments">

	<h3 class="form-heading">Got something to say?</h3>
 	
 	<div class="outer-ajax-container">
	
	 	<div class="ajax-container">
	 	
			<form id="login_form" class="sign-in-form" name="login_form" method="post" action="http://alistapart.com?ACT=159"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="159" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="eea41411894cd8448a94ef4a93b3d29e75869806" />
</div>



		
			<fieldset>

		    	<legend class="center">Sign in to add your voice to the discussion.</legend>

				<p>
					<label for="login-name-here">Email (<a id="register" class="history-nav" data-tabto="forgot-password" href="/tools/register" target="_blank">Need an account?</a>)</label>
					<input
						type="text"
						id="login-name-here"
						name="username"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your email address?"
						data-tabmaster="true"
						data-tabto="login_password"
						required>
				</p>

				<p class="password-field">
					<label for="login_password">Password (<a id="forgot-password" class="history-nav" data-tabto="comment-submit" href="/tools/forgot-password" target="_blank">Forgot?</a>)</label>
					<input
						type="password"
						id="login_password"
						name="password"
						required="required"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your password?"
						data-tabmaster="true"
						data-tabto="register"
						required>
				</p>
				
				<p class="screen-reader">
					<label for="honeepot">Don't put anything here</label>
					<input 
						type="text" 
						id="honeepot" 
						name="honeepot"
						data-tabmaster="false">
				</p>

				<p id="comment-submit-holder">
					<input 
						type="submit" 
						id="comment-submit"
						data-tabmaster="true"
						class="button primary float-left" 
						value="Submit">
				</p>

			</fieldset>
		
		
</form>
<script type="text/javascript">
$(document).ready(function(){
    $('#login_form').on('submit', function(event){
        event.preventDefault();
        if (!supports_history_api()) { return; }
        AlaAuth.spinnerStart();
           
            $.post(
                'http://alistapart.com?ACT=159',
                $('#login_form').serialize(),
                function(msg) {
                    AlaAuth.spinnerStop();
        
            if (msg.indexOf('You are now logged in.') >= 0)
            {    
           
                $.get('http://alistapart.com/ajax/comment-form/18731/article/i-dont-need-help', 
                function(ret){
                    ajaxContainer.replaceWith(ret);
                });
                AlaPostLoad.loadTranslations();
                history.pushState(
                    states.commentform, '', states.site_url + states.segments + '/' + states.commentform 
                );
              
                } else {
                    var out = /<div id="ee-errors"><ul>[\s\S]*<\/ul><\/div>/.exec(msg);
                    if ($('.error-message.none').length == $('.error-message').length) {
                        if(out === null) {
                            AlaAuth.alertMsg('This form has expired. Please refresh and try again.');
                            $.get('http://alistapart.com/ajax/comment-form/18731/article/i-dont-need-help', 
                            function(ret){
                                ajaxContainer.replaceWith(ret);
                            });
                            $('.custom-modal').remove();
                        }else {
                            AlaAuth.alertMsg(out);
                        }
                    }                   
                }
                return false;
            }
        );
        return false;
    });
});
</script>
    

		<script src="http://alistapart.com/components/assets/js/ajax-functions.js"></script>

		<script type="text/javascript">

		var states = {
			//globals
			commentsignin: 'comment-sign-in',
			register: 'register',
			password: 'forgot-password',
			commentform: 'comment-form',
			//segments
			site_url: 'http://alistapart.com',
			
			
			segments: '/article/i-dont-need-help', 
			
			tmpl_path: /ajax/,
			entry_id: '18731',
			page: 'article'
		}

		</script>

		</div>

		<div class="placeholder loader">
			<div class="top-header animated-background"></div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<!-- <div class="button primary">Submit</div> -->
		</div>

	</div>
 

	<script type="text/javascript">

	AlaAuth.loadTemplate (
		states.commentsignin
	);

	</script>
	
	</li>

</ol>
							 

					</section>

					<aside class="column more-content">

						
						<h1 class="classy">More from ALA</h1>

						<article class="item-summary article">

							<h4 class="summary-title"><a href="/article/considering-how-we-use-http2">Considering How We Use HTTP/2</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/jeremy-wagner">Jeremy Wagner</a>
							
							
							</p>

							<p>Avoid common performance issues by teaching your site how to adapt.</p>

							<footer class="byline">
								
								
   
<a href="/topic/code">Code</a>



   

								·
								<time class="pubdate updated" datetime="2017-02-02T10:00:00-05:00"><a href="article/considering-how-we-use-http2">February 02, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/using-http-2-responsibly-adapting-for-users">Using HTTP/2 Responsibly: Adapting for Users</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/jeremy-wagner">Jeremy Wagner</a>
							
							
							</p>

							<p>HTTP/2 challenges how we optimize sites for users</p>

							<footer class="byline">
								
								
   
<a href="/topic/code">Code</a>



   

								·
								<time class="pubdate updated" datetime="2017-02-02T10:00:00-05:00"><a href="article/using-http-2-responsibly-adapting-for-users">February 02, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/gaming-the-system-and-winning">Gaming the System&#8230;and Winning</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/grahamherrli">Graham Herrli</a>
							
							
							</p>

							<p>Graham Herrli thinks the gamification of websites can be fun and creative&#8230;as long as it reaches the sites&#8217; target users.</p>

							<footer class="byline">
								
								
   
<a href="/topic/design">Design</a>



   

								·
								<time class="pubdate updated" datetime="2017-01-24T10:00:00-05:00"><a href="article/gaming-the-system-and-winning">January 24, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/guerrilla-innovation">Guerrilla Innovation</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/janice-gervais">Janice Gervais</a>
							
							
							</p>

							<p>Be patient, be smart, and above all persevere. Janice Gervais guides us through guerrilla innovation in the workplace.</p>

							<footer class="byline">
								
								
   
<a href="/topic/workflow-tools">Workflow & Tools</a>



   

								·
								<time class="pubdate updated" datetime="2017-01-17T10:00:00-05:00"><a href="article/guerrilla-innovation">January 17, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/dao-of-product-design">A Dao of Product Design</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/farukates">Faruk Ateş</a>
							
							
							</p>

							<p>Encourage people to shine in their brilliance, but make sure your product also helps them avoid being petty or awful.</p>

							<footer class="byline">
								
								
   
<a href="/topic/user-experience">User Experience</a>



   

								·
								<time class="pubdate updated" datetime="2017-01-12T10:00:00-05:00"><a href="article/dao-of-product-design">January 12, 2017</a></time>
							</footer>

						</article>

					<!-- 	<div id="bsap_1032" class="bsaPROrocks ad" data-serve="C67DL2E"></div> -->

					</aside>

				</div>

			</div>

		</article>



	</div>

			<footer class="global-footer" role="navigation" aria-label="Footer" itemscope itemtype="https://schema.org/WebPage">
			<meta itemprop="headline" content="A List Apart">
			<p class="deadly-subtitle" itemprop="alternativeHeadline">For people who make websites.</p>

			<ul class="inline-items" itemscope itemtype="http://schema.org/SiteNavigationElement">
				<li><a href="/about" itemprop="url">About</a></li>
				<li><a href="/authors" itemprop="url">Authors</a></li>
				<li><a href="/about/masthead" itemprop="url">Masthead</a></li>
				<li><a href="/about/style-guide" itemprop="url">Style Guide</a></li>
				<li><a href="/contact" itemprop="url">Contact</a></li>
				<li><a href="/about/sponsor" itemprop="url">Sponsorships</a></li>
				<li class="head-east-young-man">

					Follow us:
					<a href="/about/rss">RSS</a> ·
					<a href="/email-signup/">Email</a> ·
					<span itemscope itemtype="http://schema.org/Organization">
					<a href="http://www.facebook.com/alistapart" itemprop="sameAs">Facebook</a> ·
					<a href="https://plus.google.com/107749003388305496076" rel="publisher" itemprop="sameAs">Google+</a> ·
					<a href="http://www.twitter.com/alistapart" itemprop="sameAs">Twitter</a>
					</span>

				</li>
			</ul>

			<aside class="promo-holder" aria-label="A List Apart partners">

				<ul class="partner-promos">
					<li>
						<a href="http://abookapart.com">
							<img src="/components/assets/img/promo_aba.png" alt="">
							<p class="promo-title">A Book Apart</p>
							<p>Mobile First & Responsive Web Design bundle.</p>
							<p>Buy both and save!</p>
							<p class="arrow">Order now</p>
						</a>
					</li><!--

					--><li>
						<a href="http://aneventapart.com">
							<img src="/components/assets/img/promo_aea.png" alt="">
							<p class="promo-title">An Event Apart</p>
							<p>Three days of design, code, and content for people who make websites.</p>
							<p class="arrow">See the 2016 schedule</p>
						</a>
					</li>
				</ul>

			</aside>

			<ul class="inline-items copyright">

				<li>
					<small>ISSN 1534-0295 · Copyright © <span itemprop="copyrightYear">1998–2017</span> <span itemprop="copyrightHolder">A List Apart & Our Authors</span></small>
					<small><a href="/about/copyright">Permissions & Copyright</a> · <a href="http://webtype.com">Fonts by Webtype</a><span class="logged-in"> · </span><span class="logged-out"><a href="/tools/log-in">Log In</a> · <a href="/tools/register">Register</a></span></small></li>

				<li class="affiliates head-east-young-man">
					
					<a class="ala" href="http://alistapart.com" title="A List Apart" itemprop="sameAs">A List Apart</a>
					<a class="aea" href="http://aneventapart.com" title="An Event Apart" itemprop="relatedLink">An Event Apart</a>
					<a class="aba" href="http://abookapart.com" title="A Book Apart" itemprop="relatedLink">A Book Apart</a>
					<a class="arcus" href="https://arcustech.com" title="Hosting provided by Arcustech" itemprop="provider">Arcustech</a>

				</li>

			</ul>

		</footer>

	<div id="bsap_1031" class="bsaPROrocks ad" data-serve="C67DL2V"></div>

	


	


	<!-- facebook login: remove the fragment #_=_ that facebook adds to the redirect_uri | remove this after social login module update -->
	<script>
		if (window.location.hash && window.location.hash == '#_=_') {
		    if (window.history && history.pushState) {
		        window.history.pushState("", document.title, window.location.pathname);
		        
		        	window.location.hash = '#comment-form';
		        
		    } else {
		        // Prevent scrolling by storing the page's current scroll offset
		        var scroll = {
		            top: document.body.scrollTop,
		            left: document.body.scrollLeft
		        };
		        window.location.hash = '';
		        // Restore the scroll offset, should be flicker free
		        document.body.scrollTop = scroll.top;
		        document.body.scrollLeft = scroll.left;
		    }
		}
	</script>

	<script src="http://alistapart.com/d/_cache/e8952a1f4e9e5593cdc3ceff2271ef14a9300c64.1482327043.js"></script>

	<script>
	if ($("#job-board-target").length > 0 || $("#deck-target").length > 0) {
	  	$.getScript("/components/assets/js/postscribe-init.js")
			.done(function() {
				//BuySell Ads
				(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();
		});
	} else {
		(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();
	}
	</script>

	<script>
	var _qevents = _qevents || [];

	(function() {
	var elem = document.createElement('script');
	elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
	elem.async = true;
	elem.type = "text/javascript";
	var scpt = document.getElementsByTagName('script')[0];
	scpt.parentNode.insertBefore(elem, scpt);
	})();

	_qevents.push({qacct:"p-0Gb-D0fnDnm2s"});
	</script>

	<noscript>
	<div style="display:none;">
	<img src="//pixel.quantserve.com/pixel/p-0Gb-D0fnDnm2s.gif" height="1" width="1" alt=""/>
	</div>
	</noscript>

	<script>
	var _gaq=[['_setAccount','UA-11757054-1'],['_trackPageview']];
	(function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0];
	g.src=('https:'==location.protocol?'//ssl':'//www')+'.google-analytics.com/ga.js';
	s.parentNode.insertBefore(g,s)}(document,'script'));
	</script>

	<!-- start Mixpanel --><script type="text/javascript">(function(e,b){if(!b.__SV){var a,f,i,g;window.mixpanel=b;a=e.createElement("script");a.type="text/javascript";a.async=!0;a.src=("https:"===e.location.protocol?"https:":"http:")+'//cdn.mxpnl.com/libs/mixpanel-2.2.min.js';f=e.getElementsByTagName("script")[0];f.parentNode.insertBefore(a,f);b._i=[];b.init=function(a,e,d){function f(b,h){var a=h.split(".");2==a.length&&(b=b[a[0]],h=a[1]);b[h]=function(){b.push([h].concat(Array.prototype.slice.call(arguments,0)))}}var c=b;"undefined"!==
	typeof d?c=b[d]=[]:d="mixpanel";c.people=c.people||[];c.toString=function(b){var a="mixpanel";"mixpanel"!==d&&(a+="."+d);b||(a+=" (stub)");return a};c.people.toString=function(){return c.toString(1)+".people (stub)"};i="disable track track_pageview track_links track_forms register register_once alias unregister identify name_tag set_config people.set people.set_once people.increment people.append people.track_charge people.clear_charges people.delete_user".split(" ");for(g=0;g<i.length;g++)f(c,i[g]);
	b._i.push([a,e,d])};b.__SV=1.2}})(document,window.mixpanel||[]);
	mixpanel.init("204b563994d022408e4b540a66fe6136");</script><!-- end Mixpanel -->

	<script type="text/javascript">
  WebFontConfig = {
    custom: { families: [ 'Franklin ITC:regular,bold',
                  'Franklin ITC Light:regular,italic' ],
    urls: [ '//cloud.webtype.com/css/789ea108-396c-4a3c-b0d2-f1974589df48.css' ]}
  };
  (function() {
    var wf = document.createElement('script');
    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
        '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
  })();
</script>

<!--Adblock Check--> 
<script type="text/javascript" src="/components/assets/js/adchecka.js"></script> <script type="text/javascript"> jQuery(document).ready(checkAds()); function checkAds(){ if (document.getElementById('adsense')!=undefined){document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Unblocked', 'false',,true]);</sc" + "ript>");}else{document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Blocked', 'true',,true]);</sc" + "ript>");}} </script> 
<!--End Adblock Check-->

</body>
</html>