<!doctype html>

<!--[if lt IE 7]> <html class="no-js ie ie6 lt-ie10 lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie ie7 lt-ie10 lt-ie9 lt-ie8" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie ie8 lt-ie10 lt-ie9" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="no-js ie ie9 lt-ie10" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html class="no-js" lang="en"> <!--<![endif]-->

<head>

	<meta charset="utf-8">

	<link rel="alternate" type="application/rss+xml" title="A List Apart: The Full Feed" href="/main/feed" />

	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="shortcut icon" href="/components/assets/img/favicons/favicon.ico" type="image/x-icon" />
	<link rel="apple-touch-icon" href="/components/assets/img/favicons/apple-touch-icon.png" />
	<link rel="apple-touch-icon" sizes="57x57" href="/components/assets/img/favicons/apple-touch-icon-57x57.png" />
	<link rel="apple-touch-icon" sizes="72x72" href="/components/assets/img/favicons/apple-touch-icon-72x72.png" />
	<link rel="apple-touch-icon" sizes="76x76" href="/components/assets/img/favicons/apple-touch-icon-76x76.png" />
	<link rel="apple-touch-icon" sizes="114x114" href="/components/assets/img/favicons/apple-touch-icon-114x114.png" />
	<link rel="apple-touch-icon" sizes="120x120" href="/components/assets/img/favicons/apple-touch-icon-120x120.png" />
	<link rel="apple-touch-icon" sizes="144x144" href="/components/assets/img/favicons/apple-touch-icon-144x144.png" />
	<link rel="apple-touch-icon" sizes="152x152" href="/components/assets/img/favicons/apple-touch-icon-152x152.png" />

	<meta name="application-name" content="A List Apart"/>
	<meta name="msapplication-TileColor" content="#222222"/>
	<meta name="msapplication-TileImage" content="/components/assets/img/favicons/windows-8-tile.png"/>

	<link href="https://plus.google.com/+alistapart/" rel="publisher" />

	<meta http-equiv="imagetoolbar" content="false" />

	<link rel="stylesheet" href="https://alistapart.com/d/_cache/60752e87345432991e7cd6b53c5d61e28e94f37f.1504629213.css" />

	<script src="/components/assets/js/libs/modernizr-custom.js"></script>
	<script src="/components/assets/js/libs/jquery-3.0.0.min.js"></script>
	<script src="/components/assets/js/libs/jquery-migrate-1.4.1.min.js"></script>





	<title>Conducting the Technical Interview · An A List Apart Article</title>

	<link rel="alternate" type="application/rss+xml" title="A feed for comments on this article" href="/comments/feed/conducting-the-technical-interview" />

	
	<style>
	 {
		border: 1px solid rgba(0,0,0,.4) !important;
	}
	
	 {
		/*box-shadow: inset 0 0 18px -8px rgba(255,161,161,.9);*/
		content: url(/components/assets/img/laurel-white-2.svg) !important;
		padding-top: 3px !important;
		height: 23px !important;
	}
	</style>

	

	<link rel="canonical" href="https://alistapart.com/article/conducting-the-technical-interview"/>

	<meta name="description" content="Key to hiring technical talent are a clear view of the role and the ideal candidate." class="entry-summary">
	<meta name="author" content="">

	<meta name="twitter:card" content="summary">
	<meta name="twitter:site" content="@alistapart">
	<meta name="twitter:title" content="Conducting the Technical Interview">
	<meta name="twitter:description" content="Key to hiring technical talent are a clear view of the role and the ideal candidate.">
	<meta name="twitter:url" content="https://alistapart.com/article/conducting-the-technical-interview">

	<meta property="og:title" content="Conducting the Technical Interview" />
	<meta property="og:description" content="Key to hiring technical talent are a clear view of the role and the ideal candidate." />
	<meta property="og:url" content="https://alistapart.com/article/conducting-the-technical-interview" />
	<meta property="og:image" content="" />

</head>

<body class="printable " itemscope itemtype="http://schema.org/Article">
<link itemprop="mainEntityOfPage" href="https://alistapart.com/article/conducting-the-technical-interview" />
	<header class="logo-holder">

		<h1 name="top" class="killer-logo" itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><a href="https://alistapart.com" title="A List Apart home page" tabindex="-1" itemprop="url"><span itemprop="logo" itemscope itemtype="http://schema.org/ImageObject"><img itemprop="url" src="https://alistapart.com/components/assets/img/ala-logo-big.png" alt="A List Apart"></span></a><span class="screen-reader" itemprop="name">A List Apart</span></h1>

	</header>



	<a class="go-to-nav" href="#main-nav" title="skip to nav">Menu</a>

	<nav class="global-nav" id="main-nav" role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">

		<ul class="inline-items">
			<li><a href="/" title="Home" itemprop="url"><span itemprop="name">Home</span></a></li>
			
			<li class="active"><a href="/articles" itemprop="url"><span itemprop="name">Articles</span></a></li>
			<li ><a href="/events" itemprop="url"><span itemprop="name">Events</span></a></li>
			<li ><a href="/topics" itemprop="url"><span itemprop="name">Topics</span></a></li>
			<li ><a href="/about/contribute" itemprop="url"><span itemprop="name">Write for us</span></a></li>
			<li class="back-to-top"><a href="#top">Back to top</a></li>
			<li class="head-east-young-man">
				<form id="main-search" class="main-search" data-action="/search" action="https://www.google.com/search" method="GET">
					<input type="hidden" name="sitesearch" value="alistapart.com" />
					<label for="search-keywords"><input id="search-keywords" type="search" data-name="keywards" name="q" placeholder="Search" aria-label="Search" value="" required="required"></label>
					<input id="submit-search" name="submit" type="image" src="/components/assets/img/icon_magnify_v.svg" data-fallback="/components/assets/img/icon_magnify_v.png" alt="Submit">
				</form>
			</li>
		</ul>

	</nav>


	


	<div role="main" class="main-wrapper">

		<article class="article-layout hentry">

			<header class="entry-header">

				 

				

				<h1 class="entry-title" itemprop="headline">Conducting the Technical Interview</h1>

				<p class="entry-details">
					<meta itemprop="description" content="Key to hiring technical talent are a clear view of the role and the ideal candidate."/>

					<span itemprop="author" itemscope itemtype="http://schema.org/Person">by <a itemprop="sameAs" class="author" rel="author" href="/author/brandongregory"><span itemprop="name">Brandon Gregory</span></a></span>

					<time class="pubdate updated" datetime="2017-09-05T13:41:00-04:00" itemprop="datePublished">September 05, 2017</time>
					<meta itemprop="dateModified" content="2017-09-05T17:41:18-04:00">

					<span class="entry-meta optional-break">

						Published in <a href="/topic/process"><span itemprop="about">Process</span></a>, <a href="/topic/business"><span itemprop="about">Business</span></a>


					</span>
				</p>

				 

			</header>

			 

			

			

			<div class="main-content" itemprop="articleBody">

			

			

			

				<p>I vividly remember my first interview as a manager. My hands were shaking as I led the candidate up the stairs to the conference room I had booked. When we got there, I went into a panic. What if I don’t ask a vital question? How do I even know what the vital questions are? What if I hire him and he’s completely unprofessional? How can I tell if he <em>really</em> knows JavaScript? Wait a second—does he have a prosthetic leg? <em>Did I just take a candidate with a prosthetic leg up the stairs?</em> Oh no, I’m failing this interview already!</p>

				<div class="aside-breaker"><b>Article Continues Below</b></div>

				<aside class="content-minutiae">
					
                  <a href="#comments" class="comment-bubble comment-bubble-articles">
                     <span>no comments yet</span>
                  </a>

					


                  <div class="minutiae-block share-block">
                     <h1 class="propagation-enablers" aria-hidden="true">Share this on</h1>
                     <ul class="propagation-enablers">
                        <li class="circle-twitter"><a href="http://twitter.com/intent/tweet?url=http://alistapart.com/article/conducting-the-technical-interview&text=Conducting+the+Technical+Interview&via=alistapart" data-trackevent="Share: Twitter" title="share this on Twitter"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="0 0 274 224" enable-background="new 0 0 274 224" xml:space="preserve">
                        <path d="M273.7,27.2c-10.1,4.5-20.9,7.5-32.2,8.8c11.6-6.9,20.5-17.9,24.7-31c-10.8,6.4-22.8,11.1-35.6,13.6
                           C220.3,7.7,205.7,0.9,189.6,0.9c-31,0-56.1,25.1-56.1,56.1c0,4.4,0.5,8.7,1.5,12.8C88.3,67.4,47,45.1,19.3,11.2
                           c-4.8,8.3-7.6,17.9-7.6,28.2c0,19.5,9.9,36.6,25,46.7c-9.2-0.3-17.8-2.8-25.4-7c0,0.2,0,0.5,0,0.7c0,27.2,19.3,49.8,45,55
                           c-4.7,1.3-9.7,2-14.8,2c-3.6,0-7.1-0.4-10.6-1c7.1,22.3,27.9,38.5,52.4,39c-19.2,15-43.4,24-69.7,24c-4.5,0-9-0.3-13.4-0.8
                           c24.8,15.9,54.3,25.2,86,25.2c103.2,0,159.6-85.5,159.6-159.6c0-2.4-0.1-4.9-0.2-7.3C256.7,48.3,266.2,38.5,273.7,27.2z"/>
                        </svg></a></li><!--
                        --><li class="circle-facebook"><a href="http://www.facebook.com/sharer.php?u=http://alistapart.com/article/conducting-the-technical-interview&t=Conducting+the+Technical+Interview" data-trackevent="Share: Facebook" title="share this on Facebook"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-95.6 286.6 114 220" enable-background="new -95.6 286.6 114 220" xml:space="preserve">
                        <path id="f" d="M-21.6,505.9v-99.8h33.5l5-38.9h-38.5v-24.8c0-11.3,3.1-18.9,19.3-18.9l20.6,0v-34.8
                           c-3.6-0.5-15.8-1.5-30-1.5c-29.7,0-50,18.1-50,51.4v28.7h-33.6v38.9h33.6v99.8H-21.6z"/>
                        </svg></a></li><!--
                        --><li class="circle-google"><a href="https://plus.google.com/share?url=http://alistapart.com/article/conducting-the-technical-interview" data-trackevent="Share: Google+" title="share this on Google+"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-212.7 354.2 84 86" enable-background="new -212.7 354.2 84 86" xml:space="preserve">
                        <g>
                           <g>
                              <path d="M-168.4,403.2l-4-3.1c-1.2-1-2.9-2.3-2.9-4.8c0-2.4,1.7-4,3.1-5.4c4.6-3.7,9.3-7.5,9.3-15.7
                                 c0-8.4-5.3-12.9-7.8-15h6.8l7.2-4.5h-21.8c-6,0-14.6,1.4-20.9,6.6c-4.8,4.1-7.1,9.8-7.1,14.8c0,8.6,6.6,17.4,18.3,17.4
                                 c1.1,0,2.3-0.1,3.5-0.2c-0.5,1.3-1.1,2.4-1.1,4.3c0,3.4,1.8,5.5,3.3,7.5c-5,0.3-14.3,0.9-21.1,5.1c-6.5,3.9-8.5,9.5-8.5,13.5
                                 c0,8.2,7.7,15.8,23.8,15.8c19,0,29.1-10.5,29.1-20.9C-159.1,411.1-163.5,407.3-168.4,403.2z M-182.9,390.5
                                 c-9.5,0-13.8-12.3-13.8-19.7c0-2.9,0.5-5.9,2.4-8.2c1.8-2.2,4.9-3.7,7.7-3.7c9.2,0,13.9,12.4,13.9,20.4c0,2-0.2,5.5-2.8,8.1
                                 C-177.2,389.1-180.1,390.5-182.9,390.5z M-182.8,435c-11.8,0-19.5-5.7-19.5-13.5c0-7.9,7.1-10.5,9.5-11.4
                                 c4.6-1.6,10.6-1.8,11.6-1.8c1.1,0,1.7,0,2.5,0.1c8.4,6,12.1,9,12.1,14.6C-166.5,429.9-172.2,435-182.8,435z"/>
                              <polygon points="-140.5,390.3 -140.5,379.2 -146,379.2 -146,390.3 -157,390.3 -157,395.8 -146,395.8 -146,407
                                 -140.5,407 -140.5,395.8 -129.4,395.8 -129.4,390.3 		"/>
                           </g>
                        </g>
                        </svg></a></li>
                     </ul>
                  </div>


					 
          <a href="https://www.patreon.com/alistapart" class="patreon-bubble">
            Become a patron
          </a>
				</aside>


			<div class="utility-side-bar">            <script src="/components/assets/js/libs/htmlParser.js"></script>
            <script src="/components/assets/js/libs/postscribe.js"></script>
            <!-- BuySellAds PRO Zone Code (Sidebar Sponsor) -->
            <!--<div id="bsap_2374" class="bsaPROrocks bsa-tall" data-serve="CVAIC27J" style="max-width:240px;overflow:hidden"></div>-->
            <!-- End BuySellAds PRO Zone Code -->
            <!--<aside id="job-board-target" class="job-board ad"></aside>-->

            <div class="bsa-apiads">
              <a href="https://abookapart.com">
                <img class="bsa-apiads-logo" src="//assets.servedby-buysellads.com/p/manage/asset/id/32683">
                <p>A Book Apart:<br> Brief books for people who make websites.</p>
              </a>
            </div>

</div><p>Even if you’re familiar with <a href="/article/interviewing-humans">the basics of interviewing</a>, technical interviews can be nerve-wracking. Whether you’re a new team lead or you’ve been in leadership for years, concerns and insecurities like the ones I had in my first interview can haunt you, and even well-established interview processes can fail to adequately screen candidates.</p>

<p>Interviewing for technical positions is, in many ways, a balancing act. You look at past, present, and future; you look at soft skills and hard skills; you have to think as both a buyer and a seller; you even have to worry about company image and reputation management. There are some basic things you can do to keep that balance and best represent your company.</p>

<h2>Define the ideal role</h2>

<p>I’ll admit, for my first round of interviews, all I was looking for was someone who could tick off all the technical skills on a checklist. As I progressed in my management career, I started to learn that I never looked for the same person twice—each time I had an opening, the team had different needs, and I had to take those into account when hiring someone. Even though the job description for a front-end developer didn’t change much each time, my expectations for the ideal candidate did. That gap between the job description and the ideal role tripped me up for a long time.</p>

<p>Before you start interviewing, you’ll need a solid written description of what you’re looking for in an ideal candidate, beyond what job postings typically go into. The job posting may say Senior Front End Developer, but if you need someone to be your CSS animation specialist and help define standards and best practices—whether now or in eight months—you’ll need to take that into account when hiring.</p>

<p>Be future-oriented with your description: ask yourself what happens when the employee outgrows his or her role. Could this person be a supervisor, or would they even want to be? Is there an opportunity to be a <a href="/article/the-foundation-of-technical-leadership ">technical leader</a> or architect at your company, if that’s the route this person chooses? Could this person one day replace you? (Remember, you’re probably not getting promoted until there’s someone to take your place.) If you have no answer to the question of what happens when an employee outgrows the role, the answer is usually found at another company.</p>

<p>Also ask what happens if the team continues to grow. Does this person have the aptitude to pick up new skills and responsibilities as needed? How will this person respond to change? What if you have to put this person in front of a client? At a healthy company, growth is inevitable, both in size and scope. Your definition should describe someone who can grow with you and not get left behind.</p>

<p>Define not only the technical skills, but also the soft skills needed for the role you have in mind. If you need someone to take the lead on collaborating with the Creative team, you’ll need to define what would make an employee successful in that role and hire for that. This can actually be more important than the technical skill requirements. Technical skills can be easily trained—soft skills cannot.</p>

<p>When you do all of this, you’ll have a list of expectations for a role that probably won’t fit in a job posting. When appropriate (don’t make promises of growth), test those waters with the people you’re interviewing. Even if you determine a person would be good as a trainer, they may not want to do that, which can be a nasty surprise if you hired the person with the intent of them growing into the role a year down the road.</p>

<p>Once you know what you’re looking for, the next step is getting them to want to work for you.</p>

<h2>Sell the job</h2>

<p>The saddest interviews for me are the ones where I find that ideal candidate I envisioned and they get away. Sometimes, they just get a higher salary somewhere else; but sometimes, they decide that they don’t like the company and want to keep looking. Both are sad, but either way, getting candidates to like your company is always in your best interest.</p>

<p>Remember, when you’re interviewing someone, they’re also interviewing you. Don’t ever assume that your company is the only place a candidate is interviewing. It’s true that some people walk in the door with their minds made up, but many are still deciding whether they want to work for your company—and the better the candidate, the more options they’re going to have, so the more you’re going to have to sell to win them over.</p>

<p>So how do you sell a job? A salesman will tell you it starts with knowing three things really well: the product, the competition, and the customer. The product is your company: benefits, compensation, culture, type of work, amount of work, and even location. The competition is any local business that hires similar types of people, and you’ll need to know the same things about them that you do about your own company. The customer is the job applicant. Knowing each of these things well and being able to compare them is key to winning the best candidates.</p>

<p>Do your research not only into your own company, but your local competitors. What are your competitive advantages? What are theirs? (If you think a ping pong table is a competitive advantage, you’ll probably need to dig a little deeper.) Sometimes it’s not about what you have so much as what the competition doesn’t. If you’re seeing a lot of interviewees from a competitor, find out why and see if you can use that factor to sell your company.</p>

<p>Learn <a href="http://stackoverflow.com/research/developer-survey-2016#work-job-priorities">what prospective employees are looking for in a job</a>. There will likely be some commonalities. If you’re losing top talent because you don’t offer a benefit or they don’t like your processes, you’d be wise to revisit those. Just like the technology in our industry is constantly changing, the expectations and needs of our employees are also changing. Don’t fall behind with what you offer to your employees.</p>

<p>Almost every candidate will have questions about what the work environment is like. You should have a little elevator speech to sum up your answer and sell your company in a minute or less. You may actually want to lead the interview with that speech to get those questions out of the way and get the candidate excited for the position before you start finding out about them.</p>

<p>Lastly, be authentic with your interviewees. Don’t try to spin a weakness as a strength, because most people will see right through that. If you don’t believe in your company enough to be totally honest about it, why should they believe in it enough to work for you? You don’t need to hand them a comprehensive list of everything that’s wrong with your company, but don’t shy away from questions along those lines, and don’t try to reframe a shortcoming as a strength. As an example, if your company has a reputation for burning some people out, that’s important, but you can talk about the type of people who do well there rather than the people who don’t. It’s better that people find that out in the interview than after three months of training.</p>

<h2>Hire a person, not a code machine</h2>

<p>In my five years as a supervisor, I only had to fire two people. Want to guess how many of those were because they lacked technical skills? Zero. In both cases, the employees didn’t work out for non-technical reasons.</p>

<p>There are a number of non-technical factors to look for in a candidate: personality, fit with the team, communication skills, openness to change, leadership potential, and a host of others. (That’s the real reason you’re conducting an interview and not just asking for test results.) These details don’t magically reveal themselves in the technical portion of the interview—you need to ask about them.</p>

<p>Create a list of standard questions for candidates. Questions should be open-ended and answered with a story. Examples include:</p>

<ul>
<li>Tell us about a time when your good communication helped to solve a problem.</li>
<li>Tell us about a time when you disagreed with your supervisor and what you did about it.</li>
<li>Tell us about a time you successfully described a technical concept to a non-technical person.</li>
<li>How would you explain inheritance to a junior developer?</li>
<li>Tell us about a recent time you learned from a mistake.</li>
</ul>

<p>Order is important: ask the non-technical questions first. The technical portion of the interview can make some people nervous, and you won’t get a good gauge of who the candidate is if their thoughts are fixated on the technical questions they missed.</p>

<p>Putting thought into screening for soft skills is vital. But remember that this is a technical interview—you have to put just as much thought into screening for technical talent.</p>

<h2>Stick to the standards</h2>

<p>And I’m not talking about web standards. If you’re not asking all developers the same questions, there’s a good chance you won’t get a fair comparison, which means a greater likelihood that you’ll fall back on <a href="http://www.businessinsider.com/unconscious-biases-in-hiring-decisions-2015-7 ">biases</a> like similarity or likeability. </p>

<p>Develop a standard set of technical questions, and a written test. The questions should allow for some discussion, but have a clearly-defined right answer. <a href="https://github.com/h5bp/Front-end-Developer-Interview-Questions ">Examples of these questions</a> are <a href="https://github.com/arialdomartini/Back-End-Developer-Interview-Questions">everywhere</a>. You’ll probably want to customize your list so that people can’t just look up the answers online before the interview, but lists like those will get you most of the way there.</p>

<p>(And don’t feel like you need to come up with this list on your own. If you have technical experts at your disposal, utilize them. You’ll probably want one in the interview, too.)</p>

<p>The written test can make or break an interview. It should not be easy, nor should it be mandatory to get every question right. When an applicant is writing out code by hand from memory, leniencies must be given for syntax—give points for partial answers and ideas. Remember what Stephen Wolfram, creator of the Wolfram Alpha answer engine, said on the subject: “One thing I’ve noticed is that in almost every area, the people who go furthest are not the ones with the best technical skills, but the ones who have the best strategy for figuring out what to do.” You’re trying to get a feel for the candidate’s problem-solving strategy, not their ability to memorize every minutia of coding syntax.</p>

<p>There should be at least a few “fix this code” sections to see how sharp their debugging skills are. Again, you shouldn’t focus on trick questions or ridiculously obscure syntax problems—you just want to measure the candidate’s ability to think through and solve a technical problem.</p>

<p>Questions should be relevant to what the job entails—if they’ll be expected to create custom CSS animations, make sure to ask about that—but they should avoid niche- or process-specific knowledge unless it’s vital to the position. Rule of thumb: if your company does something differently than the rest of the industry, don’t quiz them on it.</p>

<p>Once you have the questions and test prepared, run the questions by some of your existing team members to see how they fare. If your entry-level developers get all of the questions right—probably a bad sign; if your senior developers all bomb the test—also a bad sign.</p>

<p>In the questions, there should be some clear delineation between roles. What are the must-answer questions for mid-level developers? For seniors? There can be some flexibility here, but you should have a pretty good idea what a senior test looks like and what a mid-level test looks like.</p>

<p>If a candidate aces your standard interview questions, you can hire them with confidence. But when the technical portion of the interview doesn’t go well, you need to know how to handle that too.</p>

<h2>Know when to move on</h2>

<p>The most awkward interview I ever conducted was with a PHP developer who freelanced and was looking for his first agency job. When we began the technical questions, I quickly realized he didn’t know as much as he thought he did. Of the 22 technical questions, he got about 2 correct. He got more and more distressed with every tough question—especially when I corrected his wrong answers—and by the end of the technical portion, he looked like he’d been punched in the stomach.</p>

<p>That guy was not qualified for the job, and both of us knew it from question 3. This was pretty early on in my management career, so I just plowed through the entire list of questions, knowing he would fail them. Learn from my mistake: don’t do that.</p>

<p>Let interviewees fail gracefully. Don’t interrupt them with the right answer to the question they’re struggling with, and don’t correct them if they get the answer partially right. If they get the question wrong, just move on without showing judgment. If they really can’t get a question, just tell them you’re moving on.</p>

<p>If a person bombs the verbal questions, don’t make them sit through the written test (which will probably be much harder). Feel free to tell them right then and there that they’re not a good fit for your particular position and wish them well in their quest for work. If you think they could be a good fit for another position in your company, or if you’d like to see them back once they get a better grasp on the fundamentals, go ahead and let them know. But there’s no point in leading them on with a vague non-answer if the answer is definitely no.</p>

<h2>Conclusion</h2>

<p>Screening for technical talent can be tricky. Having a holistic view of both the role and the candidate is key to making the right hiring decision. Remember to take careful notes, even if you don’t think you’ll need them. And good luck!</p>

				

			

			 

				

				
				<!-- START RELATED SIDEBAR -->
				
				
				<aside id="related" class="sidebar var1 nocontent">
				<i class="widget-branding ala"></i>
				<!-- if this article does not have a follow up show recent articles by this author -->
				
				
					
							

							<section>
							<h1>Recently by  Brandon Gregory</h1>

							<article>
								<h1><a href="https://alistapart.com/article/defeating-workplace-drama-with-emotional-intelligence">Defeating Workplace Drama with Emotional Intelligence</a></h1>
								<p>There’s a straightforward emotional equation to explain workplace behavior that, on its face, makes no sense.</p>
							</article>
							</section>
							
				
				<!-- end first block -->
				
				<!-- show categories -->
				
					
	
   <section class="related-articles">



   <h1 class="primary-cat-header">
      Further reading about
      <a href="/topic/process" data-trackevent="Related sidebar: Related by category">Process</a>
   </h1>

   <article>



<h2><a href="https://alistapart.com/article/team-conflict-four-ways-to-deflate-the-discord-thats-killing-your-team">Team Conflict: Four Ways to Deflate the Discord that&#8217;s Killing Your Team</a></h2>
   <p>Navigating the complexities of human interaction.</p><h2><a href="https://alistapart.com/article/web-maintainability-survey">Web Maintainability Industry Survey: How Do We Maintain?</a></h2>
   <p>Take part in the Great Web Maintainability Survey</p>

   </article>

</section>
 
   


				
				
					
				
				</aside>
				<!-- END RELATED SIDEBAR -->
				

				<footer class="entry-footer nocontent">
				<h1>About the Author</h1>

				<div class="byline author vcard">

					<a class="photo" href="/author/brandongregory"><img src="/d/_made/pix/authors/photos/brandon-gregory-400_120_120_c1.jpg" alt="Image of Brandon Gregory"></a>

					<h2><a class="fn" href="/author/brandongregory">Brandon Gregory</a></h2>

					<div class="author-bio"><a href="http://brandongregorycreative.com/">Brandon Gregory</a> is a designer and developer in the Kansas City area, currently serving as Development Team Lead for <a href="http://www.intouchsol.com/">Intouch Solutions</a>. He’s into cats, music, psychology, writing, and cats. Also, he’s in a band. One time, he rocked so hard it killed a man.</div>

					
						<h3>More from this Author</h3>

							<ul class="author-more">
						
								<li><a href="/article/defeating-workplace-drama-with-emotional-intelligence">Defeating Workplace Drama with Emotional Intelligence</a></li><li><a href="/article/the-foundation-of-technical-leadership">The Foundation of Technical Leadership</a></li><li><a href="/article/managing-ego">Managing Ego</a></li>
						</ul>

				</div>
				
				 

				</footer>

				
<aside class="promo-box email-promo">
   <b>Get our latest articles in your inbox.</b> <a href="/email-signup" data-trackevent="Post-article: email promo">Sign up for email alerts</a>.
</aside>

			</div>

			<div class="post-article">

				<div class="column-holder unequal-columns">

					<section id="comments" class="column comment-holder">

							<h1 class="classy" itemprop="commentCount" data-url-title="conducting-the-technical-interview">
							 
							<span>No Comments (yet)<span>
							</h1>

							
							<span id="load-comments" data-url-title="conducting-the-technical-interview"></span>

							
								<ol class="article-comments form">

	<li id="commenter-signin" class="commenter-signin no-comments">

	<h3 class="form-heading">Got something to say?</h3>
 	
 	<div class="outer-ajax-container">
	
	 	<div class="ajax-container">
	 	
			<form id="login_form" class="sign-in-form" name="login_form" method="post" action="https://alistapart.com?ACT=159"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="159" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="1833bd26746f286d57a5c63cd455612334d3eead" />
</div>



		
			<fieldset>

		    	<legend class="center">Sign in to add your voice to the discussion.</legend>

				<p>
					<label for="login-name-here">Email (<a id="register" class="history-nav" data-tabto="forgot-password" href="/tools/register" target="_blank">Need an account?</a>)</label>
					<input
						type="text"
						id="login-name-here"
						name="username"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your email address?"
						data-tabmaster="true"
						data-tabto="login_password"
						required>
				</p>

				<p class="password-field">
					<label for="login_password">Password (<a id="forgot-password" class="history-nav" data-tabto="comment-submit" href="/tools/forgot-password" target="_blank">Forgot?</a>)</label>
					<input
						type="password"
						id="login_password"
						name="password"
						required="required"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your password?"
						data-tabmaster="true"
						data-tabto="register"
						required>
				</p>
				
				<p class="screen-reader">
					<label for="honeepot">Don't put anything here</label>
					<input 
						type="text" 
						id="honeepot" 
						name="honeepot"
						data-tabmaster="false">
				</p>

				<p id="comment-submit-holder">
					<input 
						type="submit" 
						id="comment-submit"
						data-tabmaster="true"
						class="button primary float-left" 
						value="Submit">
				</p>

			</fieldset>
		
		
</form>
<script type="text/javascript">
$(document).ready(function(){
    $('#login_form').on('submit', function(event){
        event.preventDefault();
        if (!supports_history_api()) { return; }
        AlaAuth.spinnerStart();
           
            $.post(
                'https://alistapart.com?ACT=159',
                $('#login_form').serialize(),
                function(msg) {
                    AlaAuth.spinnerStop();
        
            if (msg.indexOf('You are now logged in.') >= 0)
            {    
           
                $.get('https://alistapart.com/ajax/comment-form/18768/article/conducting-the-technical-interview', 
                function(ret){
                    ajaxContainer.replaceWith(ret);
                });
                AlaPostLoad.loadTranslations();
                history.pushState(
                    states.commentform, '', states.site_url + states.segments + '/' + states.commentform 
                );
              
                } else {
                    var out = /<div id="ee-errors"><ul>[\s\S]*<\/ul><\/div>/.exec(msg);
                    if ($('.error-message.none').length == $('.error-message').length) {
                        if(out === null) {
                            AlaAuth.alertMsg('This form has expired. Please refresh and try again.');
                            $.get('https://alistapart.com/ajax/comment-form/18768/article/conducting-the-technical-interview', 
                            function(ret){
                                ajaxContainer.replaceWith(ret);
                            });
                            $('.custom-modal').remove();
                        }else {
                            AlaAuth.alertMsg(out);
                        }
                    }                   
                }
                return false;
            }
        );
        return false;
    });
});
</script>
    

		<script src="https://alistapart.com/components/assets/js/ajax-functions.js"></script>

		<script type="text/javascript">

		var states = {
			//globals
			commentsignin: 'comment-sign-in',
			register: 'register',
			password: 'forgot-password',
			commentform: 'comment-form',
			//segments
			site_url: 'https://alistapart.com',
			
			
			segments: '/article/conducting-the-technical-interview', 
			
			tmpl_path: /ajax/,
			entry_id: '18768',
			page: 'article'
		}

		</script>

		</div>

		<div class="placeholder loader">
			<div class="top-header animated-background"></div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<!-- <div class="button primary">Submit</div> -->
		</div>

	</div>
 

	<script type="text/javascript">

	AlaAuth.loadTemplate (
		states.commentsignin
	);

	</script>
	
	</li>

</ol>
							 

					</section>

					<aside class="column more-content">

						
						<h1 class="classy">More from ALA</h1>

						<article class="item-summary article">

							<h4 class="summary-title"><a href="/article/yes-that-web-project-should-be-a-pwa">Yes, That Web Project Should Be a PWA</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/agustafson">Aaron Gustafson</a>
							
							
							</p>

							<p>Most websites—and, more importantly, their readers—can benefit from becoming PWAs. And it’s so easy!</p>

							<footer class="byline">
								
								
   

         <a href="/topic/application-development">Application Development</a>



 
   
								·
								<time class="pubdate updated" datetime="2017-08-30T14:30:00-04:00"><a href="article/yes-that-web-project-should-be-a-pwa">August 30, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/user-interfaces-for-variable-fonts">User Interfaces for Variable Fonts</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/Aetherpoint">Andrew Johnson</a>
							
							
							</p>

							<p>Variable fonts give us a new, wide open typographic space with which to work.</p>

							<footer class="byline">
								
								
   

         <a href="/topic/typography-web-fonts">Typography & Web Fonts</a>



 
   
								·
								<time class="pubdate updated" datetime="2017-08-25T10:00:00-04:00"><a href="article/user-interfaces-for-variable-fonts">August 25, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/integrating-animation-into-a-design-system">Integrating Animation into a Design System</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/craftui">Alla Kholmatova</a>
							
							
							</p>

							<p>A cohesive animation system can help express a product’s personality and make the interface feel connected and whole.</p>

							<footer class="byline">
								
								
   
<a href="/topic/interaction-design">Interaction Design</a>



   

								·
								<time class="pubdate updated" datetime="2017-08-17T13:09:00-04:00"><a href="article/integrating-animation-into-a-design-system">August 17, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/practical-user-research-creating-a-culture">Practical User Research: Creating a Culture of Learning in Large Organizations</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/sam-moore">Sam Moore</a>
							
							
							</p>

							<p>Demonstrate the value of user research on the ground.</p>

							<footer class="byline">
								
								<time class="pubdate updated" datetime="2017-07-27T11:00:00-04:00"><a href="article/practical-user-research-creating-a-culture">July 27, 2017</a></time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/team-conflict-four-ways-to-deflate-the-discord-thats-killing-your-team">Team Conflict: Four Ways to Deflate the Discord that&#8217;s Killing Your Team</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/jessica-hall">Jessica Hall</a>
							
							
							</p>

							<p>Navigating the complexities of human interaction.</p>

							<footer class="byline">
								
								
   
<a href="/topic/process">Process</a>



   

								·
								<time class="pubdate updated" datetime="2017-06-27T10:00:00-04:00"><a href="article/team-conflict-four-ways-to-deflate-the-discord-thats-killing-your-team">June 27, 2017</a></time>
							</footer>

						</article>

					<!-- 	<div id="bsap_1032" class="bsaPROrocks ad" data-serve="C67DL2E"></div> -->

					</aside>

				</div>

			</div>

		</article>



	</div>

			<footer class="global-footer" role="navigation" aria-label="Footer" itemscope itemtype="https://schema.org/WebPage">
			<meta itemprop="headline" content="A List Apart">
			<p class="deadly-subtitle" itemprop="alternativeHeadline">For people who make websites.</p>

			<ul class="inline-items" itemscope itemtype="http://schema.org/SiteNavigationElement">
				<li><a href="/about" itemprop="url">About</a></li>
				<li><a href="/authors" itemprop="url">Authors</a></li>
				<li><a href="/about/masthead" itemprop="url">Masthead</a></li>
				<li><a href="/about/style-guide" itemprop="url">Style Guide</a></li>
				<li><a href="/contact" itemprop="url">Contact</a></li>
				<li><a href="/about/sponsor" itemprop="url">Sponsorships</a></li>
				<li class="head-east-young-man">

					Follow us:
					<a href="/about/rss">RSS</a> ·
					<a href="/email-signup/">Email</a> ·
					<span itemscope itemtype="http://schema.org/Organization">
					<a href="http://www.facebook.com/alistapart" itemprop="sameAs">Facebook</a> ·
					<a href="https://plus.google.com/107749003388305496076" rel="publisher" itemprop="sameAs">Google+</a> ·
					<a href="http://www.twitter.com/alistapart" itemprop="sameAs">Twitter</a>
					</span>

				</li>
			</ul>

			<aside class="promo-holder" aria-label="A List Apart partners">

				<ul class="partner-promos">
					<li>
						<a href="http://abookapart.com">
							<img src="/components/assets/img/promo_aba.png" alt="">
							<p class="promo-title">A Book Apart</p>
							<p>Mobile First & Responsive Web Design bundle.</p>
							<p>Buy both and save!</p>
							<p class="arrow">Order now</p>
						</a>
					</li><!--

					--><li>
						<a href="http://aneventapart.com">
							<img src="/components/assets/img/promo_aea.png" alt="">
							<p class="promo-title">An Event Apart</p>
							<p>Three days of design, code, and content for people who make websites.</p>
							<p class="arrow">See the 2016 schedule</p>
						</a>
					</li>
				</ul>

			</aside>

			<ul class="inline-items copyright">

				<li>
					<small>ISSN 1534-0295 · Copyright © <span itemprop="copyrightYear">1998–2017</span> <span itemprop="copyrightHolder">A List Apart & Our Authors</span></small>
					<small><a href="/about/copyright">Permissions & Copyright</a> · <a href="http://webtype.com">Fonts by Webtype</a><span class="logged-in"> · </span><span class="logged-out"><a href="/tools/log-in">Log In</a> · <a href="/tools/register">Register</a></span></small></li>

				<li class="affiliates head-east-young-man">
					
					<a class="ala" href="http://alistapart.com" title="A List Apart" itemprop="sameAs">A List Apart</a>
					<a class="aea" href="http://aneventapart.com" title="An Event Apart" itemprop="relatedLink">An Event Apart</a>
					<a class="aba" href="http://abookapart.com" title="A Book Apart" itemprop="relatedLink">A Book Apart</a>
					<a class="arcus" href="https://arcustech.com" title="Hosting provided by Arcustech" itemprop="provider">Arcustech</a>

				</li>

			</ul>

		</footer>

	<div id="bsap_1031" class="bsaPROrocks ad" data-serve="C67DL2V"></div>

	


	


	<!-- facebook login: remove the fragment #_=_ that facebook adds to the redirect_uri | remove this after social login module update -->
	<script>
		if (window.location.hash && window.location.hash == '#_=_') {
		    if (window.history && history.pushState) {
		        window.history.pushState("", document.title, window.location.pathname);
		        
		        	window.location.hash = '#comment-form';
		        
		    } else {
		        // Prevent scrolling by storing the page's current scroll offset
		        var scroll = {
		            top: document.body.scrollTop,
		            left: document.body.scrollLeft
		        };
		        window.location.hash = '';
		        // Restore the scroll offset, should be flicker free
		        document.body.scrollTop = scroll.top;
		        document.body.scrollLeft = scroll.left;
		    }
		}
	</script>

	<script src="https://alistapart.com/d/_cache/e8952a1f4e9e5593cdc3ceff2271ef14a9300c64.1482327043.js"></script>

	<script>
	if ($("#job-board-target").length > 0 || $("#deck-target").length > 0) {
	  	$.getScript("/components/assets/js/postscribe-init.js")
			.done(function() {
				//BuySell Ads
				(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();
		});
	} else {
		(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();
	}
	</script>

	<script>
	var _qevents = _qevents || [];

	(function() {
	var elem = document.createElement('script');
	elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
	elem.async = true;
	elem.type = "text/javascript";
	var scpt = document.getElementsByTagName('script')[0];
	scpt.parentNode.insertBefore(elem, scpt);
	})();

	_qevents.push({qacct:"p-0Gb-D0fnDnm2s"});
	</script>

	<noscript>
	<div style="display:none;">
	<img src="//pixel.quantserve.com/pixel/p-0Gb-D0fnDnm2s.gif" height="1" width="1" alt=""/>
	</div>
	</noscript>

	<script>
	var _gaq=[['_setAccount','UA-11757054-1'],['_trackPageview']];
	(function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0];
	g.src=('https:'==location.protocol?'//ssl':'//www')+'.google-analytics.com/ga.js';
	s.parentNode.insertBefore(g,s)}(document,'script'));
	</script>

	<!-- start Mixpanel --><script type="text/javascript">(function(e,b){if(!b.__SV){var a,f,i,g;window.mixpanel=b;a=e.createElement("script");a.type="text/javascript";a.async=!0;a.src=("https:"===e.location.protocol?"https:":"http:")+'//cdn.mxpnl.com/libs/mixpanel-2.2.min.js';f=e.getElementsByTagName("script")[0];f.parentNode.insertBefore(a,f);b._i=[];b.init=function(a,e,d){function f(b,h){var a=h.split(".");2==a.length&&(b=b[a[0]],h=a[1]);b[h]=function(){b.push([h].concat(Array.prototype.slice.call(arguments,0)))}}var c=b;"undefined"!==
	typeof d?c=b[d]=[]:d="mixpanel";c.people=c.people||[];c.toString=function(b){var a="mixpanel";"mixpanel"!==d&&(a+="."+d);b||(a+=" (stub)");return a};c.people.toString=function(){return c.toString(1)+".people (stub)"};i="disable track track_pageview track_links track_forms register register_once alias unregister identify name_tag set_config people.set people.set_once people.increment people.append people.track_charge people.clear_charges people.delete_user".split(" ");for(g=0;g<i.length;g++)f(c,i[g]);
	b._i.push([a,e,d])};b.__SV=1.2}})(document,window.mixpanel||[]);
	mixpanel.init("204b563994d022408e4b540a66fe6136");</script><!-- end Mixpanel -->

	<script type="text/javascript">
  WebFontConfig = {
    custom: { families: [ 'Franklin ITC:regular,bold',
                  'Franklin ITC Light:regular,italic' ],
    urls: [ '//cloud.webtype.com/css/789ea108-396c-4a3c-b0d2-f1974589df48.css' ]}
  };
  (function() {
    var wf = document.createElement('script');
    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
        '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
  })();
</script>

<!--Adblock Check--> 
<script type="text/javascript" src="/components/assets/js/adchecka.js"></script> <script type="text/javascript"> jQuery(document).ready(checkAds()); function checkAds(){ if (document.getElementById('adsense')!=undefined){document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Unblocked', 'false',,true]);</sc" + "ript>");}else{document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Blocked', 'true',,true]);</sc" + "ript>");}} </script> 
<!--End Adblock Check-->

</body>
</html>