<!doctype html>

<!--[if lt IE 7]> <html class="no-js ie ie6 lt-ie10 lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie ie7 lt-ie10 lt-ie9 lt-ie8" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie ie8 lt-ie10 lt-ie9" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="no-js ie ie9 lt-ie10" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html class="no-js" lang="en"> <!--<![endif]-->

<head>
	
	<meta charset="utf-8">

	<link rel="alternate" type="application/rss+xml" title="A List Apart: The Full Feed" href="/main/feed" />

	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="shortcut icon" href="/components/assets/img/favicons/favicon.ico" type="image/x-icon" />
	<link rel="apple-touch-icon" href="/components/assets/img/favicons/apple-touch-icon.png" />
	<link rel="apple-touch-icon" sizes="57x57" href="/components/assets/img/favicons/apple-touch-icon-57x57.png" />
	<link rel="apple-touch-icon" sizes="72x72" href="/components/assets/img/favicons/apple-touch-icon-72x72.png" />
	<link rel="apple-touch-icon" sizes="76x76" href="/components/assets/img/favicons/apple-touch-icon-76x76.png" />
	<link rel="apple-touch-icon" sizes="114x114" href="/components/assets/img/favicons/apple-touch-icon-114x114.png" />
	<link rel="apple-touch-icon" sizes="120x120" href="/components/assets/img/favicons/apple-touch-icon-120x120.png" />
	<link rel="apple-touch-icon" sizes="144x144" href="/components/assets/img/favicons/apple-touch-icon-144x144.png" />
	<link rel="apple-touch-icon" sizes="152x152" href="/components/assets/img/favicons/apple-touch-icon-152x152.png" />

	<meta name="application-name" content="A List Apart"/>
	<meta name="msapplication-TileColor" content="#222222"/>
	<meta name="msapplication-TileImage" content="/components/assets/img/favicons/windows-8-tile.png"/>

	<link href="https://plus.google.com/+alistapart/" rel="publisher" />

	<link rel="preload" href="/components/assets/img/logo_a-list-apart.svg" as="image" type="image/svg+xml">

	<link rel="stylesheet" href="https://alistapart.com/d/_cache/4e425287d3bc7c393d0959bef082e87bd85a4a2e.1524830670.css" />

	<script src="/components/assets/js/libs/modernizr-custom.js"></script>
	<script src="/components/assets/js/libs/jquery-3.0.0.min.js"></script>
	<script src="/components/assets/js/libs/jquery-migrate-1.4.1.min.js"></script>





	<title>Conversations with Robots: Voice, Smart Agents &amp; the Case for Structured Content · An A List Apart Article</title>

	<link rel="alternate" type="application/rss+xml" title="A feed for comments on this article" href="/comments/feed/conversations-with-robots" />

	
	<style>
	 {
		border: 1px solid rgba(0,0,0,.4) !important;
	}
	
	 {
		/*box-shadow: inset 0 0 18px -8px rgba(255,161,161,.9);*/
		content: url(/components/assets/img/laurel-white-2.svg) !important;
		padding-top: 3px !important;
		height: 23px !important;
	}
	</style>

	

	<link rel="canonical" href="https://alistapart.com/article/conversations-with-robots"/>

	<meta name="description" content="Why structured content is now necessary to ensure the accuracy and integrity of your content across the evolving digital landscape" class="entry-summary">
	<meta name="author" content="">

	<meta name="twitter:card" content="summary">
	<meta name="twitter:site" content="@alistapart">
	<meta name="twitter:title" content="Conversations with Robots: Voice, Smart Agents &amp; the Case for Structured Content">
	<meta name="twitter:description" content="Why structured content is now necessary to ensure the accuracy and integrity of your content across the evolving digital landscape">
	<meta name="twitter:url" content="https://alistapart.com/article/conversations-with-robots">
	<meta name="twitter:creator" content="@@andybywire">
	
	<meta property="og:title" content="Conversations with Robots: Voice, Smart Agents &amp; the Case for Structured Content" />
	<meta property="og:description" content="Why structured content is now necessary to ensure the accuracy and integrity of your content across the evolving digital landscape" />
	<meta property="og:url" content="https://alistapart.com/article/conversations-with-robots" />
	<meta property="og:image" content="https://alistapart.com/d/voice-agents.jpg" />
	<meta property="og:locale" content="en_US">
	<meta property="og:site_name" content="A List Apart">
	<meta property="og:type" content="article">
	
	<meta property="article:published_time" content="2019-01-10T09:55:00-05:00">
	<link href="https://plus.google.com/+AListApart?rel=author" rel="publisher">

</head>

<body class="printable " itemscope itemtype="http://schema.org/Article">
<link itemprop="mainEntityOfPage" href="https://alistapart.com/article/conversations-with-robots" />
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5PLQL99"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
	<header class="logo-holder">

		<h1 id="top" class="killer-logo" itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><a href="https://alistapart.com" title="A List Apart home page" tabindex="-1" itemprop="url"><span itemprop="logo" itemscope itemtype="http://schema.org/ImageObject"><img itemprop="url" src="https://alistapart.com/components/assets/img/ala-logo-big.png" alt="A List Apart"></span></a><span class="screen-reader" itemprop="name">A List Apart</span></h1>

	</header>



	<a class="go-to-nav" href="#main-nav" title="skip to nav">Menu</a>

	<nav class="global-nav" id="main-nav" role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">

		<ul class="inline-items">
			<li><a href="/" title="Home" itemprop="url"><span itemprop="name">Home</span></a></li>
			
			<li class="active"><a href="/articles" itemprop="url"><span itemprop="name">Articles</span></a></li>
			<li ><a href="/events" itemprop="url"><span itemprop="name">Events</span></a></li>
			<li ><a href="/topics" itemprop="url"><span itemprop="name">Topics</span></a></li>
			<li ><a href="/about/contribute" itemprop="url"><span itemprop="name">Write for us</span></a></li>
			<li class="back-to-top"><a href="#top">Back to top</a></li>
			<li class="head-east-young-man">
				<form id="main-search" class="main-search" data-action="/search" action="https://www.google.com/search" method="GET">
					<input type="hidden" name="sitesearch" value="alistapart.com" />
					<label for="search-keywords"><input id="search-keywords" type="search" data-name="keywards" name="q" placeholder="Search" aria-label="Search" value="" required="required"></label>
					<input id="submit-search" name="submit" type="image" src="/components/assets/img/icon_magnify_v.svg" data-fallback="/components/assets/img/icon_magnify_v.png" alt="Submit">
				</form>
			</li>
		</ul>

	</nav>


	


	<div role="main" class="main-wrapper">

		<article class="article-layout hentry">

			<header class="entry-header">

				
				
				

				
				<figure class="wide-hero" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
				<meta itemprop="representativeOfPage" content="true">
				<meta itemprop="url" content="https://alistapart.com/d/voice-agents.jpg">
        <meta itemprop="width" content="1920">
        <meta itemprop="height" content="1101">
        <meta itemprop="description" content="A quintet of HTML ‘eggs’ singing in front of a microphone">
					<picture>
						
						<source srcset="/d/_made/d/voice-agents_960_551_81.jpg 1x, /d/_made/d/voice-agents_1920_1101_81.jpg 2x" media="(min-width: 600px)">
						<img src="/d/_made/d/voice-agents_960_551_81.jpg" alt="A quintet of HTML ‘eggs’ singing in front of a microphone" itemprop="contentUrl">
						 
					</picture>
					
				
				<p class="illustrator-credit" itemprop="contributor" itemscope itemtype="http://schema.org/Person">Illustration by
					
					
					<a itemprop="sameAs" href="/author/dmacpherson"><span itemprop="name">Dougal MacPherson</span></a>
					
					
				</p>
				
				
				</figure>
				

				<h1 class="entry-title" itemprop="headline">Conversations with Robots: Voice, Smart Agents &amp; the Case for Structured Content</h1>

				<p class="entry-details">
					<meta itemprop="description" content="Why structured content is now necessary to ensure the accuracy and integrity of your content across the evolving digital landscape"/>

					<span itemprop="author" itemscope itemtype="http://schema.org/Person">by <a itemprop="sameAs" class="author" rel="author" href="/author/andyfitzgerald"><span itemprop="name">Andy Fitzgerald</span></a></span>

					<time class="pubdate updated" datetime="2019-01-10T09:55:00-05:00" itemprop="datePublished">January 10, 2019</time>
					<meta itemprop="dateModified" content="2019-01-10T11:46:56-05:00">

					<span class="entry-meta optional-break">

						Published in <a href="/topic/html"><span itemprop="about">HTML</span></a>, <a href="/topic/content-strategy"><span itemprop="about">Content Strategy</span></a>, <a href="/topic/information-architecture"><span itemprop="about">Information Architecture</span></a>


					</span>
				</p>

				 

			</header>

			 

			

			

			<div class="main-content" itemprop="articleBody">

			

			

			

				<p>In late 2016, <a href="https://www.gartner.com/smarterwithgartner/gartner-predicts-a-virtual-world-of-exponential-change/">Gartner predicted</a> that 30 percent of web browsing sessions would be done without a screen by 2020. Earlier the same year, <a href="https://www.campaignlive.co.uk/article/just-say-it-future-search-voice-personal-digital-assistants/1392459">Comscore had predicted</a> that half of all searches would be voice searches by 2020. Though there’s <a href="https://econsultancy.com/the-state-of-mobile-voice-search-in-2018/">recent evidence</a> to suggest that the 2020 picture may be more complicated than these broad-strokes projections imply, we’re already seeing the impact that voice search, artificial intelligence, and smart software agents like Alexa and Google Assistant are making on the way information is found and consumed on the web. </p>

				<div class="aside-breaker"><b>Article Continues Below</b></div>

				<aside class="content-minutiae">
					
                  <a href="#comments" class="comment-bubble comment-bubble-articles">
                     <span>no comments yet</span>
                  </a>

					


                  <div class="minutiae-block share-block">
                     <h1 class="propagation-enablers" aria-hidden="true">Share this on</h1>
                     <ul class="propagation-enablers">
                        <li class="circle-twitter"><a href="http://twitter.com/intent/tweet?url=http://alistapart.com/article/conversations-with-robots&text=Conversations+with+Robots%3A+Voice%2C+Smart+Agents+%26amp%3B+the+Case+for+Structured+Content&via=alistapart" data-trackevent="Share: Twitter" title="share this on Twitter"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="0 0 274 224" enable-background="new 0 0 274 224" xml:space="preserve">
                        <path d="M273.7,27.2c-10.1,4.5-20.9,7.5-32.2,8.8c11.6-6.9,20.5-17.9,24.7-31c-10.8,6.4-22.8,11.1-35.6,13.6
                           C220.3,7.7,205.7,0.9,189.6,0.9c-31,0-56.1,25.1-56.1,56.1c0,4.4,0.5,8.7,1.5,12.8C88.3,67.4,47,45.1,19.3,11.2
                           c-4.8,8.3-7.6,17.9-7.6,28.2c0,19.5,9.9,36.6,25,46.7c-9.2-0.3-17.8-2.8-25.4-7c0,0.2,0,0.5,0,0.7c0,27.2,19.3,49.8,45,55
                           c-4.7,1.3-9.7,2-14.8,2c-3.6,0-7.1-0.4-10.6-1c7.1,22.3,27.9,38.5,52.4,39c-19.2,15-43.4,24-69.7,24c-4.5,0-9-0.3-13.4-0.8
                           c24.8,15.9,54.3,25.2,86,25.2c103.2,0,159.6-85.5,159.6-159.6c0-2.4-0.1-4.9-0.2-7.3C256.7,48.3,266.2,38.5,273.7,27.2z"/>
                        </svg></a></li><!--
                        --><li class="circle-facebook"><a href="http://www.facebook.com/sharer.php?u=http://alistapart.com/article/conversations-with-robots&t=Conversations+with+Robots%3A+Voice%2C+Smart+Agents+%26amp%3B+the+Case+for+Structured+Content" data-trackevent="Share: Facebook" title="share this on Facebook"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-95.6 286.6 114 220" enable-background="new -95.6 286.6 114 220" xml:space="preserve">
                        <path id="f" d="M-21.6,505.9v-99.8h33.5l5-38.9h-38.5v-24.8c0-11.3,3.1-18.9,19.3-18.9l20.6,0v-34.8
                           c-3.6-0.5-15.8-1.5-30-1.5c-29.7,0-50,18.1-50,51.4v28.7h-33.6v38.9h33.6v99.8H-21.6z"/>
                        </svg></a></li><!--
                        --><li class="circle-google"><a href="https://plus.google.com/share?url=http://alistapart.com/article/conversations-with-robots" data-trackevent="Share: Google+" title="share this on Google+"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-212.7 354.2 84 86" enable-background="new -212.7 354.2 84 86" xml:space="preserve">
                        <g>
                           <g>
                              <path d="M-168.4,403.2l-4-3.1c-1.2-1-2.9-2.3-2.9-4.8c0-2.4,1.7-4,3.1-5.4c4.6-3.7,9.3-7.5,9.3-15.7
                                 c0-8.4-5.3-12.9-7.8-15h6.8l7.2-4.5h-21.8c-6,0-14.6,1.4-20.9,6.6c-4.8,4.1-7.1,9.8-7.1,14.8c0,8.6,6.6,17.4,18.3,17.4
                                 c1.1,0,2.3-0.1,3.5-0.2c-0.5,1.3-1.1,2.4-1.1,4.3c0,3.4,1.8,5.5,3.3,7.5c-5,0.3-14.3,0.9-21.1,5.1c-6.5,3.9-8.5,9.5-8.5,13.5
                                 c0,8.2,7.7,15.8,23.8,15.8c19,0,29.1-10.5,29.1-20.9C-159.1,411.1-163.5,407.3-168.4,403.2z M-182.9,390.5
                                 c-9.5,0-13.8-12.3-13.8-19.7c0-2.9,0.5-5.9,2.4-8.2c1.8-2.2,4.9-3.7,7.7-3.7c9.2,0,13.9,12.4,13.9,20.4c0,2-0.2,5.5-2.8,8.1
                                 C-177.2,389.1-180.1,390.5-182.9,390.5z M-182.8,435c-11.8,0-19.5-5.7-19.5-13.5c0-7.9,7.1-10.5,9.5-11.4
                                 c4.6-1.6,10.6-1.8,11.6-1.8c1.1,0,1.7,0,2.5,0.1c8.4,6,12.1,9,12.1,14.6C-166.5,429.9-172.2,435-182.8,435z"/>
                              <polygon points="-140.5,390.3 -140.5,379.2 -146,379.2 -146,390.3 -157,390.3 -157,395.8 -146,395.8 -146,407
                                 -140.5,407 -140.5,395.8 -129.4,395.8 -129.4,390.3 		"/>
                           </g>
                        </g>
                        </svg></a></li>
                     </ul>
                  </div>


					 
          <a href="https://www.patreon.com/alistapart" class="patreon-bubble">
            Become a patron
          </a>
				</aside>


			<div class="utility-side-bar"> <!-- <div class="banner banner-wide pantheon">
  <a href="http://sps.northwestern.edu/ala">
    <img class="banner-logo" src="/components/assets/img/northwesten-logo_250x90.gif" alt="Northwestern Logo">
    <p>Prepare for leadership roles at the intersection of design and technology in Northwestern’s online MS in Information Design
      & Strategy program.</p>
  </a>
</div>  -->
<div class="banner banner-wide pantheon">
  <a href="http://cloudinary.rocks/ala">
    <img class="banner-logo" src="/components/assets/img/cloudinary_vertical_logo_for_white_bg.jpg" alt="Cloudinary Logo">
    <p>Want the best way to store and serve images and videos? Try Cloudinary. Get your own free account.</p>
  </a>
</div>
<div class="banner a-book-apart"> 
  <a href="https://abookapart.com">
    <img class="banner-logo" src="https://alistapart.com/components/assets/img/logo_a-book-apart-color.png" alt="">
    <p>A Book Apart:<br> Brief books for people who make websites.</p>
  </a>
</div>
<div class="banner">  
  <a href="https://aneventapart.com/">
    <img class="banner-logo" src="https://alistapart.com/components/assets/img/AEA_2017_80x80.png" alt="">
    <p>An Event Apart:<br> 3 days of design, code, and content for web & UX designers & devs.</p>
  </a>
</div></div><p>In addition to the indexing function that traditional search engines perform, smart agents and AI-powered search algorithms are now bringing into the mainstream two additional modes of accessing information: aggregation and inference. As a result, design efforts that focus on creating visually effective pages are no longer sufficient to ensure the integrity or accuracy of content published on the web. Rather, by focusing on providing access to information in a structured, systematic way that is legible to both humans and machines, content publishers can ensure that their content is both accessible and accurate in these new contexts, whether or not they’re producing chatbots or tapping into AI directly. In this article, we’ll look at the forms and impact of structured content, and we’ll close with a set of resources that can help you get started with a structured content approach to information design.</p>

<h2>The role of structured content</h2>

<p>In their recent book, <a href="https://www.oreilly.com/library/view/designing-connected-content/9780134764061/"><cite>Designing Connected Content</cite></a>, Carrie Hane and Mike Atherton define structured content as content that is “planned, developed, and connected outside an interface so that it’s ready for any interface.” A structured content design approach frames content resources—like articles, recipes, product descriptions, how-tos, profiles, etc.—not as pages to be found and read, but as packages composed of small chunks of content data that all relate to one another in meaningful ways. </p>

<p>In a structured content design process, the relationships between content chunks are explicitly defined and described. This makes both the content chunks and the relationships between them legible to algorithms. Algorithms can then interpret a content package as the “page” I’m looking for—or remix and adapt that same content to give me a list of instructions, the number of stars on a review, the amount of time left until an office closes, and any number of other concise answers to specific questions. </p>

<p>Structured content is already a mainstay of many types of information on the web. Recipe listings, for instance, have been based on structured content for years. When I search, for example, “bouillabaisse recipe” on Google, I’m provided with a standard list of links to recipes, as well as an overview of recipe steps, an image, and a set of tags describing one example recipe:</p>

<figure>
<img src="/d/convo-w-robots/fig1-a.jpg" alt="Google search results page for a bouillabaisse recipe including an image, numbered directions, and tags.">
<figcaption>A “featured snippet” for allrecipes.com on the Google results page.</figcaption>
</figure>

<figure>
<img src="/d/convo-w-robots/fig1-b.jpg" alt="Google Structured Data Testing tool showing the markup for a bouillabaisse recipe website on the left half of the screen and the structured data attributes and values for structured content on the right half of the screen.">
<figcaption>The same allrecipes.com page viewed in <a href="https://search.google.com/structured-data/testing-tool/">Google’s Structured Data Testing Tool</a>. The pane on the right shows the machine-readable values.</figcaption>
</figure>

<p>This “featured snippet” view is possible because the content publisher, allrecipes.com, has broken this recipe into the smallest meaningful chunks appropriate for this subject matter and audience, and then expressed information about those chunks and the relationships between them in a machine-readable way. In this example, allrecipes.com has used both semantic HTML and <a href="http://linkeddata.org/faq">linked data</a> to make this content not merely a page, but also legible, accessible data that can be accurately interpreted, adapted, and remixed by algorithms and smart agents. Let’s look at each of these elements in turn to see how they work together across indexing, aggregation, and inference contexts.</p>

<h2>Software agent search and semantic HTML</h2>

<p>Semantic HTML is markup that communicates information about the meaningful relationships between document elements, as opposed to simply describing how they should look on screen. Semantic elements such as heading tags and list tags, for instance, indicate that the text they enclose is a heading (<code>&lt;h1&gt;</code>) for the set of list items (<code>&lt;li&gt;</code>) in the ordered list (<code>&lt;ol&gt;</code>) that follows.</p>

<figure>
<img src="/d/convo-w-robots/fig2.jpg" alt="A combined HTML code editor and preview window showing markup and results for heading, ordered list, and list item HTML tags.">
</figure>

<p>HTML structured in this way is both presentational and semantic because people know what headings and lists look like and mean, and algorithms can recognize them as elements with defined, interpretable relationships.</p>

<p>HTML markup that focuses only on the <em>presentational</em> aspects of a “page” may look perfectly fine to a human reader but be completely illegible to an algorithm. Take, for example, the <a href="https://www.boston.gov/">City of Boston</a> website, redesigned a few years ago in collaboration with top-tier design and development partners. If I want to find information about how to pay a parking ticket, a link from the home page takes me directly to the “How to Pay a Parking Ticket” screen (scrolled to show detail):</p>

<figure>
<img src="/d/convo-w-robots/fig3.jpg" alt="The City of Boston website's “How to Pay a Parking Ticket” page, showing a tabbed view of ways to pay and instructions for the first of those ways, paying online.">
</figure>

<p>As a human reading this page, I easily understand what my options are for paying: I can pay online, in person, by mail, or over the phone. If I ask Google Assistant how to pay a parking ticket in Boston, however, things get a bit confusing:</p>

<figure>
<img src="/d/convo-w-robots/fig4.jpg" alt="Google Assistant app on iPhone with the results of a “how do I pay a parking ticket in Boston” query, showing results only weakly related to the intended content.">
</figure>

<p>None of the links provided in the Google Assistant results take me directly to the “How to Pay a Parking Ticket” page, nor do the descriptions clearly let me know I’m on the right track. (I didn’t ask about requesting a hearing.) This is because the content on the City of Boston parking ticket page is styled to communicate content relationships visually to human readers but is not structured semantically in a way that also communicates those relationships to inquisitive algorithms.</p>

<p>The City of Seattle’s “Pay My Ticket” page, though it lacks the polished visual style of Boston’s site, also communicates parking ticket payment options clearly to human visitors:</p>

<figure>
<img src="/d/convo-w-robots/fig5.jpg" alt="The City of Seattle website‘s “Pay My Ticket” page, showing four methods to pay a parking ticket in a simple, all-text layout.">
</figure>

<p>The equivalent Google Assistant search, however, offers a much more helpful result than we see with Boston. In this case, the Google Assistant result links directly to the “Pay My Ticket” page and also lists several ways I can pay my ticket: online, by mail, and in person.</p>

<figure>
<img src="/d/convo-w-robots/fig6.jpg" alt="Google Assistant app on iPhone with the results of a “how do I pay a parking ticket in Seattle” query, showing nearly the same results as on the desktop web page referenced above.">
</figure>

<p>Despite the visual simplicity of the City of Seattle parking ticket page, it more effectively ensures the integrity of its content across contexts because it’s composed of structured content that is marked up semantically. “Pay My Ticket” is a level-one heading (<code>&lt;h1&gt;</code>), and each of the options below it are level-two headings (<code>&lt;h2&gt;</code>), which indicate that they are subordinate to the level-one element.</p>

<figure>
<img src="/d/convo-w-robots/fig7.jpg" alt="The City of Seattle website’s “Pay My Ticket” page, with the HTML heading elements outlined and labeled for illustration.">
</figure>

<p>These elements, when designed well, communicate information hierarchy and relationships visually to readers, and semantically to algorithms. This structure allows Google Assistant to reasonably surmise that the text in these <code>&lt;h2&gt;</code> headings represents payment options under the <code>&lt;h1&gt;</code> heading “Pay My Ticket.”</p>

<p>While this use of semantic HTML offers distinct advantages over the “page display” styling we saw on the City of Boston’s site, the Seattle page also shows a weakness that is typical of manual approaches to semantic HTML. You’ll notice that, in the Google Assistant results, the “Pay by Phone” option we saw on the web page was not listed. If we look at the markup of this page, we can see that while the three options found by Google Assistant are wrapped in both <code>&lt;strong&gt;</code> and <code>&lt;h2&gt;</code> tags, “Pay by Phone” is only marked up with an <code>&lt;h2&gt;</code>. This irregularity in semantic structure may be what’s causing Google Assistant to omit this option from its results.</p>

<figure>
<img src="/d/convo-w-robots/fig8.jpg" alt="The City of Seattle website’s 'Pay My Ticket' page, with two HTML heading elements outlined and labeled for illustration, and an open inspector panel, where we can see that the headings look the same to viewers but are marked up differently in the code.">
</figure>

<p>Although each of these elements would look the same to a sighted human creating this page, the machine interpreting it reads a difference. While WYSIWYG text entry fields can theoretically support semantic HTML, in practice they all too often fall prey to the idiosyncrasies of even the most well-intentioned content authors. By making meaningful content structure a core element of a site’s content management system, organizations can create semantically correct HTML for every element, every time. This is also the foundation that makes it possible to capitalize on the rich relationship descriptions afforded by linked data.</p>

<h2>Linked data and content aggregation</h2>

<p>In addition to finding and excerpting information, such as recipe steps or parking ticket payment options, search and software agent algorithms also now aggregate content from multiple sources by using linked data.</p>

<p>In its most basic form, <em>linked data</em> is “<a href="http://linkeddata.org/faq">a set of best practices for connecting structured data on the web</a>.” Linked data extends the basic capabilities of semantic HTML by describing not only what kind of thing a page element is (“Pay My Ticket” is an <code>&lt;h1&gt;</code>), but also the real-world concept that thing represents: this <code>&lt;h1&gt;</code> represents a “pay action,” which inherits the structural characteristics of “trade actions” (the exchange of goods and services for money) and “actions” (activities carried out by an agent upon an object). Linked data creates a richer, more nuanced description of the relationship between page elements, and it provides the structural and conceptual information that algorithms need to meaningfully bring data together from disparate sources. </p>

<p>Say, for example, that I want to gather more information about two recommendations I’ve been given for orthopedic surgeons. A search for a first recommendation, Scott Ruhlman, MD, brings up a set of links as well as a <a href="https://en.wikipedia.org/wiki/Knowledge_Graph">Knowledge Graph</a> info box containing a photo, location, hours, phone number, and reviews from the web. </p>

<figure>
<img src="/d/convo-w-robots/fig9.jpg" alt="Google search results page for Scott Ruhlman, MD, showing a list of standard links and an info box with an image, a map, ratings, an address, and reviews information.">
</figure>

<p>If we run Dr. Ruhlman’s Swedish Hospital profile page through Google’s <a href="https://search.google.com/structured-data/testing-tool">Structured Data Testing Tool</a>, we can see that content about him is structured as small, discrete elements, each of which is marked up with descriptive types and attributes that communicate both the meaning of those attributes’ values and the way they fit together as a whole—all in a machine-readable format.</p>

<figure>
<img src="/d/convo-w-robots/fig10.jpg" alt="Google Structured Data Testing tool, showing the markup for Dr. Ruhlman's profile page on the left half of the screen, and the structured data attributes and values for the structured content on that page on the right half of the screen.">
</figure>

<p>In this example, Dr. Ruhlman’s profile is marked up with microdata based on the <a href="https://schema.org/">schema.org</a> vocabulary. Schema.org is a collaborative effort backed by Google, Yahoo, Bing, and Yandex that aims to create a common language for digital resources on the web. This structured content foundation provides the semantic base on which additional content relationships can be built. The Knowledge Graph info box, for instance, includes Google reviews, which are not part of Dr. Ruhlman’s profile, but which have been aggregated into this overview. The overview also includes an interactive map, made possible because Dr. Ruhlman’s office location is machine-readable.</p>

<figure>
<img src="/d/convo-w-robots/fig11.jpg" alt="Google search results info box for Dr. Ruhlman, showing an photo; a map; ratings; an address; reviews; buttons to ask a question, leave a review, and add a photo; and other people searched for.">
</figure>

<p>The search for a second recommendation, Stacey Donion, MD, provides a very different experience. Like the City of Boston site above, Dr. Donion’s profile on the Kaiser Permanente website is perfectly intelligible to a sighted human reader. But because its markup is entirely presentational, its content is virtually invisible to software agents.</p>

<figure>
<img src="/d/convo-w-robots/fig12.jpg" alt="Google search results page for Dr. Donion, showing a list of standard links for Dr. Donion, and a 'Did you mean: Dr Stacy Donlon MD' link at the top. There is a Google info box, as with the previous search results page example. But in this case the box does not display information about the doctor we searched for, Dr. Donion, but rather for 'Kaiser Permanente Orthopedics: Morris Joseph MD.'">
</figure>

<p>In this example, we can see that Google is able to find plenty of links to Dr. Donion in its standard index results, but it isn’t able to “understand” the information about those sources well enough to present an aggregated result. In this case, the Knowledge Graph knows Dr. Donion is a Kaiser Permanente physician, but it pulls in the wrong location and the wrong physician’s name in its attempt to build a Knowledge Graph display. </p>

<p>You’ll also notice that while Dr. Stacey Donion is an exact match in all of the listed search results—which are numerous enough to fill the first results page—we’re shown a “did you mean” link for a different doctor. Stacy Donlon, MD, is a neurologist who practices at MultiCare Neuroscience Center, which is not affiliated with Kaiser Permanente. Multicare does, however, provide semantic and linked data-rich profiles for their physicians. </p>

<h2>Voice queries and content inference</h2>

<p>The increasing prevalence of voice as a mode of access to information makes providing structured, machine-intelligible content all the more important. Voice and smart software agents are not just freeing users from their keyboards, they’re changing user behavior. According to <a href="http://www.lsainsider.com/how-voice-search-queries-differ-from-non-voice-queries/archives">LSA Insider</a>, there are several important differences between voice queries and typed queries. Voice queries tend to be:</p>

<ul>
<li>longer;</li>
<li>more likely to ask who, what, and where;</li>
<li>more conversational;</li>
<li>and more specific.</li>
</ul>

<p>In order to tailor results to these more specifically formulated queries, software agents have begun inferring intent and then using the linked data at their disposal to assemble a targeted, concise response. If I ask Google Assistant what time Dr. Ruhlman’s office closes, for instance, it responds, “Dr. Ruhlman’s office closes at 5 p.m.,” and displays this result: </p>

<figure>
<img src="/d/convo-w-robots/fig13.jpg" alt="Google Assistant app on iPhone with the results of a “what time does dr. ruhlman office close” query. The results displayed include a card with “8:30AM–5:00PM” and the label, “Dr. Ruhlman Scott MD, Tuesday hours,” as well as links to call the office, search on Google, get directions, and visit a website. Additionally, there are four buttons labeled with the words “directions,” “phone number,” and “address,” and a thumbs-up emoji.">
</figure>

<p>These results are not only aggregated from disparate sources, but are interpreted and remixed to provide a customized response to my specific question. Getting directions, placing a phone call, and accessing Dr. Ruhlman’s profile page on swedish.org are all at the tips of my fingers. </p>

<p>When I ask Google Assistant what time Dr. Donion’s office closes, the result is not only less helpful but actually points me in the wrong direction. Instead of a targeted selection of focused actions to follow up on my query, I’m presented with the hours of operation and contact information for MultiCare Neuroscience Center.</p>

<figure>
<img src="/d/convo-w-robots/fig14.jpg" alt="Google Assistant app on iPhone with the results of a “what time does Doc Dr Stacey donion office close” query. The results displayed include a card with “8AM–5PM” and the label “MulitCare Neuroscience Center, Monday hours,” as well as links to call the office, search on Google, get directions, or visit a website.">
</figure>

<p>MultiCare Neuroscience Center, you’ll recall, is where Dr. Donlon—the neuroscientist Google thinks I may be looking for, not the orthopedic surgeon I’m actually looking for—practices. Dr. Donlon’s profile page, much like Dr. Ruhlman’s, is semantically structured and marked up with linked data. </p>

<p>To be fair, subsequent trials of this search did produce the generic (and partially incorrect) practice location for Dr. Donion (“Kaiser Permanente Orthopedics: Morris Joseph MD”). It is possible that through repeated exposure to the search term “Dr. Stacey Donion,” Google Assistant fine-tuned the responses it provided. The initial result, however, suggests that smart agents may be at least partially susceptible to the same <a href="https://en.wikipedia.org/wiki/Availability_heuristic">availability heuristic</a> that affects humans, wherein the information that is easiest to recall often seems the most correct.</p>

<p>There’s not enough evidence in this small sample to support a broad claim that algorithms have “cognitive” bias, but even when we allow for potentially confounding variables, we can see the compounding problems we risk by ignoring structured content. “Donlon,” for example, may well be a more common name than “Donion” and may be easily mistyped on a QWERTY keyboard. Regardless, the Kaiser Permanente result we’re given above for Dr. Donion is for the wrong physician. Furthermore, in the Google Assistant voice search, the interaction format doesn’t verify whether we meant Dr. Donlon; it just provides us with her facility’s contact information. In these cases, providing clear, machine-readable content can only work to our advantage.</p>

<h2>The business case for structured content design</h2>

<p>In 2012, content strategist Karen McGrane wrote that “you don’t get to decide which platform or device your customers use to access your content: <em>they</em> do.”</p>

<p>This statement was intended to help designers, strategists, and businesses prepare for the imminent rise of mobile. It continues to ring true for the era of linked data. With the growing prevalence of smart assistants and voice-based queries, an organization’s website is less and less likely to be a potential visitor’s first encounter with rich content. In many cases—such as finding location information, hours, phone numbers, and ratings—this pre-visit engagement may be a user’s only interaction with an information source. </p>

<p>These kinds of quick interactions, however, are only one small piece of a much larger issue: linked data is increasingly key to maintaining the integrity of content online. The organizations I’ve used as examples, like the hospitals, government agencies, and colleges I’ve consulted with for years, don’t measure the success of their communications efforts in page views or ad clicks. Success for them means connecting patients, constituents, and community members with services and accurate information about the organization, wherever that information might be found. This communication-based definition of success readily applies to virtually any type of organization working to further its business goals on the web.</p>

<p>The model of building pages and then expecting users to discover and parse those pages to answer questions, though time-tested in the pre-voice era, is quickly becoming insufficient for effective communication. It precludes organizations from participating in emergent patterns of information seeking and discovery. And—as we saw in the case of searching for information about physicians—it may lead software agents to make inferences based on insufficient or erroneous information, potentially routing customers to competitors who communicate more effectively. </p>

<p>By communicating clearly in a digital context that now includes aggregation and inference, organizations are more effectively able to speak to their users where users actually are, be it on a website, a search engine results page, or a voice-controlled digital assistant. They are also able to maintain greater control over the accuracy of their messages by ensuring that the correct content can be found and communicated across contexts. </p>

<h2>Getting started: who and how</h2>

<p>Design practices that build bridges between user needs and technology requirements to meet business goals are crucial to making this vision a reality. Information architects, content strategists, developers, and experience designers all have a role to play in designing and delivering effective structured content solutions. </p>

<p>Practitioners from across the design community have shared a wealth of resources in recent years on creating content systems that work for humans and algorithms alike. To learn more about implementing a structured content approach for your organization, these books and articles are a great place to start:</p>

<ul>
<li><a href="https://rosenfeldmedia.com/books/content-everywhere/"><cite>Content Everywhere</cite></a>, Sara Wachter-Boettcher</li>
<li>“<a href="https://alistapart.com/article/content-modelling-a-master-skill">Content Modelling: A Master Skill</a>,” Rachel Lovinger</li>
<li><a href="https://abookapart.com/products/content-strategy-for-mobile"><cite>Content Strategy for Mobile</cite></a>, Karen McGrane</li>
<li><a href="https://www.oreilly.com/library/view/designing-connected-content/9780134764061/"><cite>Designing Connected Content</cite></a>, Carrie Hane and Mike Atherton</li>
</ul>

				

			

			 

				

				
				<!-- START RELATED SIDEBAR -->
				
				
				<aside id="related" class="sidebar var1 nocontent">
				<i class="widget-branding ala"></i>
				<!-- if this article does not have a follow up show recent articles by this author -->
				
				
					
							

							
							
				
				<!-- end first block -->
				
				<!-- show categories -->
				
					
	
   <section class="related-articles">



   <h1 class="primary-cat-header">
      Further reading about
      <a href="/topic/content-strategy" data-trackevent="Related sidebar: Related by category">Content Strategy</a>
   </h1>

   <article>



<h2><a href="https://alistapart.com/article/the-faq-as-advice-column">The FAQ as Advice Column</a></h2>
   <p>It may be easy to turn your nose up at FAQs, but Caroline Roberts can help you take the simple Q&amp;A format to the next level.</p><h2><a href="https://alistapart.com/article/no-more-faqs-create-purposeful-information-for-a-more-effective-user-experi">No More FAQs: Create Purposeful Information for a More Effective User Experience</a></h2>
   <p>The all-too-common FAQ is the antithesis of effective user experience, but it’s easy to avoid (or improve) with a little guidance.</p>

   </article>

</section>
 
   


				
				
					
				
				</aside>
				<!-- END RELATED SIDEBAR -->
				

				<footer class="entry-footer nocontent">
				<h1>About the Author</h1>

				<div class="byline author vcard">

					<a class="photo" href="/author/andyfitzgerald"><img src="/d/_made/pix/authors/photos/andy-fitz_120_120_c1.jpg" alt="Image of Andy Fitzgerald"></a>

					<h2><a class="fn" href="/author/andyfitzgerald">Andy Fitzgerald</a></h2>

					<div class="author-bio">Andy Fitzgerald is an independent designer whose practice focuses on user research, information architecture, interaction design, and prototyping. He works with organizations of all sizes to create elegant, purpose-driven solutions to complex information problems. Andy is an active member of the IA and UX communities, and speaks and facilitates workshops at conferences all over the world.</div>

					
						</ul>

				</div>
				
				 

				</footer>

				
<aside class="promo-box email-promo">
   <b>Get our latest articles in your inbox.</b> <a href="/email-signup" data-trackevent="Post-article: email promo">Sign up for email alerts</a>.
</aside>

			</div>

			<div class="post-article">

				<div class="column-holder unequal-columns">

					<section id="comments" class="column comment-holder">

							<h1 class="classy" itemprop="commentCount" data-url-title="conversations-with-robots">
							 
							<span>No Comments (yet)<span>
							</h1>

							
							<span id="load-comments" data-url-title="conversations-with-robots"></span>

							
								<ol class="article-comments form">

	<li id="commenter-signin" class="commenter-signin no-comments">

	<h3 class="form-heading">Got something to say?</h3>
 	
 	<div class="outer-ajax-container">
	
	 	<div class="ajax-container">
	 	
			<form id="login_form" class="sign-in-form" name="login_form" method="post" action="https://alistapart.com?ACT=159"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="159" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="64cd525d0024e5d09f33966afd2eb2bc53ca2ca9" />
</div>



		
			<fieldset>

		    	<legend class="center">Sign in to add your voice to the discussion.</legend>

				<p>
					<label for="login-name-here">Email (<a id="register" class="history-nav" data-tabto="forgot-password" href="/tools/register" target="_blank">Need an account?</a>)</label>
					<input
						type="text"
						id="login-name-here"
						name="username"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your email address?"
						data-tabmaster="true"
						data-tabto="login_password"
						required>
				</p>

				<p class="password-field">
					<label for="login_password">Password (<a id="forgot-password" class="history-nav" data-tabto="comment-submit" href="/tools/forgot-password" target="_blank">Forgot?</a>)</label>
					<input
						type="password"
						id="login_password"
						name="password"
						required="required"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your password?"
						data-tabmaster="true"
						data-tabto="register"
						required>
				</p>
				
				<p class="screen-reader">
					<label for="honeepot">Don't put anything here</label>
					<input 
						type="text" 
						id="honeepot" 
						name="honeepot"
						data-tabmaster="false">
				</p>

				<p id="comment-submit-holder">
					<input 
						type="submit" 
						id="comment-submit"
						data-tabmaster="true"
						class="button primary float-left" 
						value="Submit">
				</p>

			</fieldset>
		
		
</form>
<script type="text/javascript">
$(document).ready(function(){
    $('#login_form').on('submit', function(event){
        event.preventDefault();
        if (!supports_history_api()) { return; }
        AlaAuth.spinnerStart();
           
            $.post(
                'https://alistapart.com?ACT=159',
                $('#login_form').serialize(),
                function(msg) {
                    AlaAuth.spinnerStop();
        
            if (msg.indexOf('You are now logged in.') >= 0)
            {    
           
                $.get('https://alistapart.com/ajax/comment-form/18903/article/conversations-with-robots', 
                function(ret){
                    ajaxContainer.replaceWith(ret);
                });
                AlaPostLoad.loadTranslations();
                history.pushState(
                    states.commentform, '', states.site_url + states.segments + '/' + states.commentform 
                );
              
                } else {
                    var out = /<div id="ee-errors"><ul>[\s\S]*<\/ul><\/div>/.exec(msg);
                    if ($('.error-message.none').length == $('.error-message').length) {
                        if(out === null) {
                            AlaAuth.alertMsg('This form has expired. Please refresh and try again.');
                            $.get('https://alistapart.com/ajax/comment-form/18903/article/conversations-with-robots', 
                            function(ret){
                                ajaxContainer.replaceWith(ret);
                            });
                            $('.custom-modal').remove();
                        }else {
                            AlaAuth.alertMsg(out);
                        }
                    }                   
                }
                return false;
            }
        );
        return false;
    });
});
</script>
    

		<script src="https://alistapart.com/components/assets/js/ajax-functions.js"></script>

		<script type="text/javascript">

		var states = {
			//globals
			commentsignin: 'comment-sign-in',
			register: 'register',
			password: 'forgot-password',
			commentform: 'comment-form',
			//segments
			site_url: 'https://alistapart.com',
			
			
			segments: '/article/conversations-with-robots', 
			
			tmpl_path: /ajax/,
			entry_id: '18903',
			page: 'article'
		}

		</script>

		</div>

		<div class="placeholder loader">
			<div class="top-header animated-background"></div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<!-- <div class="button primary">Submit</div> -->
		</div>

	</div>
 

	<script type="text/javascript">

	AlaAuth.loadTemplate (
		states.commentsignin
	);

	</script>
	
	</li>

</ol>
							 

					</section>

					<aside class="column more-content">

						
						<h1 class="classy">More from ALA</h1>

						<article class="item-summary article">

							<h4 class="summary-title"><a href="/article/taming-data-with-javascript">Taming Data with JavaScript</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/briangreig">Brian Greig</a>
							
							
							</p>

							<p>Processing data in the browser via JavaScript occasionally makes sense. Learn the ins, outs, and best practices.</p>

							<footer class="byline">
								
								
   
<a href="/topic/javascript">JavaScript</a>



   

								·
								<time class="pubdate updated" datetime="2018-12-20T09:55:00-05:00">December 20, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/designing-for-interaction-modes">Designing for Interaction Modes</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/andrewgrimes">Andrew Grimes</a>
							
							
							</p>

							<p>How focusing on interaction modes can bring dark patterns into the light and help you deliver a better user experience.</p>

							<footer class="byline">
								
								
   
<a href="/topic/user-experience">User Experience</a>



   

								·
								<time class="pubdate updated" datetime="2018-12-13T09:18:00-05:00">December 13, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/progressive-web-apps-excerpt">Progressive Web Apps: The Case for PWAs</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/jason-grigsby">Jason Grigsby</a>
							
							
							</p>

							<p>In this excerpt from Progressive Web Apps, Jason Grigsby covers the business case for going PWA.</p>

							<footer class="byline">
								
								
   

         <a href="/topic/state-of-the-web">State of the Web</a>



 
   
								·
								<time class="pubdate updated" datetime="2018-12-06T10:00:00-05:00">December 6, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/var-to-jit">var to JIT</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/kevinsmith">Kevin Smith</a>
							
							
							</p>

							<p>Through the power of JavaScript, we learn how the browser breaks down pages and speeds up processes so we can write better code.</p>

							<footer class="byline">
								
								
   
<a href="/topic/browsers">Browsers</a>



   

								·
								<time class="pubdate updated" datetime="2018-11-29T08:36:00-05:00">November 29, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/braces-to-pixels">Braces to Pixels</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/gregwhitworth">Greg Whitworth</a>
							
							
							</p>

							<p>In this installment of our &#8220;From URL to Interactive&#8221; series, Greg Whitworth explains how cascading actually works, and then some.</p>

							<footer class="byline">
								
								
   
<a href="/topic/browsers">Browsers</a>



   

								·
								<time class="pubdate updated" datetime="2018-11-15T10:05:00-05:00">November 15, 2018</time>
							</footer>

						</article>

					</aside>

				</div>

			</div>

		</article>



	</div>

			<footer class="global-footer" aria-label="Footer" itemscope itemtype="https://schema.org/WebPage">
			<meta itemprop="headline" content="A List Apart">
			<p class="deadly-subtitle" itemprop="alternativeHeadline">For people who make websites.</p>

			<ul class="inline-items" itemscope itemtype="http://schema.org/SiteNavigationElement">
				<li><a href="/about" itemprop="url">About</a></li>
				<li><a href="/authors" itemprop="url">Authors</a></li>
				<li><a href="/about/masthead" itemprop="url">Masthead</a></li>
				<li><a href="/about/style-guide" itemprop="url">Style Guide</a></li>
				<li><a href="/contact" itemprop="url">Contact</a></li>
				<li><a href="/about/sponsor" itemprop="url">Sponsorships</a></li>
				<li class="head-east-young-man">

					Follow us:
					<a href="/about/rss">RSS</a> ·
					<a href="/email-signup/">Email</a> ·
					<span itemscope itemtype="http://schema.org/Organization">
					<a href="http://www.facebook.com/alistapart" itemprop="sameAs">Facebook</a> ·
					<a href="https://plus.google.com/107749003388305496076" rel="publisher" itemprop="sameAs">Google+</a> ·
					<a href="http://www.twitter.com/alistapart" itemprop="sameAs">Twitter</a>
					</span>

				</li>
			</ul>

			<aside class="promo-holder" aria-label="A List Apart partners">

				<ul class="partner-promos">
					<li>
						<a href="https://abookapart.com">
							<img src="/components/assets/img/promo_aba.jpg" alt="A Book Apart. Brief books for people who design, write, and code.">
							<p class="promo-title">A Book Apart</p>
							<p>Brief books for people who design, write, and code.</p>
							<p>Bundle books and save!</p>
							<p class="arrow">Shop now</p>
						</a>
					</li><!--

					--><li>
						<a href="https://aneventapart.com">
							<img src="/components/assets/img/promo_aea_v1.png" alt="An Event Apart. Three days of design, code, and content for people who make websites.">
							<p class="promo-title">An Event Apart</p>
							<p>Three days of design, code, and content for people who make websites.</p>
							<p class="arrow">See  this year’s schedule</p>
						</a>
					</li>
				</ul>

			</aside>

			<ul class="inline-items copyright">

				<li>
					<small>ISSN 1534-0295 · Copyright © <span itemprop="copyrightYear">1998–2019</span> <span itemprop="copyrightHolder">A List Apart & Our Authors</span></small>
					<small><a href="/about/copyright">Permissions & Copyright</a> ·	<a href="/about/privacy-policy">Privacy Policy</a> · <a href="http://webtype.com">Fonts by Webtype</a><span class="logged-in"> · </span><span class="logged-out"><a href="/tools/log-in">Log In</a> · <a href="/tools/register">Register</a></span></small></li>

				<li class="affiliates head-east-young-man">
					
					<a class="ala" href="http://alistapart.com" title="A List Apart" itemprop="sameAs">A List Apart</a>
					<a class="aea" href="http://aneventapart.com" title="An Event Apart" itemprop="relatedLink">An Event Apart</a>
					<a class="aba" href="http://abookapart.com" title="A Book Apart" itemprop="relatedLink">A Book Apart</a>
					<a class="arcus" href="https://arcustech.com" title="Hosting provided by Arcustech" itemprop="provider">Arcustech</a>

				</li>

			</ul>

		</footer>

	<!-- <div id="bsap_1031" class="bsaPROrocks ad" data-serve="C67DL2V"></div> -->
<div class="sponsor-top">
    <a href="http://cloudinary.rocks/ala">
        <div class="sponsor-logo">
            <img class="banner-logo" src="/components/assets/img/cloudinary_vertical_logo_for_white_bg.jpg" alt="Cloudinary Logo">
        </div>
        <p>Want the best way to store and serve images and videos? Try Cloudinary. Get your own free account.</p>
    </a>
</div>

	


	


	<!-- facebook login: remove the fragment #_=_ that facebook adds to the redirect_uri | remove this after social login module update -->
	<script>
		if (window.location.hash && window.location.hash == '#_=_') {
		    if (window.history && history.pushState) {
		        window.history.pushState("", document.title, window.location.pathname);
		        
		        	window.location.hash = '#comment-form';
		        
		    } else {
		        // Prevent scrolling by storing the page's current scroll offset
		        var scroll = {
		            top: document.body.scrollTop,
		            left: document.body.scrollLeft
		        };
		        window.location.hash = '';
		        // Restore the scroll offset, should be flicker free
		        document.body.scrollTop = scroll.top;
		        document.body.scrollLeft = scroll.left;
		    }
		}
	</script>

	<script src="https://alistapart.com/d/_cache/e8952a1f4e9e5593cdc3ceff2271ef14a9300c64.1482327043.js"></script>

	<!-- Google Analytics -->
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-11757054-1', 'auto');
	ga('send', 'pageview');

	</script>
	<!-- End Google Analytics -->

	<!-- start Mixpanel --><script type="text/javascript">(function(e,b){if(!b.__SV){var a,f,i,g;window.mixpanel=b;a=e.createElement("script");a.type="text/javascript";a.async=!0;a.src=("https:"===e.location.protocol?"https:":"http:")+'//cdn.mxpnl.com/libs/mixpanel-2.2.min.js';f=e.getElementsByTagName("script")[0];f.parentNode.insertBefore(a,f);b._i=[];b.init=function(a,e,d){function f(b,h){var a=h.split(".");2==a.length&&(b=b[a[0]],h=a[1]);b[h]=function(){b.push([h].concat(Array.prototype.slice.call(arguments,0)))}}var c=b;"undefined"!==
	typeof d?c=b[d]=[]:d="mixpanel";c.people=c.people||[];c.toString=function(b){var a="mixpanel";"mixpanel"!==d&&(a+="."+d);b||(a+=" (stub)");return a};c.people.toString=function(){return c.toString(1)+".people (stub)"};i="disable track track_pageview track_links track_forms register register_once alias unregister identify name_tag set_config people.set people.set_once people.increment people.append people.track_charge people.clear_charges people.delete_user".split(" ");for(g=0;g<i.length;g++)f(c,i[g]);
	b._i.push([a,e,d])};b.__SV=1.2}})(document,window.mixpanel||[]);
	mixpanel.init("204b563994d022408e4b540a66fe6136");</script><!-- end Mixpanel -->

<!--Adblock Check-->
<script type="text/javascript" src="/components/assets/js/adchecka.js"></script> <script type="text/javascript"> jQuery(document).ready(checkAds()); function checkAds(){ if (document.getElementById('adsense')!=undefined){document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Unblocked', 'false',,true]);</sc" + "ript>");}else{document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Blocked', 'true',,true]);</sc" + "ript>");}} </script>
<!--End Adblock Check-->

</body>
</html>
