<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8"><script type="text/javascript">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</script>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<title>Responsible JavaScript: Part III &#8211; A List Apart</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="A List Apart &raquo; Feed" href="https://alistapart.com/main/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/alistapart.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://alistapart.com/_static/??-eJyVkN0KwjAMhV/IGqZMr8RHka6tXbb0h6Zj7O3tfm7EIXoTTsh3DklgjAK9okEbBsUMGjlDQ0H1grBJMk3AeSJzdOiPBThAcajgs/EZcmtc8UmSG/QF6BhiQnZr/SDdICINFj1DZ3KUqgcX9EDFPaK2JjOwkUm1y5arFOtEPNMSov8J5VYmo6XW0yLR21/cj/Ir4KBQkqBgA781uz/aSZkv2PSM392tqq/n6lJVp/oF9geV5A==' type='text/css' media='all' />
<script type='text/javascript' src='https://alistapart.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZdVrKOPT4FubmZ6UWJJql5uZh5QsX2uraGpuaGBpaGpqVkWACV4IK4='></script>
<link rel='https://api.w.org/' href='https://alistapart.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://alistapart.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://alistapart.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.4" />
<link rel="canonical" href="https://alistapart.com/article/responsible-javascript-part-3/" />
<link rel="alternate" type="application/json+oembed" href="https://alistapart.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falistapart.com%2Farticle%2Fresponsible-javascript-part-3%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://alistapart.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falistapart.com%2Farticle%2Fresponsible-javascript-part-3%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">
						.site-title,
			.site-description {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}

						</style>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Responsible JavaScript: Part III" />
<meta property="og:url" content="https://alistapart.com/article/responsible-javascript-part-3/" />
<meta property="og:description" content="Convenience always comes at a price. On the web, developer convenience often means third-party JavaScript—and we pass the hefty cost on to our users. Jeremy Wagner shows us how to get and keep thir…" />
<meta property="article:published_time" content="2019-11-14T14:30:42+00:00" />
<meta property="article:modified_time" content="2019-11-13T15:48:27+00:00" />
<meta property="og:site_name" content="A List Apart" />
<meta property="og:image" content="https://alistapart.com/wp-content/uploads/2019/11/fig2.png" />
<meta property="og:image:width" content="930" />
<meta property="og:image:height" content="380" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@alistapart" />
<meta name="twitter:text:title" content="Responsible JavaScript: Part III" />
<meta name="twitter:image" content="https://alistapart.com/wp-content/uploads/2019/03/cropped-icon_navigation-laurel-512.jpg?fit=240%2C240" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://alistapart.com/wp-content/uploads/2019/03/cropped-icon_navigation-laurel-512.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://alistapart.com/wp-content/uploads/2019/03/cropped-icon_navigation-laurel-512.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://alistapart.com/wp-content/uploads/2019/03/cropped-icon_navigation-laurel-512.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://alistapart.com/wp-content/uploads/2019/03/cropped-icon_navigation-laurel-512.jpg?fit=270%2C270" />
</head>

<body class="article-template-default single single-article postid-7172132 wp-custom-logo article-responsible-javascript-part-3" itemscope itemtype="http://schema.org/Article">
<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header">
		<div class="site-branding">
			<a href="https://alistapart.com/" class="custom-logo-link" rel="home"><img width="960" height="98" src="https://alistapart.com/wp-content/uploads/2019/03/ala-logo-big.png?fit=960%2C98" class="custom-logo" alt="A List Apart" srcset="https://alistapart.com/wp-content/uploads/2019/03/ala-logo-big.png?w=960 960w, https://alistapart.com/wp-content/uploads/2019/03/ala-logo-big.png?resize=300%2C31 300w, https://alistapart.com/wp-content/uploads/2019/03/ala-logo-big.png?resize=768%2C78 768w" sizes="(max-width: 960px) 100vw, 960px" /></a>				<p class="site-title"><a href="https://alistapart.com/" rel="home"  itemscope itemtype="http://schema.org/ImageObject">A List Apart</a></p>
								<p class="site-description">For people who make websites</p>
					</div><!-- .site-branding -->

		<nav id="site-navigation" class="main-navigation" itemscope="" itemtype="http://schema.org/SiteNavigationElement">
			<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false"><span class="screen-reader-text">Primary Menu</span></button>
			<div class="menu-site-header-container"><ul id="primary-menu" class="menu"><li id="menu-item-6000493" class="ala-home-url menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6000493"><a href="https://alistapart.com" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-6000494" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-6000494"><a href="https://alistapart.com/articles/" itemprop="url"><span itemprop="name">Articles</span></a></li>
<li id="menu-item-6000495" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000495"><a href="https://alistapart.com/events/" itemprop="url"><span itemprop="name">Events</span></a></li>
<li id="menu-item-6000496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000496"><a href="https://alistapart.com/topics/" itemprop="url"><span itemprop="name">Topics</span></a></li>
<li id="menu-item-6000497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000497"><a href="https://alistapart.com/about/contribute/" itemprop="url"><span itemprop="name">Write for Us</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#" class="mlp-language-nav"><span itemprop="name">Language (English) <i class="arrow-down"></i></span></a><ul class="sub-menu mlp-languages"><li class="site-id-"2" mlp-language-nav-item menu-item menu-item-type-mlp_language menu-item-object-mlp_language"><a rel="alternate" href="https://alistapart.com/it" itemprop="url"><span itemprop="name">Italian</span></a></li></ul></li></ul></div>
			<form role="search" method="get" class="search-form" action="https://alistapart.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>		</nav><!-- #site-navigation -->

	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main">

			
<article id="post-7172132" class="post-7172132 article type-article status-publish hentry category-application-development category-code category-industry-business category-javascript category-state-of-the-web">

	<figure class="hero-wide" itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject">
		
	</figure>

	<header class="entry-header">
		
		<h1 class="entry-title" itemprop="headline">Responsible JavaScript: Part III</h1>		<div class="entry-meta">
			<span class="byline"> by <span class="author vcard" itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="url fn n" href="https://alistapart.com/author/jeremy-wagner/" itemprop="url"> <span itemprop="name">Jeremy Wagner</span></a></span></span><span class="posted-on"><time class="entry-date published" datetime="2019-11-14T09:30:42-05:00">November 14, 2019</time><time class="updated" datetime="2019-11-13T10:48:27-05:00">November 13, 2019</time></span>			<div class="entry-topic">
				<span class="cat-links">Published in <a href="https://alistapart.com/blog/topic/application-development/" rel="category tag">Application Development</a>, <a href="https://alistapart.com/blog/topic/code/" rel="category tag">Code</a>, <a href="https://alistapart.com/blog/topic/industry-business/" rel="category tag">Industry &amp; Business</a>, <a href="https://alistapart.com/blog/topic/javascript/" rel="category tag">JavaScript</a>, <a href="https://alistapart.com/blog/topic/state-of-the-web/" rel="category tag">State of the Web</a></span>			</div>
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	
	
	
	<div class="entry-content">
		
<p>You’ve done everything you thought was possible to address your website’s JavaScript problem. You <a href="https://alistapart.com/article/responsible-javascript-part-1/">relied on the web platform where you could</a>. You <a href="https://alistapart.com/article/responsible-javascript-part-2/#section9">sidestepped Babel</a> and <a href="https://alistapart.com/article/responsible-javascript-part-2/#section7">found smaller framework alternatives</a>. You whittled your application code down to its most streamlined form possible. Yet, things are just not fast enough. When websites fail to perform the way we as designers and developers expect them to, we inevitably turn on ourselves:</p>		<div class="aside-breaker"><span>Article Continues Below</span></div>
		<div class="ala-single-sidebar-wrapper">
			<span class="screen-reader-text">Article Continues Below</span>
			<aside class="ala-single-sidebar-minutiae">
				<span class="ala-comment-bubble"></span>					<div class="ala-share">
					<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 id="section1" class="sd-title">Share this:<a class="subhead-anchor" href="#section1">#section1</a></h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-7172132" class="share-facebook sd-button share-icon no-text" href="https://alistapart.com/article/responsible-javascript-part-3/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-7172132" class="share-twitter sd-button share-icon no-text" href="https://alistapart.com/article/responsible-javascript-part-3/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>					</div>
										<section id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://www.patreon.com/alistapart" class="patreon-bubble">Become a patron</a></div></section>					
							</aside>

			<aside class="ala-single-sidebar-1">
				<section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="banner">
	<a href="http://sps.northwestern.edu/ala">
	<img class="banner-logo" src="https://alistapart.com/wp-content/uploads/2019/10/NorthWestern_IDS_700x200_Logo.gif" alt="NorthWestern IDS MS logo">
	<p>Northwestern’s Online MS in Information Design and Strategy. Choose from tracks in content strategy, data science and analytics, and learning design.</p>
	</a>
</div>

<div class="banner ala-banner">
	<a href="https://abookapart.com/">				<img src="https://alistapart.com/wp-content/uploads/2019/03/logo_a-book-apart-color.png" alt="A Book Apart Logo" class="banner-logo" />
		<p>A Book Apart:<br> Brief books for people who make websites.</p>		
		</a>
</div>

<div class="banner">
	<a href="https://aneventapart.com/">				<img src="https://alistapart.com/wp-content/uploads/2019/04/AEA_2017_80x80_2.png" alt="An Event Apart Logo" class="banner-logo" />
		<p>An Event Apart:<br> 3 days of design, code, and content for web &amp; UX designers &amp; devs.</p>		
		</a>
</div></div></section>			</aside>

		</div>
		



<p style="text-align:center"><em>“What are we failing to do?” “What can we do with the code we have written?” “Which parts of our architecture are failing us?”</em></p>



<p>These are valid inquiries, as a fair share of performance woes <em>do</em> originate from our own code. Yet, assigning blame solely to ourselves blinds us to the unvarnished truth that a sizable onslaught of our performance problems comes from the outside.</p>



<h2 id="section2">When the third wheel crashes the party<a class="subhead-anchor" href="#section2">#section2</a></h2>



<p>Convenience always has a price, and <a href="https://httparchive.org/reports/state-of-javascript#bytesJs">the web is wracked by our collective preference for it</a>.&nbsp; JavaScript, in particular, is employed in a way that suggests a rapidly increasing tendency to outsource whatever it is that We (the first party) don’t want to do. At times, this is a necessary decision; it makes perfect financial and operational sense in many situations.</p>



<p>But make no mistake, <a href="https://www.thirdpartyweb.today/">third-party JavaScript is <em>never</em> cheap</a>. It’s a devil’s bargain where vendors seduce you with solutions to your problem, yet conveniently fail to remind you that you have little to no control over the side effects that solution introduces. If a third-party provider adds features to their product, <em>you</em> bear the brunt. If they change their infrastructure, <em>you</em> will feel the effects of it. Those who use your site <em>will</em> become frustrated, and they aren’t going to bother grappling with an intolerable user experience. You can mitigate some of the symptoms of third parties, but you can’t cure the ailment unless you remove the solutions altogether—and that’s not always practical or possible.</p>



<p>In this installment of <em>Responsible JavaScript</em>, we’ll take a <em>slightly</em> less technical approach than in the <a href="https://alistapart.com/article/responsible-javascript-part-2/">previous installment</a>. We are going to talk more about the human side of third parties. Then, we’ll go down some of the technical avenues for how you might go about tackling the problem.</p>



<h2 id="section3">Hindered by convenience<a class="subhead-anchor" href="#section3">#section3</a></h2>



<p>When we talk about the sorry state of the web today, <a href="https://infrequently.org/2018/09/the-developer-experience-bait-and-switch/">some of us are quick to point out the role of <em>developer convenience</em></a> in contributing to the problem. While I share the view that developer convenience has a tendency to harm the user experience, they’re not the only kind of convenience that can turn a website into a sluggish, janky mess.</p>



<p><em>Operational conveniences</em> can become precursors to a very thorny sort of technical debt. These conveniences are what we reach for when we can’t solve a pervasive problem on our own. They represent third-party solutions that address problems in the absence of architectural flexibility and/or adequate development resources.</p>



<p>Whenever an inconvenience arises, <em>that</em> is the time to have the discussion around how to tackle it in a way that’s comprehensive. So let’s talk about what it looks like to tackle that sort of scenario from a more human angle.</p>



<h2 id="section4">The problem is pain<a class="subhead-anchor" href="#section4">#section4</a></h2>



<p>The reason third parties come into play in the first place is pain. When a decision maker in an organization has felt enough pain around a certain problem, they’re going to do a <em>very human thing</em>, which is to find the fastest way to make that pain <em>go away</em>.</p>



<p>Markets will always find ways to address these pain points, even if the way they do so isn’t sustainable or even remotely helpful. Web accessibility overlays—third-party scripts that purport to automatically fix accessibility issues—are among the worst offenders. First, you fork over your money for <a href="https://blog.tenon.io/web-accessibility-overlays-dont-work/">a fix that doesn’t <em>fix</em> anything</a>. Then you pay a wholly different sort of price when that “fix” harms the usability of your website. This is not a screed to discredit the usefulness of the tools some third-party vendors provide, but to illustrate how the adoption of third-party solutions happens, even those that are objectively awful</p>



<figure id="figure1" class="wp-block-image"><img src="https://alistapart.com/wp-content/uploads/2019/11/fig-1.png?fit=960%2C561&#038;w=960" alt="A depiction of a long task in a flame chart from the performance panel in Chrome DevTools." class="wp-image-7172133" data-recalc-dims="1" /><figcaption>A Chrome performance trace of a <a href="https://developer.mozilla.org/en-US/docs/Web/API/Long_Tasks_API#Long_task">long task</a> kicked off by a third party’s web accessibility overlay script. The task occupies the main thread for roughly 600 ms on a 2017 <a href="https://en.wikipedia.org/wiki/MacBook_(2015%E2%80%932019)">Retina MacBook</a>.</figcaption></figure>



<p>So when a vendor rolls up and promises to solve the very painful problem we’re having, there’s a good chance someone is going to nibble. If that someone is high enough in the hierarchy, they’ll exert downward pressure on others to buy in—if not circumvent them entirely in the decision-making process. Conversely, adoption of a third-party solution can also occur when those in the trenches are under pressure and lack sufficient resources to create the necessary features themselves.</p>



<p>Whatever the catalyst, it pays to gather your colleagues and collectively form a plan for navigating and mitigating the problems you’re facing.</p>



<h2 id="section5">Create a mitigation plan<a class="subhead-anchor" href="#section5">#section5</a></h2>



<p>Once people in an organization have latched onto a third-party solution, however ill-advised, the difficulty you’ll encounter in forcing a course change will depend on how urgent a need that solution serves. In fact, you shouldn’t try to convince proponents of the solution that their decision was wrong. Such efforts almost always backfire and can make people feel attacked and more resistant to what you’re telling them. Even worse, those efforts could create acrimony where people stop listening to each other completely, and <em>that</em> is a breeding ground for far worse problems to develop.</p>



<p>Grouse and commiserate amongst your peers if you must—as I myself have often done—but put your grievances aside and <a href="https://csswizardry.com/2018/05/identifying-auditing-discussing-third-parties/#discussing">come up with a mitigation plan</a> to guide your colleagues toward better outcomes. The nooks and crannies of your specific approach will depend on the third parties themselves and the structure of the organization, but the bones of it could look like the following series of questions.</p>



<h3 id="section6">What problem does this solution address?<a class="subhead-anchor" href="#section6">#section6</a></h3>



<p>There’s a reason why a third-party solution was selected, and this question will help you suss out whether the rationale for its adoption is sound. Remember, there are times decisions are made when all the necessary people are not in the room. You might be in a position where you have to react to the aftermath of that decision, but the answer to this question will lead you to a natural follow-up.</p>



<h3 id="section7">How long do we intend to use the solution?<a class="subhead-anchor" href="#section7">#section7</a></h3>



<p>This question will help you identify the solution’s shelf life. Was it introduced as a bandage, with the intent to remove it once the underlying problem has been addressed, such as in the case of an accessibility overlay? Or is the need more long-term, such as the data provided by an A/B testing suite? The other possibility is that the solution can never be effectively removed because it serves a crucial purpose, as in the case of analytics scripts. <a href="https://alistapart.com/article/the-foundation-of-technical-leadership/#section3">It’s like throwing a mattress in a swimming pool</a>: it’s easy to throw in, but nigh impossible to drag back out.</p>



<p>In any case, you can’t know if a third-party script is here to stay if you don’t ask. Indeed, if you find out the solution is temporary, you can form a plan to eventually remove it from your site once the underlying problem it addresses has been resolved.</p>



<h3 id="section8">Who’s the point of contact if issues arise?<a class="subhead-anchor" href="#section8">#section8</a></h3>



<p>When a third-party solution is put into place, someone <em>must</em> be the point of contact for when—not <em>if</em>—issues arise.</p>



<p>I’ve seen what happens (far too often) when a third-party script gets out of control. For example, when a tag manager or an A/B testing framework’s JavaScript grows slowly and insidiously because marketers aren’t cleaning out old tags or completed A/B tests. It’s for precisely these reasons that responsibility needs to be attached to a specific person in your organization for third-party solutions currently in use on your site. What that responsibility entails will differ in every situation, but could include:</p>



<ul><li>periodic monitoring of the third-party script’s footprint;</li><li>maintenance to ensure the third-party script doesn’t grow out of control;</li><li>occasional meetings to discuss the future of that vendor’s relationship with your organization;</li><li>identification of overlaps of functionality between multiple third parties, and if potential redundancies can be removed;</li><li>and ongoing research, especially to identify speedier alternatives that may act as better replacements for slow third-party scripts.</li></ul>



<p>The idea of responsibility in this context should never be an onerous, draconian obligation you yoke your teammates with, but rather an exercise in encouraging mindfulness in your colleagues. Because without mindfulness, a third-party script’s ill effects on your website <em>will</em> be overlooked until it becomes a grumbling ogre in the room that can no longer be ignored. Assigning responsibility for third parties can help to prevent that from happening.</p>



<h2 id="section9">Ensuring responsible usage of third-party solutions<a class="subhead-anchor" href="#section9">#section9</a></h2>



<p>If you can put together a mitigation plan and get everyone on board, the work of ensuring the responsible use of third-party solutions can begin. Luckily for you, the actual technical work will be easier than trying to wrangle people. So if you’ve made it this far, all it will take to get results is time and persistence.</p>



<h3 id="section10">Load only what’s necessary<a class="subhead-anchor" href="#section10">#section10</a></h3>



<p>It may seem obvious, but load only what’s necessary. Judging by the amount of unused first-party JavaScript I see loaded—let alone <em>third-party</em> JavaScript—it’s clearly a problem. It’s like trying to clean your house by stuffing clutter into the closets. Regardless of whether they’re actually needed, it’s not uncommon for third-party scripts to be loaded on every single page, so refer to your point of contact to figure out which pages need which third-party scripts.</p>



<p>As an example, one of my past clients used a popular third-party tool across multiple brand sites to get a list of retailers for a given product. It demonstrated clear value, but that script only needed to be on a site’s product detail page. In reality, it was frequently loaded on <em>every</em> page. Culling this script from pages where it didn’t belong significantly boosted performance for non-product pages, which ostensibly reduced the friction on the conversion path.</p>



<p>Figuring out which pages need which third-party scripts requires you to do some decidedly untechnical work. You’ll actually have to get up from your desk and talk to the person who has been assigned responsibility for the third-party solution you’re grappling with. This is very difficult work for me, but it’s rewarding when good-faith collaboration happens, <em>and</em> good outcomes are realized as a result.</p>



<h3 id="section11">Self-host your third-party scripts<a class="subhead-anchor" href="#section11">#section11</a></h3>



<p>This advice isn’t a secret by any stretch. <a href="https://alistapart.com/article/responsible-javascript-part-2/#section6">I even touched on it</a> in the previous installment of this series, but it needs to be shouted from the rooftops at every opportunity: you should <a href="https://csswizardry.com/2019/05/self-host-your-static-assets/">self-host as many third-party resources</a> as possible. Whether this is feasible depends on the third-party script in question.</p>



<p>Is it some framework you’re grabbing from <a href="https://developers.google.com/speed/libraries">Google’s hosted libraries</a>, <a href="https://cdnjs.com/">cdnjs</a>, or other similar provider? Self-host that sucker <em>right now</em>.</p>



<p><a href="https://medium.com/caspertechteam/we-shaved-1-7-seconds-off-casper-com-by-self-hosting-optimizely-2704bcbff8ec">Casper found a way to self-host their Optimizely script</a> and significantly reduced their start render time for their trouble. It really drives home the point that a major detriment of third-party resources is the fact that their mere existence on other servers is one of the worst performance bottlenecks we encounter.</p>



<p>If you’re looking to self-host an analytics solution or a similar sort of script, there’s a higher level of difficulty to contend with to self-host it. You may find that some third-party scripts simply can’t be self-hosted, but that doesn’t mean it isn’t worth the trouble to find out. If you find that self-hosting isn’t an option for a third-party script, don’t fret. There are other mitigations you can try.</p>



<h3 id="section12">Mask latency of cross-origin connections<a class="subhead-anchor" href="#section12">#section12</a></h3>



<p>If you can’t self-host your third-party scripts, the next best thing is to preconnect to servers that host them. WebPageTest’s Connection View does a fantastic job of showing you which servers your site gathers resources from, as well as the latency involved in establishing connections to them.</p>



<figure id="figure2" class="wp-block-image"><img src="https://alistapart.com/wp-content/uploads/2019/11/fig2.png?w=960" alt="A screenshot of WebPageTest's connection view, which visualizes the latency involved with all the servers that serve content for a given page in a waterfall chart." class="wp-image-7172134" data-recalc-dims="1" /><figcaption>WebPageTest’s Connection View shows all the different servers a page requests resources from during load.</figcaption></figure>



<p><a href="https://web.dev/uses-rel-preconnect">Preconnections</a> are effective because they establish connections to third-party servers before the browser would otherwise discover them in due course. Parsing HTML takes time, and parsers are often blocked by stylesheets and other scripts. Wherever you can’t self-host third-party scripts, preconnections make perfect sense.</p>



<h3 id="section13">Maybe don’t preload third-party scripts<a class="subhead-anchor" href="#section13">#section13</a></h3>



<p><a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Preloading_content">Preloading resources</a> is one of those things that sounds fantastic at first—until you consider <a href="https://andydavies.me/blog/2019/02/12/preloading-fonts-and-the-puzzle-of-priorities/">its potential to backfire</a>, as <a href="https://andydavies.me/">Andy Davies</a> points out. If you’re unfamiliar with preloading, it’s similar to preconnecting but goes a step further by instructing the browser to fetch a particular resource far sooner than it ordinarily would.</p>



<p>The drawback of preloading is that while it’s great for ensuring a resource gets loaded as soon as possible, it changes the discovery order of that resource. Whenever we do this, we’re implicitly saying that other resources are less important—including resources crucial to rendering or even core functionality.</p>



<p>It’s probably a safe bet that most of your third-party code is not as crucial to the functionality of your site as your own code. That said, if you <em>must</em> preload a third-party resource, ensure you’re only doing so for third-party scripts that are critical to page rendering.</p>



<p>If you do find yourself in a position where your site’s initial rendering depends on a third-party script, refer to your mitigation plan to see what you can do to eliminate or ameliorate your dependence on it. Depending on a third party for core functionality is never a good position to be in, as you’re relinquishing a lot of control to others who might not have your best interests in mind.</p>



<h3 id="section14">Lazy load non-essential third-party scripts<a class="subhead-anchor" href="#section14">#section14</a></h3>



<p><a href="https://alistapart.com/article/the-best-request-is-no-request-revisited/">The best request is no request</a>. If you have a third-party script that doesn’t need to be loaded right away, consider lazy loading it with an <a href="https://developer.mozilla.org/en-US/docs/Web/API/Intersection_Observer_API">Intersection Observer</a>. Here’s what it might look like to <a href="https://codepen.io/malchata/pen/JjjGOGZ">lazy load a Facebook Like button</a> when it’s scrolled into the viewport:</p>



<pre id="snippet1" class="wp-block-code language-javascript"><code class="language-javascript">
let loadedFbScript = false;

const intersectionListener = new IntersectionObserver(entries =&gt; {
  entries.forEach(entry =&gt; {
    if ((entry.isIntersecting || entry.intersectionRatio) &amp;&amp; !loadedFbScript) {
      const scriptEl = document.createElement("script");

      scriptEl.defer = true;
      scriptEl.crossOrigin = "anonymous";
      scriptEl.src = "https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v3.0";
      scriptEl.onload = () =&gt; {
        loadedFbScript = true;
      };
      
      document.body.append(scriptEl);
    }
  });
});

intersectionListener.observe(document.querySelector(".fb-like"));
</code>
</pre>



<p>In the above snippet, we first set a variable to track whether we’ve loaded the Facebook SDK JavaScript. After that, an <code>IntersectionListener</code> is created that checks whether the observed element is in the viewport, and whether the Facebook SDK has been loaded. If the SDK JavaScript hasn’t been loaded, a reference to it is injected into the DOM, which will kick off a request for it.</p>



<p>You’re not going to be able to lazy load every third-party script. Some of them simply need to do their work at page load time, or otherwise can’t be deferred. Regardless, do the detective work to see if it’s possible to lazy load at least some of your third-party JavaScript.</p>



<p>One of the common concerns I hear from coworkers when I suggest lazy loading third-party scripts is how it can delay whatever interactions the third party provides. That’s a reasonable concern, because when you lazy load anything, a noticeable delay may occur as the resource loads. You can get around this to some extent with <a href="https://developer.mozilla.org/en-US/docs/Web/HTTP/Link_prefetching_FAQ">resource prefetching</a>. This is different than preloading, which we discussed earlier. Prefetching consumes a comparable amount of data, yes, but prefetched resources are given lower priority and are less likely to contend for bandwidth with critical resources.</p>



<h2 id="section15">Staying on top of the problem<a class="subhead-anchor" href="#section15">#section15</a></h2>



<p>Keeping an eye on your third-party JavaScript requires mindfulness bordering on hypervigilance. When you recognize poor performance for the technical debt that it truly is, you’ll naturally slip into a frame of mind where you’ll recognize and address it as you would any other kind of technical debt.</p>



<p>Staying on top of third parties <em>is</em> refactoring—a sort that requires you to periodically perform tasks such as cleaning up tag managers and A/B tests, consolidating third-party solutions, eliminating any that are no longer needed, and applying the coding techniques discussed above. Moreover, you’ll need to work with your team to address this technical debt on a cyclical basis. This kind of work can’t be automated, so yes, you’ll need to knuckle down and have face-to-face, synchronous conversations with actual people.</p>



<p>If you’re already in the habit of scheduling “cleanup sprints” on some interval, then <em>that</em> is the time and space for you to address performance-related technical debt, regardless of whether it involves third- or first-party code. There’s a time for feature development, but that time should not comprise the whole of your working hours. Development shops that focus only on feature development are destined to be wholly consumed by the technical debt that will inevitably result.</p>



<p>So it will come to pass that in the fourth and final installment of this series we’ll discuss what it means to do the hard work of using JavaScript responsibly in the context of process. Therein, we’ll explore what it takes to unite your organization under the banner of making your website faster and more accessible, and therefore more usable for everyone, everywhere.</p>
		<div class="ala-single-sidebar-wrapper sidebar-related">
			<aside id="related" class="ala-single-sidebar-related">
									<section class="ala-sb-rel__latest">
						<h3 class="ala-sb-rel__latest__title">
							Recently by Jeremy Wagner						</h3>
						<article>
							<h3 class="ala-sb-rel__latest__entry-title">
								<a href="https://alistapart.com/article/responsible-javascript-part-2/">Responsible JavaScript: Part II								</a></h3>
							<div class="ala-sb-rel__latest__entry-content">Web development is hard. We don’t always get it right on the first try. Fortunately, we don’t have to get everything perfect from the start. Jeremy  Wagner provides some helpful ways to start recovering from our collective JavaScript hangover.</php></div>
						</article>
					</section>
										<section class="ala-sb-rel__category">
						<h3 class="ala-sb-rel__cat__title">
							Further reading about							<a href="https://alistapart.com/blog/topic/application-development/">Application Development</a>
						</h3>
													<article>
								<h3 class="ala-sb-rel__cat__entry-title">
									<a href="https://alistapart.com/article/responsible-javascript-part-2/">Responsible JavaScript: Part II									</a></h3>
								<div class="ala-sb-rel__cat__entry-content">Web development is hard. We don’t always get it right on the first try. Fortunately, we don’t have to get everything perfect from the start. Jeremy  Wagner provides some helpful ways to start recovering from our collective JavaScript hangover.</div>
							</article>
														<article>
								<h3 class="ala-sb-rel__cat__entry-title">
									<a href="https://alistapart.com/article/responsible-javascript-part-1/">Responsible JavaScript: Part I									</a></h3>
								<div class="ala-sb-rel__cat__entry-content">The web is drowning in a sea of JavaScript, awash with unnecessary bloat, inaccessible cruft, and unsustainable patterns. Jeremy Wagner plots a course to navigate the JavaScript Sea responsibly by building the right things the right way and using the web platform the way it was meant to be used.</div>
							</article>
												</section>
								</aside>
		</div>
			</div><!-- .entry-content -->
	</article><!-- #post-7172132 -->

				<footer class="ala-author">
					<div class="ala-author__content clear">
						<a name="panelist0"></a>
													<h4 class="ala-author__about">About the Author</h4>
													<div class="ala-author__avatar">
							<img width="150" height="150" src="https://alistapart.com/wp-content/uploads/2017/02/jeremy.jpg?fit=150%2C150" class="avatar avatar-150 photo wp-post-image" alt="Jeremy Wagner" />						</div>

						<h3 class="ala-author__name">Jeremy Wagner</h3>
						<div class="ala-author__description">Jeremy Wagner is an independent web performance consultant, <a href="https://jeremy.codes/writing/" rel="noopener">author</a>, and <a href="https://speaking.jeremy.codes/" rel="noopener">speaker</a> from Minnesota doing his level best to make the web faster for everyone, everywhere.</div>
					</div>
											<aside class="ala-author__more">
							<h3 class="ala-author__more_title">More from this author</h3>
															<h4 class="ala-author__article">
									<a href="https://alistapart.com/article/responsible-javascript-part-2/">Responsible JavaScript: Part II									</a>
								</h4>
																<h4 class="ala-author__article">
									<a href="https://alistapart.com/article/responsible-javascript-part-1/">Responsible JavaScript: Part I									</a>
								</h4>
																<h4 class="ala-author__article">
									<a href="https://alistapart.com/article/designing-for-research/">Designing for Research									</a>
								</h4>
																<h4 class="ala-author__article">
									<a href="https://alistapart.com/article/gauging-the-perception-of-lossy-images-a-study/">How People Perceive Lossy Image Quality: A Study									</a>
								</h4>
																<h4 class="ala-author__article">
									<a href="https://alistapart.com/article/using-http-2-responsibly-adapting-for-users/">Using HTTP/2 Responsibly: Adapting for Users									</a>
								</h4>
														</aside>
										</footer>
									<aside class="widget-area pre-footer-widget-area pre-footer-single">
						<section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="pre-footer-email-signup">
	<strong>Get our latest articles in your inbox.</strong> <a href="https://alistapart.com/email-signup">Sign up for email alerts</a>.
</div>
</div></section>					</aside><!-- .pre-footer-widget-area -->
					
					<div class="comment-area-wrap two-column-layout">
						
<div id="comments" class="comments-area column-content">

	
		<h2 class="comments-title">No Comments</h2>
				<div class="comments-off">
			<h3 class="comments-off-title"> Got something to say?</h3>
			<p class="no-comments">We have turned off comments, but you can see what folks had to say before we did so.</p>
		</div>
		
</div><!-- #comments -->
	<div class="column-sidebar ala-posts">
		<h2 class="section-title">More from ALA</h2>
				<article id="post-7172043" class="home-post-content post-7172043 article type-article status-publish hentry category-content category-content-strategy tag-contentstrategy">

				<header class="entry-header">
					<h4 class="home-post-title"><a href="https://alistapart.com/article/the-untapped-power-of-vulnerability-transparency-in-content-strategy/" rel="bookmark">The Untapped Power of Vulnerability &#038; Transparency in Content Strategy</a></h4>					<div class="entry-meta">
						<span class="byline"> by <span class="author vcard" itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="url fn n" href="https://alistapart.com/author/travis-mcknight/" itemprop="url"> <span itemprop="name">Travis McKnight</span></a></span></span>					</div><!-- .entry-meta -->
				</header><!-- .entry-header -->

				<div class="entry-content">
					Learn the three storytelling pillars of vulnerable and transparent content to forge deeper connections with your users.				</div><!-- .entry-content -->
				<footer class="footer-meta entry-meta">
					<span class="cat-links"><a href="https://alistapart.com/blog/topic/content/" rel="category tag">Content</a></span><span class="posted-on"><time class="entry-date published" datetime="2019-08-22T09:30:11-05:00">August 22, 2019</time><time class="updated" datetime="2019-08-21T21:10:52-05:00">August 21, 2019</time></span>				</footer><!-- .entry-meta -->


			</article><!-- #post-## -->

						<article id="post-7171742" class="home-post-content post-7171742 article type-article status-publish has-post-thumbnail hentry category-career">

				<header class="entry-header">
					<h4 class="home-post-title"><a href="https://alistapart.com/article/the-career-management-document/" rel="bookmark">An Essential Tool for Capturing Your Career Accomplishments</a></h4>					<div class="entry-meta">
						<span class="byline"> by <span class="author vcard" itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="url fn n" href="https://alistapart.com/author/jessica-ivins/" itemprop="url"> <span itemprop="name">Jessica Ivins</span></a></span></span>					</div><!-- .entry-meta -->
				</header><!-- .entry-header -->

				<div class="entry-content">
					Even if you’re not looking for a job, Jessica Ivins shares a great way to jump start your résumé and portfolio right now.				</div><!-- .entry-content -->
				<footer class="footer-meta entry-meta">
					<span class="cat-links"><a href="https://alistapart.com/blog/topic/career/" rel="category tag">Career</a></span><span class="posted-on"><time class="entry-date published" datetime="2019-08-08T09:45:20-05:00">August 08, 2019</time><time class="updated" datetime="2019-08-22T15:01:12-05:00">August 22, 2019</time></span>				</footer><!-- .entry-meta -->


			</article><!-- #post-## -->

						<article id="post-7171724" class="home-post-content post-7171724 article type-article status-publish has-post-thumbnail hentry category-accessibility">

				<header class="entry-header">
					<h4 class="home-post-title"><a href="https://alistapart.com/article/getting-to-the-heart-of-digital-accessibility/" rel="bookmark">Getting to the Heart of Digital Accessibility</a></h4>					<div class="entry-meta">
						<span class="byline"> by <span class="author vcard" itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="url fn n" href="https://alistapart.com/author/carie-fisher/" itemprop="url"> <span itemprop="name">Carie Fisher</span></a></span></span>					</div><!-- .entry-meta -->
				</header><!-- .entry-header -->

				<div class="entry-content">
					The tech world has a major diversity problem. accessible developers may be an unexpected part of the solution.				</div><!-- .entry-content -->
				<footer class="footer-meta entry-meta">
					<span class="cat-links"><a href="https://alistapart.com/blog/topic/accessibility/" rel="category tag">Accessibility</a></span><span class="posted-on"><time class="entry-date published" datetime="2019-08-01T09:45:18-05:00">August 01, 2019</time><time class="updated" datetime="2019-08-22T09:58:10-05:00">August 22, 2019</time></span>				</footer><!-- .entry-meta -->


			</article><!-- #post-## -->

						<article id="post-7171673" class="home-post-content post-7171673 article type-article status-publish has-post-thumbnail hentry category-application-development category-browsers category-javascript">

				<header class="entry-header">
					<h4 class="home-post-title"><a href="https://alistapart.com/article/responsible-javascript-part-2/" rel="bookmark">Responsible JavaScript: Part II</a></h4>					<div class="entry-meta">
						<span class="byline"> by <span class="author vcard" itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="url fn n" href="https://alistapart.com/author/jeremy-wagner/" itemprop="url"> <span itemprop="name">Jeremy Wagner</span></a></span></span>					</div><!-- .entry-meta -->
				</header><!-- .entry-header -->

				<div class="entry-content">
					You’ve “moved fast and broken things.” Here’s some helpful advice from Jeremy Wagner to fix them responsibly.				</div><!-- .entry-content -->
				<footer class="footer-meta entry-meta">
					<span class="cat-links"><a href="https://alistapart.com/blog/topic/application-development/" rel="category tag">Application Development</a></span><span class="posted-on"><time class="entry-date published" datetime="2019-06-13T09:30:28-05:00">June 13, 2019</time><time class="updated" datetime="2019-06-13T09:41:57-05:00">June 13, 2019</time></span>				</footer><!-- .entry-meta -->


			</article><!-- #post-## -->

						<article id="post-7171659" class="home-post-content post-7171659 article type-article status-publish has-post-thumbnail hentry category-business category-career">

				<header class="entry-header">
					<h4 class="home-post-title"><a href="https://alistapart.com/article/resilient-management-excerpt/" rel="bookmark">Resilient Management, An Excerpt</a></h4>					<div class="entry-meta">
						<span class="byline"> by <span class="author vcard" itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="url fn n" href="https://alistapart.com/author/larahogan/" itemprop="url"> <span itemprop="name">Lara Hogan</span></a></span></span>					</div><!-- .entry-meta -->
				</header><!-- .entry-header -->

				<div class="entry-content">
					A key aspect of being a manager is helping your reports succeed. Lara Hogan shares how in this excerpt from Resilient Management.				</div><!-- .entry-content -->
				<footer class="footer-meta entry-meta">
					<span class="cat-links"><a href="https://alistapart.com/blog/topic/business/" rel="category tag">Business</a></span><span class="posted-on"><time class="entry-date published" datetime="2019-06-06T09:30:51-05:00">June 06, 2019</time><time class="updated" datetime="2019-08-06T18:27:04-05:00">August 06, 2019</time></span>				</footer><!-- .entry-meta -->


			</article><!-- #post-## -->

			
	
</div><!-- .home-post-wrap clear -->

					</div>
					
		</main><!-- #main -->
	</div><!-- #primary -->


</div><!-- #content -->

	<div class="widget-area header-widget">
		<section id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="banner">
	<a href="http://sps.northwestern.edu/ala">
	<img class="banner-logo" src="https://alistapart.com/wp-content/uploads/2019/10/NorthWestern_IDS_700x200_Logo.gif" alt="NorthWestern IDS MS logo">
	<p>Northwestern’s Online MS in Information Design and Strategy. Choose from tracks in content strategy, data science and analytics, and learning design.</p>
	</a>
</div></div></section>	</div><!-- .header-widget -->
	
<footer id="colophon" class="site-footer" itemscope itemtype="https://schema.org/WebPage">
	<nav class="footer-navigation footer navigation-top"  itemscope itemtype="http://schema.org/SiteNavigationElement">
		<div class="menu-footer-pages-container"><ul id="footer-top-left-menu" class="footer-top-left-menu"><li id="menu-item-6000544" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000544"><a href="https://alistapart.com/about/" itemprop="url">About</a></li>
<li id="menu-item-6000545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000545"><a href="https://alistapart.com/authors/" itemprop="url">Authors</a></li>
<li id="menu-item-6000546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000546"><a href="https://alistapart.com/about/masthead/" itemprop="url">Masthead</a></li>
<li id="menu-item-6000547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000547"><a href="https://alistapart.com/about/style-guide/" itemprop="url">Style Guide</a></li>
<li id="menu-item-6000548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000548"><a href="https://alistapart.com/contact/" itemprop="url">Contact</a></li>
<li id="menu-item-6000549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000549"><a href="https://alistapart.com/about/sponsor/" itemprop="url">Sponsorships</a></li>
</ul></div><div class="menu-footer-social-container"><ul id="footer-top-right-menu" class="footer-top-right-menu"><li id="menu-item-6000550" class="footer-menu-title menu-item menu-item-type-custom menu-item-object-custom menu-item-6000550"><a itemprop="url">Follow us:</a></li>
<li id="menu-item-7171602" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7171602"><a href="https://alistapart.com/about/rss-feed/" itemprop="url">RSS</a></li>
<li id="menu-item-6000552" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000552"><a href="https://alistapart.com/email-signup/" itemprop="url">Email</a></li>
<li id="menu-item-6000553" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6000553"><a href="https://www.facebook.com/alistapart" itemprop="url">Facebook</a></li>
<li id="menu-item-6000554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6000554"><a href="https://www.twitter.com/alistapart" itemprop="url">Twitter</a></li>
</ul></div>	</nav>
			<div class="widget-area footer-widget-area-wrap">
			<div class="widget-area footer-widget-area">
				<section id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="footer-promo">
	<a href="https://abookapart.com">
							<img src="https://alistapart.com/wp-content/uploads/2019/04/promo_aba_2.jpg" alt="A Book Apart. Brief books for people who design, write, and code.">
		<div class="footer-promo-copy">
				<p class="promo-title">A Book Apart</p>
				<p>Brief books for people who design, write, and code.</p>
				<p>Bundle books and save!</p>
				<p class="arrow">Shop now</p>
						</div>
			</a>
</div>

</div></section><section id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="footer-promo">
		<a href="https://aneventapart.com">
			<img src="https://alistapart.com/wp-content/uploads/2019/04/promo_aea_v1_2.png" alt="An Event Apart. Three days of design, code, and content for people who make websites.">
			<div class="footer-promo-copy">
					<p class="promo-title">An Event Apart</p>
						<p>Three days of design, code, and content for people who make websites.</p>
							<p class="arrow">See  this year’s schedule</p>
			</div>
						</a>
</div></div></section>			</div>
		</div>

		
	<div class="site-info-wrap">
		<div class="site-info">
			ISSN 1534-0295 &middot; Copyright &copy; <span itemprop="copyrightYear"> 1998–2019</span> <span itemprop="copyrightHolder"> A List Apart &amp; Our Authors</span>			<span class="sep"> | </span>
			<a href="https://wordpress.com/">
				Proudly powered by WordPress			</a>
		</div><!-- .site-info -->
	</div><!-- .site-info-wrap -->

	<nav class="footer-navigation footer navigation-bottom">
		<ul id="footer-bottom-left-menu" class="footer-bottom-left-menu"><li id="menu-item-6000555" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6000555"><a href="https://alistapart.com/about/copyright/" itemprop="url">Permissions &#038; Copyright</a></li>
<li id="menu-item-6000556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-6000556"><a href="https://alistapart.com/about/privacy-policy/" itemprop="url">Privacy Policy</a></li>
<li id="menu-item-6000558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6000558"><a href="https://webtype.com/" itemprop="url">Fonts by Webtype</a></li>
</ul><ul id="footer-bottom-right-menu" class="footer-bottom-right-menu"><li id="menu-item-6000559" class="aea menu-item menu-item-type-custom menu-item-object-custom menu-item-6000559"><a href="http://aneventapart.com/" itemprop="url"><span class="screen-reader-text">An Event Apart</span></a></li>
<li id="menu-item-6000560" class="aba menu-item menu-item-type-custom menu-item-object-custom menu-item-6000560"><a href="http://abookapart.com/" itemprop="url"><span class="screen-reader-text">A Book Apart</span></a></li>
</ul>	</nav>
</footer><!-- #colophon -->
</div><!-- #page -->
	<div style="display:none">
	</div>
	<!-- Google Analytics -->
<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) 
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');  

	ga('create', 'UA-11757054-1', 'auto'); 
	ga('send', 'pageview');  
</script>
<!-- End Google Analytics -->
	
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/alistapart.com\/article\/responsible-javascript-part-3\/":7172132};
	</script>
				<script type='text/javascript' src='https://alistapart.com/wp-content/mu-plugins/jetpack/_inc/build/photon/photon.min.js?m=1573161126g'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201946'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://alistapart.com/_static/??-eJx9kEsOwjAMRC9EarooiAXiLCZxE6f5qUkox6cfIbEhG2ukeWONBpYkZAyFQgFfRXJVc8hgqSSUE/ioqqMMS9JzNLGz+QQ/iWLIry46BJsh4Is1Fo6hzaWZsz9uG8wTJ+E4TGKMsmYx8rsdQCUNyQnblIuo/pGtDVhpKmsrwlmavd+uxGF8P3GQrqqVt9tsgvyTVOd52+Th7/1w7c+3fhgu9gNb7ou3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://alistapart.com/wp-content/mu-plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201946.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9',blog:'158094726',post:'7172132',tz:'-5',srv:'alistapart.com'} ]);
	_stq.push([ 'clickTrackerInit', '158094726', '7172132' ]);
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"949ceaf672","applicationID":"156780203","transactionName":"MQZWYhAFXhdYAUBfWwhMdVUWDV8KFhFdWFMKBg==","queueTime":0,"applicationTime":198,"atts":"HUFBFFgfTUgbAxYMTxse","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
