<!doctype html>

<!--[if lt IE 7]> <html class="no-js ie ie6 lt-ie10 lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie ie7 lt-ie10 lt-ie9 lt-ie8" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie ie8 lt-ie10 lt-ie9" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="no-js ie ie9 lt-ie10" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html class="no-js" lang="en"> <!--<![endif]-->

<head>
	
	<meta charset="utf-8">

	<link rel="alternate" type="application/rss+xml" title="A List Apart: The Full Feed" href="/main/feed" />

	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="shortcut icon" href="/components/assets/img/favicons/favicon.ico" type="image/x-icon" />
	<link rel="apple-touch-icon" href="/components/assets/img/favicons/apple-touch-icon.png" />
	<link rel="apple-touch-icon" sizes="57x57" href="/components/assets/img/favicons/apple-touch-icon-57x57.png" />
	<link rel="apple-touch-icon" sizes="72x72" href="/components/assets/img/favicons/apple-touch-icon-72x72.png" />
	<link rel="apple-touch-icon" sizes="76x76" href="/components/assets/img/favicons/apple-touch-icon-76x76.png" />
	<link rel="apple-touch-icon" sizes="114x114" href="/components/assets/img/favicons/apple-touch-icon-114x114.png" />
	<link rel="apple-touch-icon" sizes="120x120" href="/components/assets/img/favicons/apple-touch-icon-120x120.png" />
	<link rel="apple-touch-icon" sizes="144x144" href="/components/assets/img/favicons/apple-touch-icon-144x144.png" />
	<link rel="apple-touch-icon" sizes="152x152" href="/components/assets/img/favicons/apple-touch-icon-152x152.png" />

	<meta name="application-name" content="A List Apart"/>
	<meta name="msapplication-TileColor" content="#222222"/>
	<meta name="msapplication-TileImage" content="/components/assets/img/favicons/windows-8-tile.png"/>

	<link href="https://plus.google.com/+alistapart/" rel="publisher" />

	<link rel="preload" href="/components/assets/img/logo_a-list-apart.svg" as="image" type="image/svg+xml">

	<link rel="stylesheet" href="https://alistapart.com/d/_cache/4e425287d3bc7c393d0959bef082e87bd85a4a2e.1524830670.css" />

	<script src="/components/assets/js/libs/modernizr-custom.js"></script>
	<script src="/components/assets/js/libs/jquery-3.0.0.min.js"></script>
	<script src="/components/assets/js/libs/jquery-migrate-1.4.1.min.js"></script>





	<title>Progressive Web Apps: The Case for PWAs · An A List Apart Article</title>

	<link rel="alternate" type="application/rss+xml" title="A feed for comments on this article" href="/comments/feed/progressive-web-apps-excerpt" />

	
	<style>
	 {
		border: 1px solid rgba(0,0,0,.4) !important;
	}
	
	 {
		/*box-shadow: inset 0 0 18px -8px rgba(255,161,161,.9);*/
		content: url(/components/assets/img/laurel-white-2.svg) !important;
		padding-top: 3px !important;
		height: 23px !important;
	}
	</style>

	

	<link rel="canonical" href="https://alistapart.com/article/progressive-web-apps-excerpt"/>

	<meta name="description" content="In this excerpt from Progressive Web Apps, Jason Grigsby covers the business case for going PWA." class="entry-summary">
	<meta name="author" content="">

	<meta name="twitter:card" content="summary">
	<meta name="twitter:site" content="@alistapart">
	<meta name="twitter:title" content="Progressive Web Apps: The Case for PWAs">
	<meta name="twitter:description" content="In this excerpt from Progressive Web Apps, Jason Grigsby covers the business case for going PWA.">
	<meta name="twitter:url" content="https://alistapart.com/article/progressive-web-apps-excerpt">
	<meta name="twitter:creator" content="@grigs">
	
	<meta property="og:title" content="Progressive Web Apps: The Case for PWAs" />
	<meta property="og:description" content="In this excerpt from Progressive Web Apps, Jason Grigsby covers the business case for going PWA." />
	<meta property="og:url" content="https://alistapart.com/article/progressive-web-apps-excerpt" />
	<meta property="og:image" content="https://alistapart.com/d/excerptillustration_300.png" />
	<meta property="og:locale" content="en_US">
	<meta property="og:site_name" content="A List Apart">
	<meta property="og:type" content="article">
	
	<meta property="article:published_time" content="2018-12-06T10:00:00-05:00">
	<link href="https://plus.google.com/+AListApart?rel=author" rel="publisher">

</head>

<body class="printable " itemscope itemtype="http://schema.org/Article">
<link itemprop="mainEntityOfPage" href="https://alistapart.com/article/progressive-web-apps-excerpt" />
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5PLQL99"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
	<header class="logo-holder">

		<h1 id="top" class="killer-logo" itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><a href="https://alistapart.com" title="A List Apart home page" tabindex="-1" itemprop="url"><span itemprop="logo" itemscope itemtype="http://schema.org/ImageObject"><img itemprop="url" src="https://alistapart.com/components/assets/img/ala-logo-big.png" alt="A List Apart"></span></a><span class="screen-reader" itemprop="name">A List Apart</span></h1>

	</header>



	<a class="go-to-nav" href="#main-nav" title="skip to nav">Menu</a>

	<nav class="global-nav" id="main-nav" role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">

		<ul class="inline-items">
			<li><a href="/" title="Home" itemprop="url"><span itemprop="name">Home</span></a></li>
			
			<li class="active"><a href="/articles" itemprop="url"><span itemprop="name">Articles</span></a></li>
			<li ><a href="/events" itemprop="url"><span itemprop="name">Events</span></a></li>
			<li ><a href="/topics" itemprop="url"><span itemprop="name">Topics</span></a></li>
			<li ><a href="/about/contribute" itemprop="url"><span itemprop="name">Write for us</span></a></li>
			<li class="back-to-top"><a href="#top">Back to top</a></li>
			<li class="head-east-young-man">
				<form id="main-search" class="main-search" data-action="/search" action="https://www.google.com/search" method="GET">
					<input type="hidden" name="sitesearch" value="alistapart.com" />
					<label for="search-keywords"><input id="search-keywords" type="search" data-name="keywards" name="q" placeholder="Search" aria-label="Search" value="" required="required"></label>
					<input id="submit-search" name="submit" type="image" src="/components/assets/img/icon_magnify_v.svg" data-fallback="/components/assets/img/icon_magnify_v.png" alt="Submit">
				</form>
			</li>
		</ul>

	</nav>


	


	<div role="main" class="main-wrapper">

		<article class="article-layout hentry">

			<header class="entry-header">

				
				
				

				
				<figure class="wide-hero" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
				<meta itemprop="representativeOfPage" content="true">
				<meta itemprop="url" content="https://alistapart.com/d/excerptillustration_300.png">
        <meta itemprop="width" content="1920">
        <meta itemprop="height" content="938">
        <meta itemprop="description" content="Illustration: A small piece of paper is torn from a very large book with some glasses, a bookmark, and a steaming mug of something delicious nearby.">
					<picture>
						
						<source srcset="/d/_made/d/excerptillustration_300_960_469_81.jpg 1x, /d/_made/d/excerptillustration_300_1920_938_81.jpg 2x" media="(min-width: 600px)">
						<img src="/d/_made/d/excerptillustration_300_960_469_81.jpg" alt="Illustration: A small piece of paper is torn from a very large book with some glasses, a bookmark, and a steaming mug of something delicious nearby." itemprop="contentUrl">
						 
					</picture>
					
				
				<p class="illustrator-credit" itemprop="contributor" itemscope itemtype="http://schema.org/Person">Illustration by
					
					
					<a itemprop="sameAs" href="/author/kcornell"><span itemprop="name">Kevin Cornell</span></a>
					
					
				</p>
				
				
				</figure>
				

				<h1 class="entry-title" itemprop="headline">Progressive Web Apps: The Case for PWAs</h1>

				<p class="entry-details">
					<meta itemprop="description" content="In this excerpt from Progressive Web Apps, Jason Grigsby covers the business case for going PWA."/>

					<span itemprop="author" itemscope itemtype="http://schema.org/Person">by <a itemprop="sameAs" class="author" rel="author" href="/author/jason-grigsby"><span itemprop="name">Jason Grigsby</span></a></span>

					<time class="pubdate updated" datetime="2018-12-06T10:00:00-05:00" itemprop="datePublished">December 06, 2018</time>
					<meta itemprop="dateModified" content="2018-12-04T15:07:59-05:00">

					<span class="entry-meta optional-break">

						Published in <a href="/topic/state-of-the-web"><span itemprop="about">State of the Web</span></a>


					</span>
				</p>

				 

			</header>

			 

			
			<div class="main-content pre-article">
				<p class="editors-note"><b>A note from the editors:</b> We’re pleased to share an excerpt from Chapter 2 of Jason Grigsby’s <a href="https://abookapart.com/products/progressive-web-apps"><cite>Progressive Web Apps</cite></a>, from <a href="https://abookapart.com/"><cite>A Book Apart</cite></a>.</p>
			</div>
			

			

			<div class="main-content" itemprop="articleBody">

			

			

			

				<p>Now that you know what a progressive web app is, you’re probably wondering if your organization would benefit from one. To determine if it makes sense for your organization, ask yourself two questions:</p>

<ol>
<li><strong>Does your organization have a website?</strong> If so, you would probably benefit from a progressive web app. This may sound flippant, but it’s true: nearly every website should be a progressive web app, because they represent best practices for the web.</li>
<li><strong>Does your organization make money on your website via ecommerce, advertising, or some other method?</strong> If so, you <em>definitely</em> need a progressive web app, because progressive web apps can have a significant impact on revenue.
</ol>

				<div class="aside-breaker"><b>Article Continues Below</b></div>

				<aside class="content-minutiae">
					
                  <a href="#comments" class="comment-bubble comment-bubble-articles">
                     <span>no comments yet</span>
                  </a>

					


                  <div class="minutiae-block share-block">
                     <h1 class="propagation-enablers" aria-hidden="true">Share this on</h1>
                     <ul class="propagation-enablers">
                        <li class="circle-twitter"><a href="http://twitter.com/intent/tweet?url=http://alistapart.com/article/progressive-web-apps-excerpt&text=Progressive+Web+Apps%3A+The+Case+for+PWAs&via=alistapart" data-trackevent="Share: Twitter" title="share this on Twitter"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="0 0 274 224" enable-background="new 0 0 274 224" xml:space="preserve">
                        <path d="M273.7,27.2c-10.1,4.5-20.9,7.5-32.2,8.8c11.6-6.9,20.5-17.9,24.7-31c-10.8,6.4-22.8,11.1-35.6,13.6
                           C220.3,7.7,205.7,0.9,189.6,0.9c-31,0-56.1,25.1-56.1,56.1c0,4.4,0.5,8.7,1.5,12.8C88.3,67.4,47,45.1,19.3,11.2
                           c-4.8,8.3-7.6,17.9-7.6,28.2c0,19.5,9.9,36.6,25,46.7c-9.2-0.3-17.8-2.8-25.4-7c0,0.2,0,0.5,0,0.7c0,27.2,19.3,49.8,45,55
                           c-4.7,1.3-9.7,2-14.8,2c-3.6,0-7.1-0.4-10.6-1c7.1,22.3,27.9,38.5,52.4,39c-19.2,15-43.4,24-69.7,24c-4.5,0-9-0.3-13.4-0.8
                           c24.8,15.9,54.3,25.2,86,25.2c103.2,0,159.6-85.5,159.6-159.6c0-2.4-0.1-4.9-0.2-7.3C256.7,48.3,266.2,38.5,273.7,27.2z"/>
                        </svg></a></li><!--
                        --><li class="circle-facebook"><a href="http://www.facebook.com/sharer.php?u=http://alistapart.com/article/progressive-web-apps-excerpt&t=Progressive+Web+Apps%3A+The+Case+for+PWAs" data-trackevent="Share: Facebook" title="share this on Facebook"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-95.6 286.6 114 220" enable-background="new -95.6 286.6 114 220" xml:space="preserve">
                        <path id="f" d="M-21.6,505.9v-99.8h33.5l5-38.9h-38.5v-24.8c0-11.3,3.1-18.9,19.3-18.9l20.6,0v-34.8
                           c-3.6-0.5-15.8-1.5-30-1.5c-29.7,0-50,18.1-50,51.4v28.7h-33.6v38.9h33.6v99.8H-21.6z"/>
                        </svg></a></li><!--
                        --><li class="circle-google"><a href="https://plus.google.com/share?url=http://alistapart.com/article/progressive-web-apps-excerpt" data-trackevent="Share: Google+" title="share this on Google+"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
                            viewBox="-212.7 354.2 84 86" enable-background="new -212.7 354.2 84 86" xml:space="preserve">
                        <g>
                           <g>
                              <path d="M-168.4,403.2l-4-3.1c-1.2-1-2.9-2.3-2.9-4.8c0-2.4,1.7-4,3.1-5.4c4.6-3.7,9.3-7.5,9.3-15.7
                                 c0-8.4-5.3-12.9-7.8-15h6.8l7.2-4.5h-21.8c-6,0-14.6,1.4-20.9,6.6c-4.8,4.1-7.1,9.8-7.1,14.8c0,8.6,6.6,17.4,18.3,17.4
                                 c1.1,0,2.3-0.1,3.5-0.2c-0.5,1.3-1.1,2.4-1.1,4.3c0,3.4,1.8,5.5,3.3,7.5c-5,0.3-14.3,0.9-21.1,5.1c-6.5,3.9-8.5,9.5-8.5,13.5
                                 c0,8.2,7.7,15.8,23.8,15.8c19,0,29.1-10.5,29.1-20.9C-159.1,411.1-163.5,407.3-168.4,403.2z M-182.9,390.5
                                 c-9.5,0-13.8-12.3-13.8-19.7c0-2.9,0.5-5.9,2.4-8.2c1.8-2.2,4.9-3.7,7.7-3.7c9.2,0,13.9,12.4,13.9,20.4c0,2-0.2,5.5-2.8,8.1
                                 C-177.2,389.1-180.1,390.5-182.9,390.5z M-182.8,435c-11.8,0-19.5-5.7-19.5-13.5c0-7.9,7.1-10.5,9.5-11.4
                                 c4.6-1.6,10.6-1.8,11.6-1.8c1.1,0,1.7,0,2.5,0.1c8.4,6,12.1,9,12.1,14.6C-166.5,429.9-172.2,435-182.8,435z"/>
                              <polygon points="-140.5,390.3 -140.5,379.2 -146,379.2 -146,390.3 -157,390.3 -157,395.8 -146,395.8 -146,407
                                 -140.5,407 -140.5,395.8 -129.4,395.8 -129.4,390.3 		"/>
                           </g>
                        </g>
                        </svg></a></li>
                     </ul>
                  </div>


					 
          <a href="https://www.patreon.com/alistapart" class="patreon-bubble">
            Become a patron
          </a>
				</aside>


			<div class="utility-side-bar"> <!-- <div class="banner banner-wide pantheon">
  <a href="http://sps.northwestern.edu/ala">
    <img class="banner-logo" src="/components/assets/img/northwesten-logo_250x90.gif" alt="Northwestern Logo">
    <p>Prepare for leadership roles at the intersection of design and technology in Northwestern’s online MS in Information Design
      & Strategy program.</p>
  </a>
</div>  -->
<div class="banner banner-wide pantheon">
  <a href="http://cloudinary.rocks/ala">
    <img class="banner-logo" src="/components/assets/img/cloudinary_vertical_logo_for_white_bg.jpg" alt="Cloudinary Logo">
    <p>Want the best way to store and serve images and videos? Try Cloudinary. Get your own free account.</p>
  </a>
</div>
<div class="banner a-book-apart"> 
  <a href="https://abookapart.com">
    <img class="banner-logo" src="https://alistapart.com/components/assets/img/logo_a-book-apart-color.png" alt="">
    <p>A Book Apart:<br> Brief books for people who make websites.</p>
  </a>
</div>
<div class="banner">  
  <a href="https://aneventapart.com/">
    <img class="banner-logo" src="https://alistapart.com/components/assets/img/AEA_2017_80x80.png" alt="">
    <p>An Event Apart:<br> 3 days of design, code, and content for web & UX designers & devs.</p>
  </a>
</div></div><p>This doesn’t mean that your site needs to have every possible feature of progressive web apps. You may have no need to provide offline functionality, push notifications, or even the ability for people to install your website to their homescreen. You may only want the bare minimum: a secure site, a service worker to speed up the site, and a manifest file—things that benefit every website.</p>

<p>Of course, you may decide that your personal website or side project doesn’t warrant the extra effort to make it into a progressive web app. That’s understandable—and in the long run, even personal websites will gain progressive web app features when the underlying content management systems add support for them. For example, both <a href="https://magento.com/news-room/press-releases/magento-commerce-announces-progressive-web-applications-studio">Magento</a> and <a href="https://www.youtube.com/watch?v=Di7RvMlk9io">WordPress</a> have already announced their plans to bring progressive web apps to their respective platforms. Expect other platforms to follow suit.</p>

<p>But if you’re running any kind of website that makes money for your organization, then it would behoove you to start planning for how to convert your website to a progressive web app. Companies that have deployed progressive web apps have seen increases in conversion, user engagement, sales, and advertising revenue. For example, <a href="https://medium.com/dev-channel/a-pinterest-progressive-web-app-performance-case-study-3bd6ed2e6154">Pinterest saw core engagement increase by 60 percent</a> and user-generated ad revenue increase by 44 percent (Fig 2.1). <a href="https://www.youtube.com/watch?v=PsgW-0M67TQ&amp;feature=youtu.be&amp;t=34m4s">West Elm saw a 15 percent increase in average time spent on their site</a> and a 9 percent lift in revenue per visit.</p>

<figure>
<img src="/d/progressive-web-apps/fig2-1.jpg" alt="Comparing old mobile web to the progressive web version of Pinterest, the time spent that was greater than 5 minutes increased by 40%, the user-generated ad revenue increased by 44%, ad clickthroughs increased by 50%, and core engagement metrics improved by 60%. Even comparing to the native app, most of these same metrics increased between 2-5%.">
<figcaption><strong>Fig 2.1:</strong> Addy Osmani, an engineering manager for Google, wrote <a href="https://medium.com/dev-channel/a-pinterest-progressive-web-app-performance-case-study-3bd6ed2e6154">a case study about Pinterest’s progressive web app</a>, comparing it to both their old mobile website and their native app.</figcaption>		
</figure>

<p>The success stories for progressive web apps are so abundant that my company, Cloud Four, started a website called <a href="https://www.pwastats.com/">PWA Stats</a> to keep track of them (Fig 2.2). There’s a good chance that we’ve collected a case study from an organization similar to yours that you can use to convince your coworkers that building a progressive web app makes sense.</p>

<figure>
<img src="/d/progressive-web-apps/fig2-2.jpg" alt="A screenshot of the PWA Stats homepage, showing case studies for Uber, Trivago, Petlove, and the Grand Velas Riviera Maya resort.">
<figcaption><strong>Fig 2.2:</strong> <a href="https://www.pwastats.com/">PWAstats.com</a> collects statistics and stories documenting the impact of progressive web apps.</figcaption>
</figure>

<p>And convincing them may be necessary. Despite the clear benefits of progressive web apps, many businesses still haven’t converted—often because they simply don’t know about PWAs yet. (So if you start building one now, you may get a jump on your competition!)</p>

<p>But there is also a lot of confusion about what progressive web apps are capable of, where they can be used, and how they relate to native apps. This confusion creates fear, uncertainty, and doubt (FUD) that slow the adoption of progressive web apps.</p>

<p>If you advocate for progressive web apps in your organization, you’ll likely find some confusion and possibly even encounter some resistance. So let’s equip you with arguments to cut through the FUD and convince your colleagues.</p>

<h2>Native apps and PWAs can coexist</h2>

<p>If your organization already has a native app, stakeholders may balk at the idea of <em>also</em> having a progressive web app—especially since the main selling point of PWAs is to enable native app features and functionality.</p>

<p>It’s tempting to view progressive web apps as competition to native apps—much of the press coverage has adopted this storyline. But the reality is that progressive web apps make sense irrespective of whether a company has a native app.</p>

<p>Set aside the “native versus web” debate, and focus on the experience you provide customers who interact with your organization via the web. Progressive web apps simply make sense on their own merits: they can help you reach more customers, secure your site, generate revenue, provide more reliable experiences, and notify users of updates—all as a complement to your native app.</p>

<h3>Reach more customers</h3>

<p>Not all of your current customers—and none of your potential customers—have your native app installed. Even your average customer is unlikely to have your app installed, and those customers who <em>do</em> have your app may still visit your site on a desktop computer.</p>

<p>Providing a better experience on the website itself will increase the chances that current and future customers will read your content or buy your products (or even download your native app!). A progressive web app can provide that better experience.</p>

<p>Despite what the tech press might have you believe, the mobile web is growing faster than native apps. comScore compared the top one thousand apps to the top one thousand mobile web properties and found that “<a href="https://www.comscore.com/Insights/Presentations-and-Whitepapers/2016/The-2016-US-Mobile-App-Report">mobile web audiences are almost 3x the size and growing 2x as fast as app audiences</a>”.</p>

<p>And while it’s true that people spend more time in their favorite apps than they do on the web, you may have trouble convincing people to install your app in the first place. <a href="https://www.comscore.com/Insights/Presentations-and-Whitepapers/2017/The-2017-US-Mobile-App-Report">Over half of smartphone users in the United States don’t download any apps</a> in a typical month.</p>

<p>Having a native app in an app store doesn’t guarantee that people will install it. It costs a lot to advertise an app and convince people to try it. According to app marketing company Liftoff, <a href="https://www.emarketer.com/Article/Cost-of-Acquiring-Mobile-App-User/1016688">the average cost to get someone to install an app is $4.12</a>, and that shoots up to $8.21 per install if you want someone to create an account in your app.</p>

<p>If you’re lucky enough to get someone to install your app, the next hurdle is convincing them to continue to use it. When analyst Andrew Chen analyzed user retention data from 125 million mobile phones, he found that “<a href="https://andrewchen.co/new-data-shows-why-losing-80-of-your-mobile-users-is-normal-and-that-the-best-apps-do-much-better/">the average app loses 77% of its DAUs [daily active users] within the first 3 days</a> after the install. Within 30 days, it’s lost 90% of DAUs. Within 90 days, it’s over 95%” (Fig 2.3).</p>

<figure>
<img src="/d/progressive-web-apps/fig2-3.jpg" alt="Chart: The average retention curve for Android apps drops precipitously within the first three days and continues to drop more slowly to near 0 over the next 90 days.">
<figcaption><strong>Fig 2.3:</strong> App loyalty remains a big issue for native apps. The average app loses over 95 percent of its daily active users within 90 days.</figcaption>
</figure>

<p>Progressive web apps don’t have those same challenges. They’re as easy for people to discover as your website is, because they <em>are</em> your website. And the features of a progressive web app are available immediately. There’s no need to jump through the hoops of visiting an app store and downloading the app. Installation is fast: it happens in the background during the first site visit, and can literally be as simple as adding an icon to the home screen.</p>

<p>As Alex Russell wrote in <a href="https://medium.com/dev-channel/why-are-app-install-banners-still-a-thing-18f3952d349a">a 2017 Medium post</a>:</p>

<figure class="quote">
	<blockquote>The friction of PWA installation is <em>much</em> lower. Our internal metrics at Google show that for similar volume of prompting for PWA banners and native app banners — the closest thing to an apples-to-apples comparison we can find — <em>PWA banners convert 5–6x more often</em>. More than half of users who chose to install a native app from these banners fail to complete installing the app whereas PWA installation is near-instant.</blockquote>
</figure>

<p>In short, a large and growing percentage of your customers interact with you on the web. Progressive web apps can lead to more revenue and engagement from more customers.</p>

<h3>Secure your website</h3>

<p>If you’re collecting credit cards or private information, providing a secure website for your web visitors is a must. But even if your website doesn’t handle sensitive data, it still makes sense to use HTTPS and provide a secure experience. Even seemingly innocuous web traffic can provide signals that can identify individuals and potentially compromise them. That’s not to mention the concerns raised by revelations of government snooping.</p>

<p>It used to be that running a secure server was costly, confusing, and (seemingly) slower. Things have changed. SSL/TLS certificates used to cost hundreds of dollars, but now certificate provider <a href="https://letsencrypt.org/">Let’s Encrypt</a> gives them out for free. Many hosting providers have integrated with certificate providers so you can set up HTTPS with a single click. And it turns out that <a href="https://istlsfastyet.com/">HTTPS wasn’t as slow as we thought it was</a>.</p>

<p>Websites on HTTPS can also move to a new version of HTTP called HTTP/2. The biggest benefit is that HTTP/2 is significantly faster that HTTP/1. For many hosting providers and content delivery networks (CDNs), the moment you move to HTTPS, you get HTTP/2 with no additional work.</p>

<p>If that wasn’t enough incentive to move to HTTPS, browser makers are using a carrot-and-stick approach for pushing websites to make the change. For the stick, Chrome has started warning users when they enter data on a site that isn’t running HTTPS. By the time you read this, <a href="https://blog.chromium.org/2017/04/next-steps-toward-more-connection.html">Google plans to label all HTTP pages with a “Not secure” warning</a> (Fig 2.4). Other browsers will likely follow suit and start to flag sites that aren’t encrypted to make sure users are aware that their data could be intercepted.</p>

<figure>
<img src="/d/progressive-web-apps/fig2-4.jpg" alt="The eventual treatment of all HTTP pages in Chrome will be to show a red yield icon with the words 'Not secure'.">
<figcaption>Fig 2.4: Google has announced its intention to <a href="https://www.chromium.org/Home/chromium-security/marking-http-as-non-secure">label any website that isn’t running HTTPS as not secure</a>. Different warning styles will be rolled out over time, until the label reaches the final state shown here.
</figcaption>
</figure>

<p>For the HTTPS carrot, browsers are starting to require HTTPS to use new features. If you want to utilize the latest and greatest web tech, <a href="https://blog.mozilla.org/security/2018/01/15/secure-contexts-everywhere/">you’ll need to be running HTTPS</a>. In fact, some features that used to work on nonsecure HTTP that are considered to contain sensitive data—for example, geolocation—are being restricted to HTTPS now. On second thought, perhaps this is a bit of a stick as well. A carrot stick?</p>

<p>With all that in mind, it makes sense to set up a secure website for your visitors. You’ll avoid scary nonsecure warnings. You’ll get access to new browser features. You’ll gain speed benefits from HTTP/2. And: you’ll be setting yourself up for a progressive web app.</p>

<p>In order to use service workers, the core technology for progressive web apps, your website <em>must</em> be on HTTPS. So if you want to reap the rewards of all the PWA goodness, you need to do the work to make sure your foundation is secure.</p>

<h3>Generate more revenue</h3>

<p>There are numerous studies that show a connection between the speed of a website and the amount of time and money people are willing to spend on it. DoubleClick found that “<a href="https://marketingplatform.google.com/about/resources/">53% of mobile site visits are abandoned if pages take longer than 3 seconds to load</a>.” Walmart found that <a href="https://www.slideshare.net/devonauerswald/walmart-pagespeedslide">for every 100 milliseconds of improvement to page load time, there was up to a one percent increase in incremental revenue</a>.</p>

<p>Providing a fast web experience makes a big difference to the bottom line. Unfortunately, the average load time for mobile websites is <a href="https://marketingplatform.google.com/about/resources/">nineteen seconds on 3G connections</a>. That’s where a progressive web app can help.</p>

<p>Progressive web apps use service workers to provide an exceptionally fast experience. Service workers allow developers to explicitly define what files the browser should store in its local cache and under what circumstances the browser should check for updates to the cached files. Files that are stored in the local cache can be accessed much more quickly than files that are retrieved from the network.</p>

<p>When someone requests a new page from a progressive web app, most of the files needed to render that page are already stored on the local device. This means that the page can load nearly instantaneously because all the browser needs to download is the incremental information needed for that page.</p>

<p>In many ways, this is the same thing that makes native apps so fast. When someone installs a native app, they download the files necessary to run the app ahead of time. After that occurs, the native app only has to retrieve any new data. Service workers allow the web to do something similar.</p>

<p>The impact of progressive web apps on performance can be astounding. For example, <a href="https://medium.com/@addyosmani/a-tinder-progressive-web-app-performance-case-study-78919d98ece0">Tinder cut load times from 11.91 seconds to 4.69 seconds</a> with their progressive web app—and it’s 90 percent smaller than their native Android app. Hotel chain Treebo launched a progressive web app and <a href="https://tech.treebo.com/we-didnt-see-a-speed-limit-so-we-made-it-faster-treebo-and-pwas-the-journey-so-far-f7378410abc7">saw a fourfold increase in conversion rates year-over-year</a>; conversion rates for repeat users saw a threefold increase, and their median interactive time on mobile dropped to 1.5 seconds.</p>

<h3>Ensure network reliability</h3>

<p>Mobile networks are flaky. One moment you’re on a fast LTE connection, and the next you’re slogging along at 2G speeds—or simply offline. We’ve all experienced situations like this. But our websites are still primarily built with an assumption that networks are reliable.</p>

<p>With progressive web apps, you can create an app that continues to work when someone is offline. In fact, the technology used to create an offline experience is the same technology used to make web pages fast: service workers.</p>

<p>Remember, service workers allow us to explicitly tell the browser what to cache locally. We can expand what is stored locally—not only the assets needed to render the app, but also the content of pages—so that people can continue to view pages offline (Fig 2.5).</p>

<figure>
<img src="/d/progressive-web-apps/fig2-5.jpg" alt="Three screens from the housing.com site show how the design adapts to show when it is offline and that it can continue to show saved results even when offline.">
<figcaption><strong>Fig 2.5:</strong> The header in <a href="https://housing.com">housing.com’s progressive web app</a> changes from purple (left) to gray when offline (middle). Content the user has previously viewed or favorited is available offline (right), which is important for housing.com’s home market in India, where network connectivity can be slow and unreliable.
</figcaption>
</figure>

<p>Using a service worker, we can even precache the shell of our application behind the scenes. This means that when someone visits a progressive web app for the first time, the whole application could be downloaded, stored in the cache, and ready for offline use without requiring the person to take any action to initiate it. For more on when precaching makes sense, see Chapter 5.</p>

<h3>Keep users engaged</h3>

<p>Push notifications are perhaps the best way to keep people engaged with an application. They prompt someone to return to an app with tantalizing nuggets of new information, from breaking news alerts to chat messages.</p>

<p>So why limit push notifications to those who install a native application? For instance, if you have a chat or social media application, wouldn’t it be nice to notify people of new messages (Fig 2.6)?</p>

<figure>
<img src="/d/progressive-web-apps/fig2-6.jpg" alt="Two screens: On the left, a list of system notifications including one from the Twitter website. On the right, the notification opened on the Twitter site to a funny tweet about WiFi passwords in a bar.">
<figcaption><strong>Fig 2.6:</strong> Twitter’s progressive web app, Twitter Lite, sends the same notifications that its native app sends. They appear alongside other app notifications (left). Selecting one takes you directly to the referenced tweet in Twitter Lite (right).</figcaption>		
</figure>

<p>Progressive web apps—specifically our friend the service worker—make push notifications possible for any website to use. Notifications aren’t required for something to be a progressive web app, but they are often effective at increasing re-engagement and revenue:</p>

<ul>
<li>United eXtra Electronics saw <a href="https://developers.google.com/web/showcase/2016/extra">a fourfold increase in re-engagement and a 100 percent increase in sales</a> from users arriving via push notifications.</li>
<li>Notifications contributed to <a href="https://developers.google.com/web/showcase/2017/lancome">a 12 percent increase in recovered carts</a> for Lancôme.</li>
<li>Classified ads company OLX saw <a href="https://developers.google.com/web/showcase/2017/olx">a 250 percent increase in re-engagement</a> using push notifications and a 146 percent higher click-through rate on ads.</li>
<li>Carnival Cruise Line garnered <a href="https://developers.google.com/web/showcase/2016/carnival">a 42 percent open rate from its push notifications</a>. In addition to the 24 percent of mobile users who opted in to the notifications, 16 percent of desktop users opted in as well.</li>
</ul>

<p>We’ll talk more about push notifications in Chapter 6. For now, it can be helpful to know that progressive web apps can send push notifications, just like a native app—which may help you make the case to your company.</p>

<p>Whether you have a native app or not, a progressive web app is probably right for you. Every step toward a progressive web app is a step toward a better website. Websites <em>should</em> be secure. They <em>should</em> be fast. They would be better if they were available offline and able to send notifications when necessary.</p>

<p>For your customers who don’t have or use your native app, providing them with a better website experience is an excellent move for your business. It’s really that simple.</p>

				

			

			 

				

				
				<!-- START RELATED SIDEBAR -->
				
				
				<aside id="related" class="sidebar var1 nocontent">
				<i class="widget-branding ala"></i>
				<!-- if this article does not have a follow up show recent articles by this author -->
				
				
					
							

							<section>
							<h1>Recently by  Jason Grigsby</h1>

							<article>
								<h1><a href="https://alistapart.com/article/adapting-to-input">Adapting to Input</a></h1>
								<p>The way of the web now means adapting to ever-multiplying forms of input.</p>
							</article>
							</section>
							
				
				<!-- end first block -->
				
				<!-- show categories -->
				
					
   <section class="related-articles">


	<h1 class="primary-cat-header">
	 	Further reading about
	 	<a href="/topic/state-of-the-web" data-trackevent="Related sidebar: Related by category">State of the Web</a>
	</h1>
    <article>
      	<h2><a href="https://alistapart.com/article/web-developer-representation-in-w3c">Web Developer Representation in W3C</a></h2>
   <p>Fronteers, the Dutch front-end association, aims to join the W3C to represent independent web developers worldwide.</p><h2><a href="https://alistapart.com/article/cult-of-the-complex">The Cult of the Complex</a></h2>
   <p>ALA’s Zeldman bemoans our industry’s fetish for the needlessly complicated over the straightforward.</p>   
	</article>


</section>
   
				
				
					
				
				</aside>
				<!-- END RELATED SIDEBAR -->
				

				<footer class="entry-footer nocontent">
				<h1>About the Author</h1>

				<div class="byline author vcard">

					<a class="photo" href="/author/jason-grigsby"><img src="/d/_made/pix/authors/photos/jg-teso-casual_120_120_c1.jpg" alt="Image of Jason Grigsby"></a>

					<h2><a class="fn" href="/author/jason-grigsby">Jason Grigsby</a></h2>

					<div class="author-bio"><a href="https://twitter.com/grigs">Jason Grigsby</a> is cofounder of <a href="https://cloudfour.com/">Cloud Four</a>, a small web consultancy with big aspirations. Since cofounding Cloud Four, he has had the good fortune to work on many fantastic projects, including the Obama ’08 iOS app. He was founder and president of Mobile Portland, where he helped start the world's first community device lab. He is the coauthor of <cite>Head First Mobile Web</cite> (O’Reilly 2011) and one of the signatories of the Future Friendly web manifesto. He participated in the Responsive Images Community Group, which helped define the new web standard for responsive images. He tracks progressive web app case studies at <a href="https://pwastats.com">pwastats.com</a>.</div>

					
						<h3>More from this Author</h3>

							<ul class="author-more">
						
								<li><a href="/article/adapting-to-input">Adapting to Input</a></li>
						</ul>

				</div>
				
				
				<aside class="author-book">
					 
					<figure class="author-book__cover">
						
						<a class="author-book__purchase-url" href="https://abookapart.com/products/progressive-web-apps">
						<img src="/d/_made/pix/authors/aba-book-covers/aba-cover-28_100x@3x_120_186.png" alt=""/>
						</a>
					</figure>
					
					<article class="author-book__description">
						<mark>Also from this author</mark> 
						<h2>
						<a class="author-book__purchase-url" href="https://abookapart.com/products/progressive-web-apps">Progressive Web Apps <span class="author-book__author-name">by Jason Grigsby</span></a></h2>
						<p>Progressive web apps represent the next big digital opportunity: they look and feel like native apps, they work offline, and they’re available to anyone—no app store required. But with that freedom and flexibility come challenging questions about how to create the most value for your users (and your bottom line). Jason Grigsby answers the what, why, and how of progressive web apps, from making the case in your organization to reaching your users in bold, new ways. Build your audience, increase revenue, and widen the web’s reach—all with the power of progressive web apps.</p>
						<a class="author-book__purchase-url--cta" href="https://abookapart.com/products/progressive-web-apps"><span>➝</span> Buy now</a>
					</article>
					
				</aside>
				

				</footer>

				
<aside class="promo-box email-promo">
   <b>Get our latest articles in your inbox.</b> <a href="/email-signup" data-trackevent="Post-article: email promo">Sign up for email alerts</a>.
</aside>

			</div>

			<div class="post-article">

				<div class="column-holder unequal-columns">

					<section id="comments" class="column comment-holder">

							<h1 class="classy" itemprop="commentCount" data-url-title="progressive-web-apps-excerpt">
							 
							<span>No Comments (yet)<span>
							</h1>

							
							<span id="load-comments" data-url-title="progressive-web-apps-excerpt"></span>

							
								<ol class="article-comments form">

	<li id="commenter-signin" class="commenter-signin no-comments">

	<h3 class="form-heading">Got something to say?</h3>
 	
 	<div class="outer-ajax-container">
	
	 	<div class="ajax-container">
	 	
			<form id="login_form" class="sign-in-form" name="login_form" method="post" action="https://alistapart.com?ACT=159"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="159" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="62e6138c60a63cc07797b91b41773386c46ceadf" />
</div>



		
			<fieldset>

		    	<legend class="center">Sign in to add your voice to the discussion.</legend>

				<p>
					<label for="login-name-here">Email (<a id="register" class="history-nav" data-tabto="forgot-password" href="/tools/register" target="_blank">Need an account?</a>)</label>
					<input
						type="text"
						id="login-name-here"
						name="username"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your email address?"
						data-tabmaster="true"
						data-tabto="login_password"
						required>
				</p>

				<p class="password-field">
					<label for="login_password">Password (<a id="forgot-password" class="history-nav" data-tabto="comment-submit" href="/tools/forgot-password" target="_blank">Forgot?</a>)</label>
					<input
						type="password"
						id="login_password"
						name="password"
						required="required"
						data-validate="onblur"
						data-type="any"
						data-isvalid=""
						data-error="What’s your password?"
						data-tabmaster="true"
						data-tabto="register"
						required>
				</p>
				
				<p class="screen-reader">
					<label for="honeepot">Don't put anything here</label>
					<input 
						type="text" 
						id="honeepot" 
						name="honeepot"
						data-tabmaster="false">
				</p>

				<p id="comment-submit-holder">
					<input 
						type="submit" 
						id="comment-submit"
						data-tabmaster="true"
						class="button primary float-left" 
						value="Submit">
				</p>

			</fieldset>
		
		
</form>
<script type="text/javascript">
$(document).ready(function(){
    $('#login_form').on('submit', function(event){
        event.preventDefault();
        if (!supports_history_api()) { return; }
        AlaAuth.spinnerStart();
           
            $.post(
                'https://alistapart.com?ACT=159',
                $('#login_form').serialize(),
                function(msg) {
                    AlaAuth.spinnerStop();
        
            if (msg.indexOf('You are now logged in.') >= 0)
            {    
           
                $.get('https://alistapart.com/ajax/comment-form/18898/article/progressive-web-apps-excerpt', 
                function(ret){
                    ajaxContainer.replaceWith(ret);
                });
                AlaPostLoad.loadTranslations();
                history.pushState(
                    states.commentform, '', states.site_url + states.segments + '/' + states.commentform 
                );
              
                } else {
                    var out = /<div id="ee-errors"><ul>[\s\S]*<\/ul><\/div>/.exec(msg);
                    if ($('.error-message.none').length == $('.error-message').length) {
                        if(out === null) {
                            AlaAuth.alertMsg('This form has expired. Please refresh and try again.');
                            $.get('https://alistapart.com/ajax/comment-form/18898/article/progressive-web-apps-excerpt', 
                            function(ret){
                                ajaxContainer.replaceWith(ret);
                            });
                            $('.custom-modal').remove();
                        }else {
                            AlaAuth.alertMsg(out);
                        }
                    }                   
                }
                return false;
            }
        );
        return false;
    });
});
</script>
    

		<script src="https://alistapart.com/components/assets/js/ajax-functions.js"></script>

		<script type="text/javascript">

		var states = {
			//globals
			commentsignin: 'comment-sign-in',
			register: 'register',
			password: 'forgot-password',
			commentform: 'comment-form',
			//segments
			site_url: 'https://alistapart.com',
			
			
			segments: '/article/progressive-web-apps-excerpt', 
			
			tmpl_path: /ajax/,
			entry_id: '18898',
			page: 'article'
		}

		</script>

		</div>

		<div class="placeholder loader">
			<div class="top-header animated-background"></div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<div class="label animated-background">label</div>
			<div class="field">field</div>
			<!-- <div class="button primary">Submit</div> -->
		</div>

	</div>
 

	<script type="text/javascript">

	AlaAuth.loadTemplate (
		states.commentsignin
	);

	</script>
	
	</li>

</ol>
							 

					</section>

					<aside class="column more-content">

						
						<h1 class="classy">More from ALA</h1>

						<article class="item-summary article">

							<h4 class="summary-title"><a href="/article/var-to-jit">var to JIT</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/kevinsmith">Kevin Smith</a>
							
							
							</p>

							<p>Through the power of JavaScript, we learn how the browser breaks down pages and speeds up processes so we can write better code.</p>

							<footer class="byline">
								
								
   
<a href="/topic/browsers">Browsers</a>



   

								·
								<time class="pubdate updated" datetime="2018-11-29T08:36:00-05:00">November 29, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/braces-to-pixels">Braces to Pixels</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/gregwhitworth">Greg Whitworth</a>
							
							
							</p>

							<p>In this installment of our &#8220;From URL to Interactive&#8221; series, Greg Whitworth explains how cascading actually works, and then some.</p>

							<footer class="byline">
								
								
   
<a href="/topic/browsers">Browsers</a>



   

								·
								<time class="pubdate updated" datetime="2018-11-15T10:05:00-05:00">November 15, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/tags-to-dom">Tags to DOM</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/travisleithead">Travis Leithead</a>
							
							
							</p>

							<p>Continuing our “From URL to Interactive” series, the second part dives into how HTML is parsed.</p>

							<footer class="byline">
								
								
   
<a href="/topic/browsers">Browsers</a>



   

								·
								<time class="pubdate updated" datetime="2018-11-01T08:45:00-04:00">November 1, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/from-url-to-interactive">From URL to Interactive</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/agustafson">Aaron Gustafson</a>
							
							
							</p>

							<p>The car lurches and loses all power. You coast to a stop, steam rising from the hood. So you think you know how browsers work?</p>

							<footer class="byline">
								
								
   
<a href="/topic/browsers">Browsers</a>



   

								·
								<time class="pubdate updated" datetime="2018-10-25T09:11:00-04:00">October 25, 2018</time>
							</footer>

						</article><article class="item-summary article">

							<h4 class="summary-title"><a href="/article/server-to-client">Server to Client</a></h4>

							<p class="aside-author">
							
							
							
							by <a class="author" href="/author/alialabbas">Ali Alabbas</a>
							
							
							</p>

							<p>Kicking off our &#8220;From URL to Interactive&#8221; series, we take a look under the hood to find out how our code makes it to the browser.</p>

							<footer class="byline">
								
								
   
<a href="/topic/browsers">Browsers</a>



   

								·
								<time class="pubdate updated" datetime="2018-10-25T09:10:00-04:00">October 25, 2018</time>
							</footer>

						</article>

					</aside>

				</div>

			</div>

		</article>



	</div>

			<footer class="global-footer" aria-label="Footer" itemscope itemtype="https://schema.org/WebPage">
			<meta itemprop="headline" content="A List Apart">
			<p class="deadly-subtitle" itemprop="alternativeHeadline">For people who make websites.</p>

			<ul class="inline-items" itemscope itemtype="http://schema.org/SiteNavigationElement">
				<li><a href="/about" itemprop="url">About</a></li>
				<li><a href="/authors" itemprop="url">Authors</a></li>
				<li><a href="/about/masthead" itemprop="url">Masthead</a></li>
				<li><a href="/about/style-guide" itemprop="url">Style Guide</a></li>
				<li><a href="/contact" itemprop="url">Contact</a></li>
				<li><a href="/about/sponsor" itemprop="url">Sponsorships</a></li>
				<li class="head-east-young-man">

					Follow us:
					<a href="/about/rss">RSS</a> ·
					<a href="/email-signup/">Email</a> ·
					<span itemscope itemtype="http://schema.org/Organization">
					<a href="http://www.facebook.com/alistapart" itemprop="sameAs">Facebook</a> ·
					<a href="https://plus.google.com/107749003388305496076" rel="publisher" itemprop="sameAs">Google+</a> ·
					<a href="http://www.twitter.com/alistapart" itemprop="sameAs">Twitter</a>
					</span>

				</li>
			</ul>

			<aside class="promo-holder" aria-label="A List Apart partners">

				<ul class="partner-promos">
					<li>
						<a href="https://abookapart.com">
							<img src="/components/assets/img/promo_aba.jpg" alt="A Book Apart. Brief books for people who design, write, and code.">
							<p class="promo-title">A Book Apart</p>
							<p>Brief books for people who design, write, and code.</p>
							<p>Bundle books and save!</p>
							<p class="arrow">Shop now</p>
						</a>
					</li><!--

					--><li>
						<a href="https://aneventapart.com">
							<img src="/components/assets/img/promo_aea_v1.png" alt="An Event Apart. Three days of design, code, and content for people who make websites.">
							<p class="promo-title">An Event Apart</p>
							<p>Three days of design, code, and content for people who make websites.</p>
							<p class="arrow">See  this year’s schedule</p>
						</a>
					</li>
				</ul>

			</aside>

			<ul class="inline-items copyright">

				<li>
					<small>ISSN 1534-0295 · Copyright © <span itemprop="copyrightYear">1998–2018</span> <span itemprop="copyrightHolder">A List Apart & Our Authors</span></small>
					<small><a href="/about/copyright">Permissions & Copyright</a> ·	<a href="/about/privacy-policy">Privacy Policy</a> · <a href="http://webtype.com">Fonts by Webtype</a><span class="logged-in"> · </span><span class="logged-out"><a href="/tools/log-in">Log In</a> · <a href="/tools/register">Register</a></span></small></li>

				<li class="affiliates head-east-young-man">
					
					<a class="ala" href="http://alistapart.com" title="A List Apart" itemprop="sameAs">A List Apart</a>
					<a class="aea" href="http://aneventapart.com" title="An Event Apart" itemprop="relatedLink">An Event Apart</a>
					<a class="aba" href="http://abookapart.com" title="A Book Apart" itemprop="relatedLink">A Book Apart</a>
					<a class="arcus" href="https://arcustech.com" title="Hosting provided by Arcustech" itemprop="provider">Arcustech</a>

				</li>

			</ul>

		</footer>

	<!-- <div id="bsap_1031" class="bsaPROrocks ad" data-serve="C67DL2V"></div> -->
<div class="sponsor-top">
    <a href="http://cloudinary.rocks/ala">
        <div class="sponsor-logo">
            <img class="banner-logo" src="/components/assets/img/cloudinary_vertical_logo_for_white_bg.jpg" alt="Cloudinary Logo">
        </div>
        <p>Want the best way to store and serve images and videos? Try Cloudinary. Get your own free account.</p>
    </a>
</div>

	


	


	<!-- facebook login: remove the fragment #_=_ that facebook adds to the redirect_uri | remove this after social login module update -->
	<script>
		if (window.location.hash && window.location.hash == '#_=_') {
		    if (window.history && history.pushState) {
		        window.history.pushState("", document.title, window.location.pathname);
		        
		        	window.location.hash = '#comment-form';
		        
		    } else {
		        // Prevent scrolling by storing the page's current scroll offset
		        var scroll = {
		            top: document.body.scrollTop,
		            left: document.body.scrollLeft
		        };
		        window.location.hash = '';
		        // Restore the scroll offset, should be flicker free
		        document.body.scrollTop = scroll.top;
		        document.body.scrollLeft = scroll.left;
		    }
		}
	</script>

	<script src="https://alistapart.com/d/_cache/e8952a1f4e9e5593cdc3ceff2271ef14a9300c64.1482327043.js"></script>

	<!-- Google Analytics -->
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-11757054-1', 'auto');
	ga('send', 'pageview');

	</script>
	<!-- End Google Analytics -->

	<!-- start Mixpanel --><script type="text/javascript">(function(e,b){if(!b.__SV){var a,f,i,g;window.mixpanel=b;a=e.createElement("script");a.type="text/javascript";a.async=!0;a.src=("https:"===e.location.protocol?"https:":"http:")+'//cdn.mxpnl.com/libs/mixpanel-2.2.min.js';f=e.getElementsByTagName("script")[0];f.parentNode.insertBefore(a,f);b._i=[];b.init=function(a,e,d){function f(b,h){var a=h.split(".");2==a.length&&(b=b[a[0]],h=a[1]);b[h]=function(){b.push([h].concat(Array.prototype.slice.call(arguments,0)))}}var c=b;"undefined"!==
	typeof d?c=b[d]=[]:d="mixpanel";c.people=c.people||[];c.toString=function(b){var a="mixpanel";"mixpanel"!==d&&(a+="."+d);b||(a+=" (stub)");return a};c.people.toString=function(){return c.toString(1)+".people (stub)"};i="disable track track_pageview track_links track_forms register register_once alias unregister identify name_tag set_config people.set people.set_once people.increment people.append people.track_charge people.clear_charges people.delete_user".split(" ");for(g=0;g<i.length;g++)f(c,i[g]);
	b._i.push([a,e,d])};b.__SV=1.2}})(document,window.mixpanel||[]);
	mixpanel.init("204b563994d022408e4b540a66fe6136");</script><!-- end Mixpanel -->

<!--Adblock Check-->
<script type="text/javascript" src="/components/assets/js/adchecka.js"></script> <script type="text/javascript"> jQuery(document).ready(checkAds()); function checkAds(){ if (document.getElementById('adsense')!=undefined){document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Unblocked', 'false',,true]);</sc" + "ript>");}else{document.write("<script>_gaq.push(['_trackEvent', 'Adblock', 'Blocked', 'true',,true]);</sc" + "ript>");}} </script>
<!--End Adblock Check-->

</body>
</html>
